MacBook Pro not finding roon Core on other MacBook Pro

Hi there, setup is like this

  • (DHCP): Internet Provider’s Modem+Router, Compal Broadband

  • (DHCP): Linksys EA7500 in Bridge Mode

  • (static IP): Synology with audio data, LAN connected to Compal Moden, Audio Data > Works

  • (DHCP): Android Phone with Roon App > Works, finds the core

  • (DHCP): MB Pro Mid 2014, High Sierra, WiFi, roon core running, with Linn Klimax DSM+Linn Majik DS as renderers > Works

  • (DHCP): 2nd MB Pro Mid 2014, High Sierra, WiFi, which I want to use as remote & audio output to RME audio interface > not working, does not find the core

On MacBook2 the “full roon” is installed (as well as the bridge, but it’s not running now). big roon is “Looking for roon core” forever. Entering IP of “core” MacBook1 does not help.

Firewall on both MacBooks is disabled.

Android App finds the core.

The goal is to have roon on one MacBook while using others as remote and/or renderers (RME audio interfaces), lus of course the Linn renderers.

  • Any idea to get this running?

  • How long is the searching for the core supposed to take?

  • Currently, both MacBooks are in Linksys’ Wifi, but the wifi access point should not matter, right?

Thanks for looking into this …


The Core at least should be wired in for reliability.

Thx Henry, it’s connected now: (DHCP): MB Pro Mid 2014, High Sierra, LAN, roon core running, with Linn Klimax DSM+Linn Majik DS as renderers > Works

Still the same: Android finds the core, 2nd Mac doesn’t.

OK. That is weird. Try addressing the support team direct @support, they have more experience of Mac gear than me.

The first step would be to confirm you can ping the core Macbook from the other Macbook, which can be done in the Terminal.

Pinging works. Thx guys.
@support Any hints? Am I missing something?

Rebooting your router may help too…

Hello @David_Holler,

Thanks for contacting support regarding this issue. This does indeed seem like some kind of firewall is blocking your connection to the main Macbook.

Do you by any chance have any other firewall blocking apps such as “Little Snitch” or “Bullguard” installed on the non-working Core? I would also double check to make sure that Roon is listed as an exception in your OSX firewall using these instructions from Apple and possibly even add the Roon exception again to that list.

Since you are using the second Macbook only as a Roon Remote, can you try to reinstall the Roon application for it if you have not done so yet? As a test, I would also temporarily connect both the Core and the Mac Remote to the Linksys router and then reboot your networking gear to see if that works as expected. Please let me know your results.


Solved. Thanks everybody for their tips so far!
I had no additional Firewalls like Little Snitch etc., but re-installing of the “remote side” did the job.
Ethernet connection or connection to the same linksys bridge was not necessary, btw.

@support There’s another interesting issue, which is not a dealbreaker to me but I thought maybe you might know:

Macbook2 (remote) is a clone of Macbook1 (core) – the MacOS partition has been cloned with Carbon Copy Cloner. After cloning, Macbook2 has been renamed.

As result, roon sees both Macbooks as one, listing only the core’s devices in the “connected to this mac” section on both computers. Settings can be changed on both Macbooks but are immediately updated on the other Macbooks “connected to this mac” settings.
(A 3rd MacbookPro in my home network – please don’t laugh – which is no clone is being properly shown in the “networked” section.)

I guess this is not intended behaviour. Any “quick fix” for this? Plan B would be a clean reinstall of MacOS.
Happy to provide more info if you need it to follow up …



Hello @David_Holler,

Happy to hear that the issue has been resolved by reinstalling your Roon Remote!

I have PM’d you a suggestion on how to get the Macbook2 recognized as a new Roon Remote, please let me know if it helps and if you’re in the United States, I hope you have a happy Thanksgiving! :slight_smile:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.