MacOS 10.15.5 Panic and restart

Hi, Running Roon as remote (control) on a 2017 i5 MacBook running Catalina 10.15.5.

Ever since the latest update (Roon’s) have the following issue: I leave home and also use the MacBook at work. If I don’t quit the Roon app, and it keeps looking for a core (obviously on a different network) 9-10 times my laptop is used at work, it freezes and restarts.

In the report generated from MacOS it is clear that the issue is with the Roon software. An obvious solution would be to quit the Roon app before I leave home, but I sometimes I forget, and anyhow I think this is a bug.

MacOS report as below

panic(cpu 3 caller 0xffffff801c24aa3a): Kernel trap at 0xffffff7f9f0b6100, type 14=page fault, registers:

CR0: 0x000000008001003b, CR2: 0x0000000000000000, CR3: 0x0000000145482143, CR4: 0x00000000003626e0

RAX: 0x0046000000000000, RBX: 0x00000000413a5440, RCX: 0x0000000000000000, RDX: 0x000c000100080001

RSP: 0xffffff9160e4b860, RBP: 0xffffff9160e4b960, RSI: 0x0000000000000000, RDI: 0xffffff801ca0b8a0

R8: 0x4005544161010011, R9: 0x0000000000000000, R10: 0x00000000400d5440, R11: 0x0000000000000000

R12: 0x0000000000080000, R13: 0x00080000fffff001, R14: 0x0000000000000000, R15: 0x0000000040055460

RFL: 0x0000000000010206, RIP: 0xffffff7f9f0b6100, CS: 0x0000000000000008, SS: 0x0000000000000000

Fault CR2: 0x0000000000000000, Error code: 0x0000000000000002, Fault CPU: 0x3, PL: 0, VF: 0

Backtrace (CPU 3), Frame : Return Address

0xffffff9160e4b2c0 : 0xffffff801c11f5cd

0xffffff9160e4b310 : 0xffffff801c258b05

0xffffff9160e4b350 : 0xffffff801c24a68e

0xffffff9160e4b3a0 : 0xffffff801c0c5a40

0xffffff9160e4b3c0 : 0xffffff801c11ec97

0xffffff9160e4b4c0 : 0xffffff801c11f087

0xffffff9160e4b510 : 0xffffff801c8c27cc

0xffffff9160e4b580 : 0xffffff801c24aa3a

0xffffff9160e4b700 : 0xffffff801c24a738

0xffffff9160e4b750 : 0xffffff801c0c5a40

0xffffff9160e4b770 : 0xffffff7f9f0b6100

0xffffff9160e4b960 : 0xffffff7f9ef9d51e

0xffffff9160e4b9a0 : 0xffffff7f9ef9da4f

0xffffff9160e4b9d0 : 0xffffff7f9efac67d

0xffffff9160e4ba10 : 0xffffff7f9f0bc706

0xffffff9160e4ba40 : 0xffffff7f9ef9b00b

0xffffff9160e4bac0 : 0xffffff801c85695e

0xffffff9160e4bb10 : 0xffffff801c854be7

0xffffff9160e4bb60 : 0xffffff801c85dcb3

0xffffff9160e4bca0 : 0xffffff801c2082b2

0xffffff9160e4bdb0 : 0xffffff801c125328

0xffffff9160e4be10 : 0xffffff801c0fbcc5

0xffffff9160e4be70 : 0xffffff801c112aa2

0xffffff9160e4bf00 : 0xffffff801c230d05

0xffffff9160e4bfa0 : 0xffffff801c0c6226

Kernel Extensions in backtrace:[D695D9DA-7C20-35D6-910F-E7A332A0F515]@0xffffff7f9ef94000->0xffffff7f9f058fff










**BSD process name corresponding to current thread: Roon**

Mac OS version:


Kernel version:

Darwin Kernel Version 19.5.0: Tue May 26 20:41:44 PDT 2020; root:xnu-6153.121.2~2/RELEASE_X86_64

Kernel UUID: 54F1A78D-6F41-32BD-BFED-4381F9F6E2EF

Kernel slide: 0x000000001be00000

Kernel text base: 0xffffff801c000000

__HIB text base: 0xffffff801bf00000

System model name: MacBook10,1 (Mac-EE2EBD4B90B839A8)

System shutdown begun: NO

Panic diags file available: YES (0x0)

System uptime in nanoseconds: 137938235352229

last loaded kext at 74697764015987: @filesystems.afpfs 11.2 (addr 0xffffff7f9fc9a000, size 364544)

Tagging @support and moving this to the Support section where it will get the proper attention.

Hi, Thanks for the move. No it was copied / pasted.

1 Like

Hello @Dimitrios_Mimis, and thanks for this report! I’ve passed this information along to our QA and development staff, and after their review and comparison to other kernel panic reports we have seen in the past. Our staff has determined that Roon itself is not at fault for this behavior as this type of issue cannot be caused by an app as it is a system-level error.

We also ask that you review the contents of this article from Apple’s support team regarding instances of this issue. We recommend that you reach out to Apple support with this trace and see what they say!

Hi. Thanks for the answer. While I understand your point there are three issues. 1st, in the Apple support article you ask me to review, it specifies that these restarts are caused by either a particular software, or some hardware attached to the Mac. As no hardware is attached, it therefore must be software related. 2nd, on the report issued by the OS, when it crashes, it clearly states the following: BSD process name corresponding to current thread: Roon (and its the only software mentioned in this report). And 3rd, when Roon is not running (as mentioned before, on a different network) this unexpected restart has never happened (Ever). While point 1 is obviously a speculation, points 2 and 3 are facts. Especially point 2, where in the crash report it clearly states that the process Roon is what generates the panic codes. Please look into it some more. Thanks again for your time.

Hi @Dimitrios_Mimis,

Nuwriy brought your question to my attention and I am hoping I can help clear some things up. We met with our QA lead and our CTO to discuss this issue last week and Nuwriy’s previous reply was based on their feedback.

While this error may be triggered by Roon, it is important to note that this type of error cannot be caused exclusively by Roon. Mac OS (and most modern operating systems) sandbox apps that are running, effectively meaning that the app can’t cause issues with the underlying system. Kernel panics are an error that happens at this underlying system level when low-level code on the OS level fails. Roon might be triggering something that exposes an underlying issue, but the issue itself isn’t from Roon, if that makes sense.

We haven’t been able to reproduce this error in-house, and we aren’t seeing widespread reports of this issue either, so it looks like something specific to the environment of your Core machine is doing something differently when Roon interacts with it, resulting in the kernel panic.

I’m sorry I don’t have better news for you here, Dimitrios, but I hope this helps to clarify what is occurring here. if you have any questions about the above please let us know!

1 Like


I have the same issue, but I am not able to reproduce it
@ Dimitrios_Mimis
Do you see the following in the top of the .panic reports?

Maybe it is related to the following?

My trace is more or less identical:

Kernel trap at type 14=page fault
Kernel Extensions in backtrace:
and top dependency:
BSD process name corresponding to current thread: Roon

I only have kernel panics since i installed roon (a week ago) 3 kernel panics till now, all stack traces contain the lines listed

@Sander_Puts HI. It hasn’t happened since initially posting this thread, but I now knowingly quit the Roon app on my MacBook when leaving home. (TBH I avoid using it all together and use an iPad or my iPhone for control). As stated, this issue presented itself ONLY when the MacBook was on a network different than the one the Core is on, AND the Roon app running. When at home, connected to the same network as the core, this does not occur. Underlying issue or not (with MacOS) this only happens when Roon is running (and away from core). Regarding the kernel panic bug you mention, its for Mojave, while I currently run Catalina and I was using Catalina with Roon prior to this. This started happening after the latest Roon update and not a MacOS update.

Hi, thanks for the additional info. Sorry for posting an irrelevant link, I run mac OS X 10.15.5 as well.Yesterday when the panic occurred I had indeed network issues and my core couldn’t be found when waking up the Mac from sleep. So far I am not able to reproduce the error, nor by unplugging network cables, nor by stopping the roon core. Maybe it requires the powernap to run. For now I will disable my Avast virusscanner, let’s see if that solves it. “Unfortunately” I am not experienced in debugging OSX panics :wink:

Currently I am positive that removing the Avast virusscanner solved the issue for me. No panics in the last 4 days.

From my stack trace I learned the following:

  • AppleMobileFileIntegrity part of the panic, did get an update recently.
  • The first loaded kexts entry in the panic report was Avast (not posted in this thread)

Mmmm just got a panic for the 4th time. Report looks different now, although the roon thread is still the trigger of the panic. After reboot my bluetooth devices did not work anymore. Had to reset NVRAM and SMC.

FWIW, I am getting panics with a very similar trace (2019 16" MacBook Pro). If helpful, let me know and I can paste the full trace. Needless to say, not a good thing when a laptop abruptly shuts down with a panic during a Zoom call.

Related to above experiences, I do not have Avast. I do have Carbon Black. I am running Roon as remote to a separate Roon server