MacOS keyboard media keys

Hello there

Did the option to activate the keyboard media keys on MacOS disappeared? I couldn’t find it in the option.

It now opens iTunes after updating Roon.

Hello @Gigatoaster ,

There is no need to activate media keys anymore, Roon has switched to using the systemwide Now Playing API.

Roon should appear in the Now Playing widget when the currently selected zone is actively playing audio. The media key controls should be routed to Roon when Roon is the active “Now Playing” app.

-John

Hi @John

Unfortunately, this is not working. Since updating to the latest version, I lost control of the keyboard media key. When pressing Play, it launches iTunes…before updating to 756 it was working. Any work-around?

Hello @Gigatoaster,

We’re using the official macOS API for this functionality, I’m running macOS 11.1 and have not run into any issues with Roon 1.8.

No workarounds that I’m aware of either. Certainly odd that it was working in 710 but not 756. We haven’t received any other reports of this.

Some thoughts:

A) What version of macOS are you running? Media keys should be using the now playing API on macOS 10.13+.
B) Try this test to see if the API is working correctly: Open Safari.app, go to YouTube, play a video, try using the media keys to pause YouTube playback.
C) Some other unknown application is redirecting media keys to iTunes.
D) When all else fails, try a reboot.

-John

Thanks @john for your help. Here are the answers to your questions.

A) 10.14.6
B) Play/Pause works on YouTube
C) Only Roon is used on this Mac.

I am very puzzled and unfortunately the wifi is not strong enough to use my phone as a remote.

Not sure if I should delete and reinstall. :pleading_face:

May I have more help, please?

Hello @Gigatoaster,

Can you take a screenshot of your “Now Playing” menu bar item when Roon is open and playing on your Mac?

The Now Playing menu bar item should look like this when clicked:

-John

Hi @john

I can’t see the icon:

I find that media keys work for a period of time but then Roon stops responding to them. Restarting the client resolves the issue but it would best if it worked all the time.

MacOS 11.4

Mine have stopped working since I flagged it. Sadly @support hasn’t came back to me since 5 months now. I don’t know why & what to do. Is there way to escalate?

Hi, I have the same issue. But for me only the “Play/Pause” button is not working.

Macbook Pro 2019 with macOS Monterey 12.1
Roon v1.8 build 884

I don’t think it’s a keyboard issue. I’m having the same issue with the Macbook Pro keyabord and the MagicKeyboard. “Previous” and “Next” working as expected. Only the “Play/Pause” is not working.
Any ideas what could be?

Still not working. :man_facepalming:

Not solving any bugs, but could solve the problem for some: Remember to check Roon in this system prefs pane for Roon (Security & Privacy → Privacy → Acessibility)

Hi @Gigatoaster / @CvK ,

We were not able to reproduce this issue in the QA lab. Can you please confirm if the media keys are working properly in other apps?

Hi @noris,

I tracked down my issue. It was not Roon’s fault. Another app was taking over control of the Play button (and just the Play media button).

So, everything’s normal for me. Thank you and sorry for my delayed response!

1 Like

Yes, the media keys are working for VLC, for instance.

I actually had exactly the same problem on my Macbook Air M1. It turned out that the problem was with VOX player - it took over control of media keys. I disabled it and after restarting Roon started to work!

1 Like

Hi @Gigatoaster ,

@Romtje 's situation sounds very similar to yours. When the media keys are not working in Roon, this is because some other app is requesting access to Now Playing and kicking Roon off the controls. The reason why VLC is not affected by this is that they use a depreciated method of controlling Now Playing. When your Media Keys are not working in Roon, you can check the Now Playing widget to see which app currently has control. Hope this helps!