macOS Monterey no longer sees external drives

Roon Core Machine

Apple Macbook Pro mid-2015, 16GB Memory, 512GB local storage
Monterey 12.2.1
Music stored on two external hard drives (4GB each)

Networking Gear & Setup Details

1Gbps/1Gbps fiber optic internet connection (AdTran wifi router)
Hardwired to router

Connected Audio Devices

Number of Tracks in Library

Over 200K tracks

Description of Issue

Roon is reporting that it can no longer access the folders on my external drives containing music. Roon will not let me navigate to the external drives. I’ve made sure that Roon has Full Disk Access in the Security & Privacy preference. This worked after my upgrade from Catalina to Monterey. Not sure when this stopped working.

Have you also checked that it has permission to access ‘Files and Folders’?

Roon had been granted Full Disk Access, but just to be certain, I removed Full Disk Access and enabled Files and Folders, making sure Removable Volumes was enabled, and restarted Roon. No change.

Can you confirm that your Mac can see both drives, i.e. that they are mounted and visible on your desktop?

And when you say that Roon won’t let you navigate to your external drives, do you mean that they’re not visible when you click “+ Add folder” in Settings → Storage?

If so, I’d suggest rebooting your Mac but would guess you’ve already tried that. If none of that helps, hopefully @support will be able to suggest something more useful.

The drives are mounted on the desktop, and I can browse them in the finder.
Roon will not let me browse to these drives. It used to.
I have rebooted a few times, after changing permissions, with no change.
These drives are NTFS, so are read-only on the Mac. I have just purchased an NTFS driver that allows the drives to be mounted read-write. That appears to have solved the issue, but now Roon is reindexing everything. With more than 200k tracks, that is going to take a while, but at least I can access the drives again. Thanks for your help @DaveN!

2 Likes

I’m not sure I did or said anything that helped, but I’m glad you got it sorted out :slight_smile:

The Monterey v12.2.1 upgrade must have caused this. It is a long story, but these drives were written on a Windows 10 machine, and formatted NTFS. macOS has a read-only NTFS driver built in, but it is bare-bones. Obviously something happened in Monterey to cause the issue. Adding in the $20 Paragon Software NTFS fully featured driver resolved the issue, and now allows me to write to these drives directly. Looking for a new way to store the music, some kind of RAID array probably. Don’t want to break the bank, but having a single device that holds all of the music (as opposed to the 2 4GB external I have now) will be much better.

Any chance you can reformat the drives to APFS and transfer the data? I know this would be a royal PITA but if the drives are functional at least you could continue using them.

1 Like

I use an 8TB Seagate Barracuda Pro, mounted in an Inateck enclosure. This is backed up to a cheaper 8TB drive in another Inateck enclosure, and also backed up using Backblaze. It’s not the cheapest solution, but it won’t break the bank.

1 Like

I’d need to purchase a third 4GB drive, format that to APFS, and use that an a holding drive in order to reformat. I could definitely do that, but feels like a bandaid to the actual issue of having two externals, neither of which are large enough to hold everything.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.