MacOS Roon Core discovery failing...suspect MacOS security policy

Core Machine (Operating system/System info/Roon build number)

Ubuntu 20.04.1 LTS - Roon 1.7 build 710

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Unifi firewall, switch, APs. Audio endpoints and Core wired, remotes wireless

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

various not really relevant

Description Of Issue

MacOS remote app is unable to locate the Core. This is a work machine and I suspect there is some policy in place preventing the discovery. I can ping the Core and ssh to it from the MacOS machine…simple network connectivity is not the issue. Everything else on my network connects to the Core fine (a Win10 machine, several iOS devices, etc). My work MacOS device used to work and then stopped. I’m curious what needs to be allowed inbound on the MacOS side for discovery to work successfully and I can go from there. Providing the Core IP to the MacOS discovery process does not help.

Hi @ProperlyDeafened,

Do you have any firewalls on the Mac you can try to temporarily disable or apps like Little Snitch, Bullguard, etc? I would also check the Mac firewall by using these instructions.

Hey @noris forgot to include that. I’ve previously allowed Roon incoming connections in the MacOS firewall and that doesn’t help. I’m blocked from editing it via corp policy but it’s in the list so shouldn’t be blocked. I don’t have any other app firewalls in place.

Hi @ProperlyDeafened,

Thanks for the firewall screenshot!

Since this is a work machine, it is possible that it has other restrictions in place.

You can try to perform a Roon reinstall to see if this will help:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location (on the Mac, not Ubuntu Core)
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

If this still does not resolve the issue, I would check with your company on what other restrictions are in place or use another remote that does not have these restrictions with Roon.

Thanks, I’ll try that. I’ve reinstalled the app but didn’t rename the existing Roon folder to force it to create a new one. I’ll try that…but as we suspect I think there is something else I’m not finding that is blocking the incoming connection on the discovery. Thanks for the help.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.