MacOS spin-loop Issue

Roon Core Machine

Headless Mac Mini, macOS Catalina Version 10.15.7
2.5 GHz Dual Core Intel Core i5
8GB memory.

Networking Gear & Setup Details

Ethernet via Telstra (Australia) modem/router.

Connected Audio Devices

Main connection is ethernet to RP4> Ropiee > Pi2AES hat > spdif > Audio GD DI-20HE interface > Musical Paradise MP-D2 Mk3 and onto the analogue section.
A range of other endpoints are enabled but the only other one I use is the BlueSound Node 2i from time to time.

Number of Tracks in Library

Using Tidal exclusively

Description of Issue

The system has been stable for a very long time. I downloaded the latest build (913) 36 hours ago. Nothing else changed in the system, except the update of Roon. Mac Mini immediately bogged down and became extremely slow to respond to commands. Nothing would play. I reinstalled Roon and it would play for a couple of seconds then seize up. The Mac Mini became hot to the touch. The issue went away when I quit out of Roon. I just started Roon up again with Activity Monitor visible and it’s showing over 100% CPU usage at all times.

Appreciate your help - let me know if you require further information.

Hi Michael,

Fellow user here. If you start up Roon, do not play anything, go to Settings Library, does it indicate that Roon might be re-analyzing your library? If so, try turning the audio analysis to OFF and see if that helps with the CPU usage.

Thanks for the suggestion Daniel, I followed your instructions and thought for a few minutes that the problem had been solved but alas, no. It will stream for about 2 minutes and stop. It will then become non-responsive with 120%+ CPU usage. When this happens screen sharing also bogs down, everything just grinds to a halt.

It occurs to me that I also have HQPlayer 4 Desktop version 4.17.1 on the core machine but I disabled it when I first had these problems so it is not in the signal chain and I wouldn’t imagine is a contributing factor.

Again, Daniel, I appreciate your interest.


Hi Michael. Have you tried looking the the Mac mini activity monitor (in the Utilities folder)? That should give you some idea of what application or activity is using up the Mac mini resources. I’m also running a Mac mini (M1) with Roon core with a very similar set up to what you describe and not having any issues. Only thing I’ve done in recent weeks is as a result of a memory leak in Roon was to schedule an automatic shut down the mini every night for a couple of hours and then auto reboot. This basically resets the mini at night when it’s not been used. BTW I believe the memory leak issue has since been resolved by Roon but I’m leaving the shutdown/reboot routine in place regardless.

My life & SQ got better the day I moved the core off my Mac Mini.

Thanks Brian - yes I’ve been using Activity Monitor to gauge CPU usage and it’s well over 100% most of the time. When I quit Roon everything goes back to normal. I have restarted a number of times over the last week as I’ve been troubleshooting, but to know avail. Thanks for the thoughts.

Hey Michael,

we are looking into the log and will get back soon.

Hi @Michael_Rowe2,

We’re sorry to hear about your issues here, we’d be happy to lend a hand! Can you let us know if you’re you still experiencing this problem on Build 918? I’ll be watching for your reply!

Thanks for reaching out, Jamie! I just deleted the Roon instal on what was my core mac and installed the most recent build. When it launched it immediately seized the whole machine up again. Nothing responding, spinning pizza of death, etc. Closed down Roon and the problem went away. I have repurposed my main Mac to be the core and it is working flawlessly, however any log you access remotely might well refer to this (functioning) machine. I’m still using the ex-Roon mac as host for my HQPlayer and it works fine. All other functionality on the ex-Roon mac works fine…until I fire up Roon.
Hope this is helpful!

Hey @Michael_Rowe2,

Thank you for the update. If you’re ok with having Roon Server on the alternate machine we can call this one a win. If you prefer to have it on the previous machine please try this.

We have a theory as to what is going on here and would like you to try something if you are willing. This won’t impact your library in any way or otherwise make a bad situation worse.

  1. Leave Roon closed on the Mac Mini
  2. Open Finder and click Go in the top bar
  3. Hold down the Option key (or Alt)(⌥) to unhide the Library folder
  4. Click the Library folder
  5. Navigate to RoonServer -> Database -> Orbit
  6. In that folder you will find three subfolders. Delete the one named orbit_v3.db
  7. Start RoonServer on the Mac and check to see if it remains stable.

This will reset an internal housekeeping system which may be misbehaving.

Please try the above and let us know if it makes an improvement. Thanks!

I’m happy to report that that worked, Jamie! Back in business.

Very grateful for your assistance.

Have a great day!



1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.