Main album sort order preference not being used when Qobuz is enabled

Roon core on macOS
Version 1.8 (Build 790)

I have set, that I want main albums under artist view set to the following

  • Album dates for sorting: Original release date

  • Album date sort order: Newest first

  • Sort order on “Main albums” is “Albums by release date” and “Sort by Date”

This works fine, when on an artist page, I see it in correct sort order with that artists newest album first.
But as soon as I enable Qobuz, it reverts that sort order to oldest first and I can’t change that back, which is a little annoying.
And if I disable Qobuz, sort order is right back as it should be.

I hope that this a bug and can be fixed and not by design.

I tried to click the sort order on the artists main albums page multiple times to reverse the sort order, and now it’s 100% stuck on oldest first and it’s impossible to get newest first, even with Qobuz completely removed. So something is definitely broken with the sort order in general.

And it’s the same on all viewers, Android, iOS, macOS, even with their individual setting set to show newest first.

Hi @Peter_S

I’m passing this along to the QA team to investigate further. Can you share some screenshots of what you’re seeing as well? Thanks!

Here are some screenshots.

This is settings on macOS (same settings on iOS and same behaviour as well)

As you can see everything is set to show newest first.
And this is the settings on album area of artist

And no matter how many times I press on date it does not switch between newest/oldest. And it did work at one point because I always had it showing the newest albums of the artist first and hitting date it switched to oldest, but no way to get back again.

And I can’t get the error with Qobuz anymore as it’s totally stuck on showing oldest first now constantly, no matter what I try. But that error was there when enable Qobuz it was stuck on showing oldest first, disable Qobuz and it was back to newest.

Have you tried to press on the arrow instead of the text label (“Date”) and then click outside the dropdown to close it?

Ohh man do I will stupid now, yes clicking the arrow itself does what I expected clicking on the word “date” would. So when it got stock on oldest, I must have hit the arrow by accident… Doh !

Gui wise, I don’t know why that was not obvious for me, but thanks so much for pointing that out.

I tested enabling Qobuz again and it does switch it back to sorting by older, but now I can switch it back to newest, so it’s all good.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.