Manage audio-no devices Audio-GD NOS 7 DAC Amanero Combo 384

Hi @support
Windows 10, 64 bit on a recent Asus laptop
Two DACs: North Star Design Venti + Audio-GD NOS 7
I have no media other than Tidal with selections on ‘My Albums’ recovered in Roon.
Problem: the Venti is enabled and works just fine (unless a Windows update blows things sky-high, in which case I restore the earlier version). But the Audio-GD is anomalous: installed in place of the Venti, enabled, and set for Amanero Combo 384, all is fine; but after having been powered down, as soon as it is turned on Roon recognizes no devices, the Audio page blinks on and off, all devices marked as ‘enabling’.
BTW, Tidal accepts the Amanero, so at least, with the Audio-gd in the system, there is music.
Any advice?

Many thanks

Thanks for reaching out, @edward_swiderski!

So we can better understand what you’re experiencing, please verify the following:

  • Can you confirm that you have the latest firmware and drivers installed for the Audio-GD?
  • Do you have any active firewall or antivirus on the Core machine. If you temporarily disable them, is there any change in behavior here?
  • Do you have a different device available that you can connect this device to with Roon? If you connect it elsewhere does the same behavior occur, or only with this Windows machine.


Hi Dylan,
I just discovered that I had enabled two different drivers for the Audio-gd NOS 7. I am experimenting by disenabling one of them. Will be back in touch once my experiment delivers some kind of protocol.
Thanks for your response and requests for more info.

best … edward

1 Like

Here is the situation at this stage:

  1. In case I insert the North Star ‘Venti’ all is fine when using Roon
  2. Removing the Venti and inserting the Audio-GD NOS 7, without shutting down the computer, Roon immediately picks it up and all seems well
  3. However, when I shut down the computer and the system as a whole, and after some time restart, Roon knows not what I want - no devices are recognized, the ‘Audio’ page blinks incessantly.
    To your questions:
  4. I believe that I have the up-to-date drivers (it appears that disabling one of the drivers for the NOS 7 has had no effect), but I am researching the matter
  5. Am not sure what you mean in asking about a firewall or anitivirus ‘on the Core’ - The ‘core’ is the PC I am running, correct? In that case, yes - I use Trend Micro
  6. Another device: my description of the performance of the Venti shows that it is the interface of the Audio-GD and Roon that is the issue.


Hi Dylan,
I corresponded with Audio-gd in China and they suggested the simplest of changes - to try another usbport … which I did, and everything was suddenly fine … the manage audio and no devices messages were gone. But then I did something silly … navigating around in Audio I foolishly engaged enable for JRiver 23: it is no longer a program on my computer after I upgraded to 24. As soon as I made the mistake, Audio dropped out, the blinking and enabling thing began, and nothing I do makes a difference.
Have I created a dysfunctional state - a missing and a present version of JRiver at odds with each other, so to speak?
I would be grateful for some guidance …

Hey @edward_swiderski,

Is there any difference if you temporarily disable Trend Micro?

In your Windows firewall settings can you verify that you’ve entered exceptions for Roon and RAATServer?

Since the above have you tried power cycling the Core machine?

If you change USB ports again do you notice any difference?


I’m sorry to be obtuse … but what is ‘power cycling’? - Restart?

Sorry, @edward_swiderski, I should have been more clear there. Yes, I meant reboot the machine.


Just, tried that more than once … and switched back to the original usb port - no change.
Is my ‘theory’ of a struggle between the phantom JRiver 23 and the bonified JRiver 24 mere fantasy? To repeat: things appeared to be going well until, stupidly, a engaged ‘Enable’ for the 23 version - then all was lost

Hey @edward_swiderski,

If you disabled JRiver 23 and it is still happening, I don’t believe that should be the case, but there is a test we can do to confirm whether or not it affected anything. Please follow the steps listed below and let me know if there’s any change:

  • Make a backup
  • Shut down your Roon Core
  • Locate your Roon database according to these instructions
  • Rename the entire Roon (or RoonServer) folder to roon_old
  • Relaunch Roon, sign in, and configure a new install
  • Let us know if you see this database error again

After the test you can return to your current database by changing the folder name back to Roon, replacing the new folder that was created.


Before I attempt to implement the procedure you advise - not for a week or so since I will be traveling as of tomorrow - I should say that, with respect to JRiver 23, I did not succeed in disabling it following the error I describe above. The Audio page will not cease blinking, there is no access to any of the devices, I can Neither enable Nor disable … Is there some way of making this stop in advance of, and independently of, the procedure you outline?


Please disregard the last question … i simply installed my other dac, it works flawlessly, and disabled JRiver 23 … am too tired now to retry the Audio-gd. When I do, I will let you know if I recover it on the other usb port, as Kingwa advised.