Manually adding ffmpeg does not work

Roon Core Machine

5.0.0.1850 / TS-251+ / Celeron J1900 up to 1993 MHz 4 cores / 4GB

Networking Gear & Setup Details

QNAP connected by ethernet via Netgear 5 port switch and dLAN 500 duo pair to Airport Time Capsule which connects to Virgin Super Hub 3 and Virgin 500Mb internet connection.

Roon Remote on iPhone 12 and on MacBook pro connected by WiFi to either Airport Time Capsule or Super Hub

Connected Audio Devices

Arcam Solo Uno and Apple TV via WiFi. Linn Majik DS streamer via ethernet to the above fast switch.

On the same switch above are also a Virgin Media cable TV box and an Arcam AVR450 receiver. An LG smart TV connects to the second port in the Duo.

Number of Tracks in Library

15,000 tracks

Description of Issue

In order to improve performance of the Roon core I added a 64Gb Samsung SSD to the USB3.0 port on the back of the QNAP and transferred all the RoonOnNAS folders across to it.

All fine, and I could see the speed improvement. However, the Roon Server will no longer recognise the ffmpeg file transferred with the folders, it was in the bin folder. I’ve removed it and added it, restarted Roon, removed Roon and installed it again, etc. But it will only recognise the built in version.

It seems to me the system has also become unstable, whether due to the Roon or not, where the NAS suddenly cannot be found on the network and has to restarted. I then had the problems of Roon not playing tracks from Qobuz and in the end i had to restart the QNAP and restart the Virgin Super Hub to get everything back working. As I write the same thing has just happened and I suspect I may have to restart everything again.

Please advise - is there a problem in QTS 5 using a manually added ffmpeg file when the Roon database is on a USB SSD?

Many thanks

Chris

1 Like

Chris it might be worth looking at the following….

Hi @Chris_Jenkin1,
I was away on the weekend, but already noticed your post. Being home again, I checked with my QNAP once more and could not identify an issue.

So to get to the bottom of the issue, could you check the file RoonOnNAS.log.txt which is inside of the RoonOnNAS folder of your selected database storage folder?
There should be an entry for the used ffmpeg version. On my log file I could read the following:

############### Used FFMPEG Version ##############
ffmpeg version 4.4.1-static https://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2021 the FFmpeg developers built with gcc 8 (Debian 8.3.0-6) configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --disable-ffplay --disable-indev=sndio --disable-outdev=sndio --cc=gcc --enable-fontconfig --enable-frei0r --enable-gnutls --enable-gmp --enable-libgme --enable-gray --enable-libaom --enable-libfribidi --enable-libass --enable-libvmaf --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librubberband --enable-libsoxr --enable-libspeex --enable-libsrt --enable-libvorbis --enable-libopus --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libdav1d --enable-libxvid --enable-libzvbi --enable-libzimg libavutil 56. 70.100 / 56. 70.100 libavcodec 58.134.100 / 58.134.100 libavformat 58. 76.100 / 58. 76.100 libavdevice 58. 13.100 / 58. 13.100 libavfilter 7.110.100 / 7.110.100 libswscale 5. 9.100 / 5. 9.100 libswresample 3. 9.100 / 3. 9.100 libpostproc 55. 9.100 / 55. 9.100
##################################################

It indicates it uses the ffmpeg binary which is located in the RoonOnNAS/bin folder of your selected database folder.

The version should also be indicated in the Roon Server web ui on QNAP when hovering over “ffmpeg: User supplied Version”:

When using an external ssd, there should be no difference in the process.

To my knowledge, there is no issue with ffmpeg on QTS 5. But there are indeed issues with the latest build of Roon Server, which is currently being investigated by the Roon team.

Many thanks for this - the log file shows it is using the system version of ffmpeg, whether I put the new ffmpeg file in the bin folder or not. And the web UI confirms it is using the system version whatever I do.

I will try going back to using the built in disks to check all works there and report back.

ok. Just for clarification: You’ll need ffmpeg for the amd64 architecture. When you download it from johnvansickles page, you’ll normally need to extract the archive at least once and sometimes twice (depends on the used application for this process).
You only need to copy the file ffmpeg into the RoonOnNAS/bin folder.

When done, you have to restart Roon Server in the app center in order to make use of the new provided ffmpeg.
:wink:

1 Like

OK - so I used the AMD64 ffmpeg, no change. The UI still shows Roon is using the system ffmpeg version.

I then stopped Roon, moved the entire 5Gb RoonOnNas database without change back from the plug-in Samsung USB SSD to where it used to be, in my Media folder on the main QNAP storage, restarted Roon, used the UI to change to the new database location, restarted Roon and the UI showed that it was now using the user supplied ffmpeg.

So there is clearly a problem with having the database on an attached USB device, maybe I need a different device, or there is a system setting somewhere that needs changing.

Anyway, I hope a solution can be found and I can move the database back to the SSD with Roon Core correctly using the user supplied ffmpeg.

Thanks

1 Like

And just to add that it was a job and a half getting Roon working after all this - the database move seemed to corrupt something. Had to start over, fortunately not so much lost - had to set up all the audio devices again. Now listening to calming Radio 3!

Out of curiosity, are you still having this issue with the new builds? My gear is similar, and I’m using a USB ssd drive for the database. I’m able to update my ffmpeg but the system reverts every night, forcing me to retsart the service if I want to play Live Radio or mp3, etc.

What’s the difference in performance when the database is on the NAS disks? If it’s not terrible, I might try to migrate it back to the NAS so I don’t have to restart Roon every day.

I gave up trying, put the core back on the NAS discs and focused on improving the network instead.

So now, apart from the well reported but yet to be fixed (by Arcam) problem with the Arcam Solo Uno volume control via Roon, Roon loses the Arcam perhaps once or a couple of times a day, and finds it again a few seconds later. Otherwise the performance is fine at the highest bit rates. I could replace the disks, or one of the RAID pair, with SSDs, but at a few £100 I am not convinced it is a) worth it and would b) fix the remaining issue.

One thing I have observed - I’ve grouped the Arcam with my Linn streamer and an old Apple TV device to stream as a single airplay zone. I don’t often use it, but if I do, and then revert to streaming to the Arcam via RAAT, the Apple TV device going back to sleep upsets things and Roon loses the Arcam.

Maybe!

1 Like

I’ve got this issue as well, also on a TS 251+, also with the roon software on an external SSD drive. I had it previously working with these devices, but due to a long story, ended up reformatting my SSD, reinstalling Roon, and when I add the new Jogn Van Sickle ffmpeg to the proper folder and reboot, it still doesn’t function and in the app center Roon application, still shows me as using the 3.3.6 system version. Any new news / thoughts on how to fix?

Hi Mark - no, sorry. I gave up. Performance is OK with the QNAP spinning discs, and even the Arcam Solo Uno is not dropping out as often at the moment. My only thought is whether it depends on what kind of plug-in SSD is used. I just used a USB stick, but maybe something else is needed. Chris

1 Like

@crieke
Any thoughts or advice on this?

Nothing further tried at the moment.

I have exactly this problem. Moved to a Samsung SSD for database. Tried putting ffmpeg into RoonOnNas/bin. It still picks up version 3.3.6 (system version?).

which ffmpeg do I need? I have QNAP T235A but Roon Server is on the Samsung SSD. I have tried the AMD and the i686 but neither get picked up. Ideas welcome as I have many .m4a files.