Manually configure public IP or URL for ARC

I can’t use port forwarding because my ISP doesn’t provide me a public IP. I want to try other approaches, such as a VPN with an outside machine that does have a public IP, but I’ll need to specify a different IP than the one Roon thinks is my public IP. Specifying a URL would be better. Is there a way of doing that?


It’s not possible right now to specify the IP in ARC.

There really should be some way to do this, specify the IP address.

It may be that ARC refuses to work when it sends requests to one IP and gets responses from a different IP. Response IPs can be spoofed. So it simply sticks with the IP it saved during ARC setup.

Yes, but that only supports one use case. I want to enable ARC use in my LAN, not my WAN, just to try it out. Can’t do that, as Roon insists on using my external ISP-provided IP address and punching a hole in my firewall for it to connect.

So sad. Thank you.

With a VPN, or a similar solution, the responses would come from the same IP as the requests, just not the one Roon is determining.

I can use ARC within my LAN. It worked automatically at the first try. But, have no use for it.

ARC setup does require external access, but it seems ARC works on LAN just fine, even if ARC is misconfigured or even disabled. I just tested this by setting ARC port to zero. The ARC app is still working.

1 Like

Roon needs to see that particular IP when authorizing the core and configuring ARC.

Interesting. I figured since the setup didn’t work, it wouldn’t be active. I’ll try it.

If you want to test ARC, just turn off wifi on the phone and it’ll have to go through cellular.

I want to test it on my LAN, without punching a hole through my firewall.

Makes sense. Just set the port to zero.

That works. Thanks!

Dart/Flutter, eh? I’m suddenly feeling much much better about this, because this framework makes it easy to deploy Web apps, too.

Hi @Carlo_Patargo,

Thank you for your patience and please accept my apologies on behalf of the team that you’ve waited so long for an official response here.

There are several VPN workarounds and proxy server solutions that users have started to test out in the #tinkering and #roon sections. I suggest you take a look into this thread, for example. Note that VPNs aren’t officially supported by Roon, so the support team can’t help you out directly; however, many other users will be able to provide assistance.

That said, we’ll want to try everything possible to get port forwarding working with your current ISP tier and subscription. If you don’t mind, who is your ISP? It’s possible that their carrier-grade NAT isn’t implemented in a way that fully prohibits port forwarding, and there may be steps you can take independently to possibly allow for mobile ARC playback via manual port forwarding configuration.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.