Marantz NA8005 disappearing on Allo USBridge

Same problem here.
Yesterday the DAC (Marantz NA 8005) was found. see below (I named it All DAC2)

Today its gone see below

Love to hear your suggestions.

Indeed, there is no issue with seeing them and playing back to them directly to the core. Ik will check the firmware. But isn’t it strange that everything worked well last 5 days and suddenly its gone?

Hi @Jan_Willem_Bootsma,

Just to confirm here, you have rebooted your Core, Allo and Marantz already and the behavior is still the same? If it worked well in the last 5 days and the issue is just now occurring I am wondering if this could perhaps be an issue with the hardware side of things, USB cables and Ethernet cables do fail sometimes so I would like to ask if you can try another cable and also make sure that the newest firmware is being used on the DietPi.


Edit: I have also split up your posts from the previous threads so that we can address this specific issue better.

Hi Jan,
For me, what ended up happening was the Roonbridge in the gui became deactivate. I don’t know how because it was active when i first checked it. The other solution for me was to plug in my benchmark dac to my computer and update the usb 2.0 driver. Yours seems to be a slightly different problem than mine though.

Hi Noris,

System is working again!
I updated dietpi 6.21 (was 6.20). I don’t think the update did it. I think rebooting did it. Could this be due to failing cables? Or perhaps something else? My ethernet is not always 100% stable. Could this be causing the problem. Things are running now with the same (perhaps bad) cables.

Hi @Jan_Willem_Bootsma,

Glad to hear that everything is working again! Since your screenshot displays the Allo Bridge just fine and the Marantz has disappeared, I would suggest replacing the USB cable from Allo -> Marantz as the first step here.

You mention that the Ethernet is not always 100% stable, in what regard is this? If the network itself is unstable, that can cause some strange behavior, I would definitely suggest taking a look over our Networking Best Practices Guide in case it helps you identify any areas of improvement on the network side of things.

I believe the DietPi update and swapping out USB cables will have helped you here but if you experience this issue again do reach out to us.


Hi Noris,

Just shut down bij networkplayer with the DAC (Marantz NA8005). When I turn it on the dac is gone again in Roon. Same problem as before. I am getting a bit annoyed. I am going to replace the USB cable. to be continued…

… and rebooted dietpi and its back again.

I have a different behaviour with mine. When I switch off the NA8005, it disappears as an endpoint. The Allo bridge remains visible (I still see 3 atm7059_link entries in the audio settings).
When I turn on the NA8005 again, it appears right away as a zone with the NA8005 entry in the settings under the Dietpi.
My Dietpi version is probably older. In the settings I notice: DietPi - Linux 3.10.38

Hi @Jan_Willem_Bootsma,

Is this still the same behavior after replacing the USB cable? I would also take a look at Dirk’s suggestion that the NA8005 is powered on before attempting to select it as a zone.


I replaced the USB cable 7 days ago.It seems the new cable does the trick. Continuous connection between between the Allo USBridge and the Marantz NA8005.

Thanks guys!

Jan Willem

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.