Maximum sample rate for Squeezebox Touch?

I have Squeezebox Touches. I would like to set Roon to downsample 192 kHz files to 96 kHz for those players, but in settings, I can only set a 48 kHz sample rate for the Touches. What gives?

The only solution I see at the moment is to make downsampled copies of the files in question and move the full-res versions out of the music folder - not so great.

Down the road, I’ll need to look into making the enhanced digital output plugin work with Roon. But in the interim, it would be much easier just to be able to set max sample rate and have a solution in one click.

Could it be because they only do a maximum of 48K

No, they do 96K.

That’s strange I get the following options

Have you the latest firmware etc. installed?


7.8.0 on one and 7.7.3 on the other.

So at least on the one with 7.8.0, we should be good.

The documentation says that Roon requires 7.8.x to work with Enhanced Digital Output, which would be another answer to this issue. Both Touches almost work with EDO. They play for a few seconds, then lose sync. Given that they’re made of unobtanium, I’m loathe to speculatively fiddle with their firmware, but if somebody knows for sure that a particular firmware version is solid with EDO and if I switch to Roon, I’d go that way.

I am running version 7.8.0 r16754 on my SB Touch and it works beautifully with Roon, the EDO plugin, and my Meridian 818. Do make sure you install stuff in the right order - there is a good set of install instructions at the top of the EDO thread on the slimdevices forum here.

Good to know.

I’ll investigate further and report back.

Very strange.

In the SB system, the endpoint HW and server are supposed to communicate so that the server knows the max sample rate it can send to each device (some older SB devices are limited to 48K, for instance). The server should be able to send different max sample rates to different devices, if needed. The Touch should be telling the server it can do up to 24/96 (without EDO) and 24/192 with EDO.

The question is either: a) your Touch is somehow setup to do max 24/48 in its settings and is announcing that to the server; b) you’ve somehow setup your LMS software on the server or the OS on the server to send content at a rate no greater than 48.

EDO is just a plugin for the touch. If you don’t like it, you just do a factory reset and it will be deleted\erased when the Touch reboots. No harm to the Touch. IME, SB devices work best when they are updated to match the LMS server software they are connected to. Usually your Touch will tell you if it needs an update. Check the settigns.

That said, if I was you, I’d try to get my setup working at 24/96 without EDO. That’s what it should do, and I’d fix that before adding EDO into the mix and complicating things.

If you have 2 Touches up and running with different capabilities, and are streaming to both simultaneously, this could cause a problem. In general, the SB system will default to the lowest common denominator for streaming file rate if it is streaming to 2 different endpoints with different capabilities.

Disconnect the one with 7.7.3 and see if you get 24/96 on the other. You might have to restart the Touch and the server for the system to “figure out” the change.

Both Touches work fine with LMS. It’s with Roon that things get dodgy.

So… I unplugged the Touch with 7.7.3. Looking at the one with 7.8.0 (which does have EDO):

Roon, in its sample rate limit dialog still only offers rates up to 48 kHz.

With the Touch set to digital output only (which enables 192 kHz), 96kHz files will play for about one track, then just noise. 192 kHz files don’t play at all. Just noise. After that first track, 96K files would only play a few seconds in. I tried power cycling the Touch and trying first the 192K and and first the 96K one. Behavior was the same in all cases.

Roon had been playing fine with both Touches set at analog plus digital output (which is, I believe, the stock SBT kernel.) In this mode, the Touch will stream up to 24/96. Not surprisingly, 96K files played fine. 192K ones didn’t.

For a baseline, I stopped RoonServer and started LMS. The Touch worked as expected. 96K files played fine in analog plus digital, and all files up to 192K (FLACs, that is) played just fine in digital only.

AFAIK, the downsample to a client feature is server-side. There is no setting on the Touch to invoke it. (Unless maybe you run the server on the Touch, which you can do. I guess. Never have done that.) Frankly, I don’t remember how it works in the LMS interface, but it’s obvious from behavior that it’s not invoked in my LMS. And - obviously - what’s in LMS doesn’t affect Roon at all. No downsampling is invoked in Roon. That’s where this thread started :slight_smile:

And more strangeness…

I have a third Squeezebox, an SB3 in the kitchen. I decided to point it to Roon to see what would happen. Roon recognized it just fine. In its settings dialog, there was no offer to downsample. Well, OK, maybe that’s just assumed for an SB3, since it doesn’t do hi-res at all. No biggie. Long story short, Roon wasn’t able to stream to the SB3. The VU meters in the Roon logo screen moved, but no sound.

So, after a lot of ssh-ing to the two servers, turning them on and off and pointing the SB3 this way and that, I decided to see if the LMS and Roon servers would coexist. And…

It APPEARS to work!

At least based on a half hour of fiddling around, it looks like the I can run the SB3 on LMS and the Touches on RoonServer. It doesn’t look like the Squeezeboxen can remember two servers and switch in a single menu click, but it does look like you can go to the setting in the Squeezebox for the IP of the server and change the IP, without power cycling the Squeezebox. In my case, the two servers are running on boxes with adjacent IPs - xx.xx.xx.9 and xx.xx.xx.10. So, it’s pretty easy.

This is big for me because it gives me an out when I run into a functionality blocker in Roon.

I don’t know if there’s a thread on running both servers simultaneously. If so, maybe the mods should cross link…

Oh, and Joel, what version of the server are you running? What OS? I wonder if the difference is there. Maybe functionality isn’t exactly standardized OS to OS. I gather that the Linux server was just recently released. Hmmm.

Hi @Carl_Seibert. Roon doesn’t support running an instance of LMS on the same network (at the same time) as the Roon Squeezebox “server”.

Hi Joel,


As far as keeping things straight from the clients’ point of view, multiple SB servers (which is what the clients would see if they could see, but they can only see one at a time anyway.) is okeedokey as far as Squeezebox is concerned:

The only common point between the two servers is the data store. Roon - in my case anyway - sees it read-only. So Roon can’t do anything bad to LMS. If LMS were to write constantly, or very often, to the data I can see how that might put Roon in a tizzy. But as far as I know, LMS doesn’t do that. (According to their forum, LMS can run if its user has only read-only access to the data, so I guess it never writes there at all - which is as it should be!) So all should be good.

Unless I’m missing something…

Then there is the semantic (and resources and ,sigh, liability) matter of “supports” vs “what works”. Best to keep in mind that users usually only end up in “what works” territory when they are trying to work around some piece of functionality that isn’t working in the first place. A “what works” workaround can often be the difference a successful implementation (and sale) and a failure. Thus, a mechanism for “un-support” can be critical.

@Carl_Seibert Please bear in mind that Roon is not LMS; it implements what it needs to, to achieve audio streaming (which it does very well), and that’s about it. Interoperability with other LMS instances is not expected, nor guaranteed.

Okay, but why not help him with his original question: why, when using Roon, is all his high res material downsampled to 48K before it is streamed to his SBTouch devices - a behavior that doesn’t happen if he runs full scale LMS with the same endpoint HW.

Dropping a flag for @Eric.

@Carl_Seibert Please bear in mind that Roon is not LMS; it implements what it needs to, to achieve audio streaming (which it does very well), and that’s about it. Interoperability with other LMS instances is not expected, nor guaranteed.

Funny you should put it that way, since not achieving audio streaming is the problem I was trying to work around.

I suspended testing running the two servers side by side because it introduced an extra variable to looking at the underlying issue. More later, if it turns out I still need a workaround.

As for the issue at the top of this thread, indeed, the problem appears to be server-side, in my Linux version of RoonServer. When I stopped the server and ran a Roon Core on my Mac laptop, the limit sample rate dialog looks like the one in the screenshot above. 96K is available as a choice. AND the underlying issue of high res files not playing properly seems to lie there as well. I’ll fork discussion of that issue to another thread.

I was running EDO some time ago, but long ago installed the ‘Toolbox 3.0’ firmware upgrade, now long ago, unsupported. I see that I only have a two options for bit rates 1. disabled 2. 48k