McIntosh USB bug fixed


(Christoph Longree) #1

… anyone using McIntosh (C52 in my case) may have experienced the problem that the DAC mutes the first second when addressed via USB connection… I had my C52 serviced and the software update installed - problem was fixed by this.

Just thought it might be interesting 4 people having the same issues (reported several times here)…


(Mike Ormerod) #2

I have a C52 also and have the issue. Do know what the fix was/is ? What is your firmware version now?


#3

Have a MA9000, it has the same DAC-module (DA1). Just upgraded my DAC firmware to the newest 1.02 - all existing problems are gone :grinning:

Remark: System-fimware and DAC-firmware are 2 different things. And: Self-updating does not forgive mistakes.


(Christoph Longree) #4

… I had mine sent in for the service…


(Mike Ormerod) #5

I understand but it would be great to know the firmware version in your C52. Mine is 1.06.


(Christoph Longree) #6

Hi - I`ll check next week and let u know… :slight_smile:


(Mike Ormerod) #7

I still have this issue and McIntosh support is being less than cooperative. I’d love to know what was fixed @Christoph_Longree when your unit was serviced. Anyone else with a C52 having the issue? I’m pushing them to update the firmware to add the same USB Automute setting that is exposed in other models which allows you to turn off the feature.


#8

I upsample via noon to dad 64 and there are no issues with dac muting or strange noises. I turned off the usb mute feature. I use a mcintosh d1100.


(Christoph Longree) #9

Some Software Update - but I‘m in Germany and the Distributor (Audio Components) took care of it…


(Mike Ormerod) #10

The key here is ‘I turned off the usb mute feature’ - Unfortunately, that option isn’t on the C52, which is what I’m trying to get McIntosh to add to the C52 firmware.


#11

I did not know that. Seems like a reasonable request to Mcintosh.


(Julien Boissard) #12

Hello, did the service fixed the problem ? What is your firmware revision? I am having V1.06 on my C52 and still having the mute issue.


(Mike Ormerod) #13

Nope :frowning: Even worse they claim it’s not something that could be simply fixed by a new firmware that could be customer installed. Have you contacted McIntosh support? It would be great if they heard from other people to see if we can somehow force them into action!


(Julien Boissard) #14

Here’s the answer I got from McIntosh:

Message:

Hi Julien,

Digital signals have a bit in them that tells the DAC what format is, it takes the DAC a second to figure it out. If the DAC decodes wrong because formats changed, and it has not seen the bit yet, a burst of noise will come out for a half second or so until the DAC switches decoding modes. So, DAC’s mute for a second to avoid this.

If you play a CD, you will notice that tracks typically have a couple seconds of silence and the music starts at about 0:02, not 0:00. Many download files have forgotten about this and start music at 0:00.

If your music player can be set to insert a little silence between songs, that issue should be solved.

End of message

After thinking about it, I can understand that if the audio as to be synchronized with video (if there is a video source at the same time), I could understand that they need that time to switch to the correct encoding type and keep it synch with video…

I have the C52 for two weeks now. I think I can live with that…


(Mike Ormerod) #15

I got the same response, which quite frankly is awful! I also experience the issue when not changing formats. No other DAC that I’ve owned previously has had this issue. McIntosh should fix this rather just passing folks off with standard replies.