Media import stalls

Core Machine (Operating system/System info/Roon build number)

2015 Mac Mini 512GB SSD Samsung evo pro 16GB ram Catalina

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet connections through TP-link rack mount 24port switch. Synology RS816 All devices are on the same subnet. Roon controllers connected to network via Ubiquiti Unifi AC Pro access point.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Raspberry Pi 3 - Hifiberry Digi+ pro Optical connection to stereo, Ethernet connection to TP link switch.

Description Of Issue

Upon setup I configured the roon core to use a NAS share. The nas share has an account specifically for the roon core with read / write access. The first attempt the core scanned 21+ thousand tracks. 1680 imported and 1680 identified. I let this sit for a day or so, then tried the instructions posted by Eric Stewart here This yielded slightly better results as i was able to import 5609 tracks. But again, this paused and roon started analyzing the tracks. I though it might be breaking the work up into chunks so I let it go until the analyze was done. After I tried rescanning and it was stuck. I then deleted the NAS share from roon and reconfigured it. Now I get 0 imported. What should I try?

Edit: I cleaned up the library, and deleted the NAS. Rebooted the core, Added the NAS, and it stopped again at 5609. It sounds like there is a magic number here. I attempted one more reboot of the core, and it would not import any more of the library.

2nd edit: Roon finished analyzing. I rebooted the roon core and the rest of the library will not import. I did notice the cpu usage is high, this was posted in another thread. It may have something to do with the importing.

tag @support for some help.

The server has been running for 2 days, still refuses to import the rest of the library.

Hi @JohnC,

Can you please share a screenshot of your Roon Settings -> Storage tab?

Is there any change in behavior if you click the 3-dot drop-down menu next to your share and press “Force Rescan”?

Are any of your missing files showing up in the Skipped Files Section? Do the files have any special characters?

Special Characters

Avoid using “special” characters in the names of files and folders. Using these characters may render the files inaccessible under some circumstances, particularly if files are transferred between different platforms, or viewed over a network share.

< (less than),  > (greater than),
: (colon - sometimes works, but best avoided),
" (double quote),
/ (forward slash),
\ (backslash),
| (vertical bar or pipe),
? (question mark),  * (asterisk),
$ (dollar sign),
` (backtick), and 
~ (tilde)

Sometimes the presence of one of these characters causes Roon to be unable to “see” a file or folder in the first place. Files skipped for this reason do not (and can not) show up in the Skipped files list, since it may not even be possible for us to know their name.

Hey Noris,

I have attached a screenshot of the storage folder. When creating my library, I was sure to only use spaces and hyphens. Force rescan, rescans the directory but nothing changes on the import.

Hi @JohnC,

If you open up the “Skipped Files” section, do you see any files listed there?

Can you share a screenshot of the NAS contents?

Is there any change in behavior if you try connecting via IP address instead of hostname?

Hey Noris,

There are 2 files in the skipped files section. one of them is an image file another is a single song. I have attached a screenshot of the NAS contents. All folders and files follow this format. Thank you for the quick responses :slight_smile:

Just checked using the IP, it stops at 5609 again.

Hi @JohnC,

Can you please try to locate an album which does not import into Roon and copy it over to your Mac Mini’s hard drive and try adding it from there? I wonder if this issue affects just the media on the Synology or if the behavior is the same on the Core PC.

Just added a new storage location that was the local music folder on the mini. Pulled in an artist from the library that hadn’t imported. The number of tracks increased, but the number of imported and identified stayed at 5609.

Another useful tidbit of knowledge. Adding an album from tidal or Qobuz fails as well. So it looks like somehow there is a library limitation. Is there a standard location for logging on the core software?

Hi @JohnC,

Thanks for trying to add the Mac mini music folder. Since identification did not increase, perhaps you are having an issue with just identifying the tracks.

Yes, logs can be accessed by using these instructions.

As for next steps, I suggest we proceed as follows:

  1. Can you please zip up an example of an album or artist which does not import on your end and send it to me in a private message via Dropbox / Google Drive / I would like to try importing it on my end just to make sure this is not media-related.

  2. Can you reproduce the behavior of adding one artist/album from your Mac’s HDD and note the exact local time + date + name of artist/album you try adding? After, can you please send me a copy of your Roon logs via Dropbox / Google Drive /

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.