Memory leak in QNAP/Synology NAS?

Hello all,

I have Roon running on a docker in DS720+. It’s memory is 8 MB ram.

Before the last update, Roon was using only 52% to 56% of memory. Now it is using over 70% of the memory. I restarted the Roon and the memory usage went back to %50 percent but it creeps up as the day goes.

Does this happening to anyone else?

Thank you and have a great day!

I do not think your problem is Roon. I have the same NAS running multiple other services and mine sits around 1-2%. Even 50% is way too much. Look elsewhere. Failing hard drives can cause mem usage but it can be something else too. Have a look into the task manager.

To me it’s just the opposite way. I kept complaining about Roon’s memory leak which with the roll-out of v903 seem solved. The red arrow marks the time when the new version was installed. (DS1517+ and RoonOnNAS)

Thank you for that. I checked my task manager, and it seems like Roon is using around 2.5 GB
memory. Would you still think it is something else?

I am quite surprised. This minimal memory consumption I never saw here before. Maybe too good to be true but computers don’t lie :wink:

I decided to limit the ram roon container is using. That seems to be working fine. But it is still at around 50%. No where close to what you have.

Hello Guys!
I’m quite new to this, with Roon running on an old SSD 64 GB on my Synology DS1519+ with 8 GB RAM. DSM is 7.0.1 - 42218 Update 2 (just performed the recent upgrade).

My memory utilization is 44 %.
Roon Server is using 2.68 GB of memory accodingly to the Task manager.

Anything to worry about?

BR Björn

All of a sudden Roon started to behave. Nothing changed apart from v903. Before, when it grabbed more and more RAM, I restarted the service about once a week.

Maybe it was in the process of rescanning your media library when consumption was higher?
Currently there is still a major known bug with QNAP causing local files to be lost after a restart.

There s no media library. Almost no local files and a quite medium size Tidal collection. I mostly jump online from album to album often without adding it to my Roon library. And even with this Roon used to grab memory totally out of proportion up to a point when it started to slow down.

The amount of memory used will be library dependant as the database is retained in ram I believe when it’s running. It’d doesn’t matter if you have no local files if you have streaming and a large collection of favourites its still all held in the local database. So larger libraries will take up more ram no one users will be the same I would imagine.

Where do you see these graphs? In the Resource Monitor app?

In Synology’s Insight service. It’s free and lets you monitor your NAS(es) from your mobile our via their website.

1 Like

Charles_Jean suggested that bad memory can cause this type of behaviour. I’m running a memory test and I will report back.


Other than high memory usage, are you suffering from performance issues? I indicated you the wrong information on my first reply, sorry. With one remote connected to the core, I’m averaging 2% CPU and 20% memory and also running other services at the same time. Bad memory will cause increased memory usage but you should also observe other problems. The size of your Roon library and other services will impact the memory footprint. More than 50% seems high to me but you need to look at the whole picture before blaming Roon alone.

My intent is not to blame Roon at all. I’m just trying to figure out why this is happening.

I just did a memory test and it seems like they are not going bad.

You are right it might be the size of my Roon library. I have around 5000 CD’s in my local library. And I may simply need more ram.


Wow, ok. Your Library is quite big and the 2 Gig of Ram you use is normal to me. Compared to you, I have about 600 CD’s and my library is just below 1 Gig; numbers are lining up. If you’re considering adding more ram then you’ll be disappointed. The Celeron processor in our DS720+ can only page 8 Gig or ram; limitation of this processor. Alternatively, I’m suggesting you add NVMe cache. I did it and the responsiveness is much better. Additionally, if you have considerable traffic in and out of your NAS then you may want to enable the link aggregation of the network ports but your switch / router must support it.

Thank you for all these suggestions. I really appreciate your help!!

1 Like

I’ve recently noticed memory leak on Roon’s QNAP version. I’m running the latest build (931) and as I write this message, Roon takes 5,2GB of RAM on my QNAP TS-253D which I have upgraded to 8GB of RAM. I’ve now had few crashes happen when Roon just runs out of memory and suddenly won’t react to any commands. I have to restart the core to make things work again. I’ve always had a restart scheduled for every night but this is suddenly not enough, Roon runs out of memory after few hours of browsing and listening to music.

I must say I’m disappointed to how Roon handles their QNAP customers nowadays. QNAP, even the models without i3 or i5 processors, are perfectly capable of running Roon core and even do basic DSP but Roon seems to do their best to make this as difficult and painful as possible. I ran Roon on my TS-253D for over a year with zero problems but then after an update few months back, first we couldn’t access our libraries, then there were endless loading jellyfish icons (core didn’t start) and now we have memory leak. It makes zero sense to buy another box (NUC with Rock) to waste electricity and do the same thing which QNAP NAS is perfectly capable to. These are all software related problems which we didn’t have before.

1 Like

Not sure how much QNAP & SYNOLOGY Roon software differ. The 8xx versions were awful and had to be restarted weekly to clear up RAM. Since the 9xx this behavior has gone completely. Can be run for weeks while memory consumption does not increase.