Merging albums sometimes completely dissapear or get added to a completely random artist/album

I have an organized folder and sometimes when I merge two albums (one album split in two, not unrelated music) all their files get erased but no resulting album is created.

There should be a check before deleting and a proper error, I’m lucky I did a backup before this.

It may be permissions, though Roon uses my basic user credentials for a folder that this user owns. It should be good now (now trying fixed RW for everyone in all music folders and files). I’ll keep an eye on this.

Also, sometimes this music gets added to a totally wrong artist/album and I see no easy way to correct this other than delete and import again.

I have noticed the problem with merging albums. I think what might be happening is that previous mergers aren’t being unselected by roon. So if you merge the tracks of album A then go and merge the tracks of album B - the B tracks are actually added in to album A.
That is certainly what was happening to mine by the time I tracked down what was happening.

I’ve had this happen too. At one point I had the Celibate Rifles performing Funky Town, which was amusing but frustrating.

Part of the difficulty in tracking down a bug is replicating it. I’ve repeated steps that led to this behaviour and had a different result. If you find some files or album where it reliably repeats, I’m sure the devs would like to know.

I think Ged is correct, all of my mixed up merges have been onto previously merged albums.

Until this bug is squashed I’m merging in a watched folder rather than an organised folder; that seems to avoid files disappearing or being moved and tagged incorrectly.

For some reason that defies logic one of my Bill Evans albums became three. One was unidentified but contained all the tracks. The second and thrid was the same album but identified by roon. Of those two, the first was missing a few tracks the last contained all the tracks. The trio was correctly identified in those two albums, but that information was missing in the unidentified album. I decided to merge the two albums of the same title. After the merge action, both of those albums disappeared OR no longer appeared in roon’s display of album view. And the unidentified album remained. I am guessing that roon scanned the Bill Evans album from my watched folder and created two versions of it using correct information but one version was missing files and one was complete and when merged the default album remained apparently because my music library was the only edition of that particular title. I realize I am describing some activity that I had nothing to do with. But once I attempted to correct the two duplicates by merging them, my watched folder’s edition took precedence. I gather roon et al might understand what took place. I haven’t a clue what triggered the duplicates and what made them disappear. Now I am back to the original album added but unidentified. Perhaps, If I went into my iTunes Library using the iTunes program and changed the metadata, the corrections would show up. But I no longer watch that version of the iTunes music library. How to change the metadata to conform to the roon’s edition of the same album?


I’ve totally lost faith in Roon’s organized folder.

I just found my XX-Coexist files (one of the albums I’ve merged)… they where added to the Beatles - White Album as duplicate, renamed and all.
I’ve also tried fixing track groupings but with the same result: moved to a totally random (as far as I can see) other artist/album but keeping original tracknames. How can I know there are no other albums being moved/removed without me knowing until I try to play them?

Is this (without file moving of course) happening in watched folders as well?

I’ve had it happen in watched folders. For me, however, it was associated with moving files. Now I close down RoonServer and all remotes before moving files from an organised folder to a watched folder. Then I merge in the watched folder. It hasn’t happened to me now for a while, but I’m not doing as much merging as I was.

Oh, it also sometimes seems to forget identified (by me) albums and to remove/misplace single tracks from an album. Have not had time to go back to a watched folder and have lost another track today.

Well, not lost it seems: it is still in it’s folder and I can see it when identifying the album at the right place but it is not added to the album.

It has now found the missing track and put it in a duplicate (identified but with other version of the songnames) album along with copies(?) of the other songs with files starting with 2-0x for a one disk album.
One of the albums is not playing its songs, and the one missing track now got duplicated in the duplicate album…
And the other albums of the same artist were duplicated as well. Interesting :stuck_out_tongue:

These merging issues are under active investigation, but are proving difficult to replicate. Before the cause can be identified and the bug squashed, the devs have to be able to reproduce the same behaviour on their system.

It’s already an inconvenience to suffer the problems set out above, but anything that users can do to assist in replication of the issue is a step closer to solving it. The following are circumstances in which the bug often occurs for me:

  1. Rip a double CD, but specifying each CD as 1/1. You should end up with two albums.
  2. Merge them.
  3. Rip other CDs (may not be necessary)
  4. Repeat 1 & 2. The second merger often (but not always) writes tracks into the first merged album.

Please keep reporting issues and data points as they occur. If you are able to set out the steps leading up to the bug in a similar way as above then that will be of great assistance to those attempting to reproduce it.

First person to set out a reliable procedure for reproducing this one deserves an honorary title in my opinion: Bug Slayer (Merge) sounds nice.

No new datapoint, but It (with this artist at least) has resolved itself now. The duplicates are gone and the missing tracks found.

Hi - Just wondering if this one is still under active investigation? Merging albums does some extremely strange things to the DB. It mostly manifests itself by identifying a newly merged album as part of the prior merged activity. I generally merge albums for two reasons - either a two disc set appears as two separate albums, or Roon has “exploded” or split an album into two or more sections, for instance tracks 1-3 and 5-10 as one version, track 4 on its own as another (a bug I guess?)

For instance, I merged Nick Drake’s Bryter Later which had split itself. That was fine. I then followed the same process for Elvis Costello’s When I Was Cruel. The Elvis album then vanished from the DB, and all the tracks appeared in the Nick Drake album (correct track names, but there was two of each numbered track, one the correct Nick Drake track, and one the Elvis track which now thought it was part of Bryter Later) Only way to fix it was to delete the Elvis album at a file level, let Roon reidentify the Nick Drake album, then restore the Elvis files so Roon could “find” the album afresh.

It feels like the merge activity is somehow keeping a DB temporary table or the like open, so rather than closing off a merge process any subsequent files are thrown into the same bucket, causing what’s described above.

This happens when controlling from either Mac or iPad. It’s happened a fair amount, and I should be able to replicate it and supply log files if it helps?

1 Like

We’re aware of this issue, but in our testing, we haven’t been able to reproduce it consistently. The screen is due for a redesign soon as well, so it would be great if you could let us know the exact steps you’re taking to get in the state you’re describing above.

This is on the list of issues I really want to close out for 1.2, so if you have a way to trigger this issue consistently, definitely let me know. Thanks @VincentB!

Thanks Mike, I’ll give it a go over the next couple of days and take appropriate notes & screenshots if/when it happens again.

yep – this happens somewhat often. Seems connected to folder renaming and/or relocating to a different watched share. I think the most annoying part is that no form of editing, closing/re-opening Roon, forced re-scans etc will fix it – even though the album might be as simple as <10 tracks all properly tagged & in the same folder. End up having to go to the dreaded merge menu to fix.

here’s a quick one for you @mike : putting a date in brackets ( [] or {} ) to differentiate between different releases of an album (let’s say) does not work. i.e the date does not show as an overlay on top of the album art. You have to add at least one character of non-numeric punctuation to get it to show. So, for instance, Space Oddity [1984] and Space Oddity [1990] won’t show the dates. Currently I’m tricking Roon into showing the date by using the least obtrusive additional punctuation possible. So, Space Oddity [1984.] and [1990.] works – the date appears, as does the additional punctuation. Can do screen caps if necessary…

Spent an hour or so going through anything I could find that needed merging today (both two disc sets, and “exploded” albums) and fixed around 15 albums in all. Was fully expecting it to break, as I’ve never managed more than a few before I get some DB weirdness. Of course, I couldn’t break it, everything behaved exactly as it should. I took screen shots of every screen I went through, so I now have quite a collection showing everything working fine! I’ll leave it a few days and have another go - apologies I couldn’t provide the info needed on this occasion.

1 Like

Good news !

Brian was able to reproduce the merge bug, which appears to be associated with restarting a Remote. A fix has been implemented and will be in the next build (which may be 1.2, not sure yet).

That’s great news @andybob - I run with 3 remotes (two Macs & an iPad) which are always being restarted, so that would explain why I’m often a victim of this one. I’ll lay off doing any more housekeeping until the fix is implemented.

If you have to merge before the fix is out, restarting the Core between merges had always avoided the bug for me.

Will do - thanks again Andy.