Meridian 218 disappers from Roon on iMac

Hi Everyone, whilst this is an old thread, I am also having this issue.
My Meridian 218s don’t show up in Roon all the time. Some days they appear, then they disappear again.
I’m running Roon on an imac (OS Ventura). My other endpoints Meridian Prime and Sonos Move always show up, it’s the 218s that disappear. Sometimes a reboot of the iMac brings them back but normally only for a day or two before they go again.
The 218s are always available via their webpages so I don’t think the issue lies with them.

Hi @peterrussellwilks,

Thank you for your demonstration of extreme patience.

We’ll need to know more about the network configuration and hardware involved to pinpoint what’s wrong here.

Diagnostic pings and Roon’s audio streams have different sensitivity and bandwidth requirements. Depending on how you’ve connected both the Meridian 218s and your iMac within your network, Roon’s path to the 218s might be changing.

Please list out a) how you’ve connected both the 218s and your iMac to the internet and b) any network hardware involved (switches, access points, routers, etc.)


Hi Connor,
I use Ubiquiti for my network.
I have a USG Pro 4 router and a USW-24-POE 24 port managed network switch. I use UAP-NanoHD WAPs.

All of my network is on one IP range (192.168.69.XXX) I do not have separate VLANs.
Incoming broadband is FTTP from BT on a BT router on IP range (192.168.1.XXX). This router connects into one of my WAN inputs on the USG Pro 4. Incoming broadband speeds are 500Mb with a 1ms ping wired and around 288Mc with a 5ms ping on wifi.

All of the network is wired (CAT6a) except for the phone and iPad which are on Wifi. So the iMac and 218s are all hard wired.
The Meridian Prime is connected to the iMac via USB. The Sonos Move is wireless.

I have speaking to Meridian about the issue too. They asked me to use Static IP addresses on the 218s. Previously I was binding the MAC addresses. Changing to Static IP did not resolve the issue. I also switched off DHCP snooping. This has also not resolved the issue.

When the fault occurs, if I open windows (I use Parallels) and run the Meridian device manager. It immediately finds the 218s and also immediately Roon does too.
For some reason, the Meridian Device Manager Mac version does not like my Mac and won’t load.

Since I posted this thread, I have formatted the iMac and reinstalled all software as a fresh new install. The issue remains. If I use my Macbook Pro as a Core, the issue remains.

I can send screenshots of the Ubiquiti network config if that helps. It is set up as a fairly secure domestic network.
Multicast DNS and IGMP Snooping are both on by default. Spanning tree is set to RSTP. DHCP snooping is off. No VPNs are setup.

Hi Connor,
Any further news on this? I reported this issue back in December 2022 and it is still not resolved. Support has been sporadic and disappointing. How am I supposed to recommend Roon to my clients when I can’t even get support myself.

Another week with no response from support…

Another week with no response from support…

I have a problem with my Roon account dropping connections to my Meridian 218s since December 2022. I put my question on the forum. The only response I got from support was to move the problem into a new topic and then a message to thank me for my patience.
Well, unsuprisingly after 9 months of waiting for help my patience has run out.

Do other users experience the same total lack of support or am I just unlucky?

I ask mainly as I am a Hifi dealer and if I can’t get any support with my own system how can Roon expect me to sell theirs to clients.

Do other people have alternatives to Roon to try out? Whilst I like the software, the fact that it fails me on a daily basis is beyond a joke.

I am just a user but this is not quite correct if I may point out. In your first thread in January, Wes (then Roon support) answered but you then wrote that the issue resolved itself:

Wes added that this seemed to be a known issue with the 218s and said to open a new thread if it happens again. The thread was closed on Jan 12 because it was marked solved

In your new thread, created many months later by moving your post from a different old thread about potentially a similar/same issue, Connor answered (after too much time had passed) and had some questions (i.e., not just saying thanks for patience), which you then answered - this was 28 days ago and everyone, including me, agrees that this is way too slow. This is always a problem and currently particularly bad because support is even less staffed than usual.

However, if it is true that this is a device issue (I don’t know) maybe Roon can’t do very much. Did you ask Meridian?

Edit: I see that you did ask Meridian and their response was not super helpful [1]. However, the fact that, as you wrote, running the Meridian Device Manager makes the device appear immediately and then Roon also finds it, is IMHO a hint that the issue may well be with the Meridian.

[1] To say the least - static IPs are nearly always a spectacularly bad idea for anything but testing unless the device is broken with normal networking

1 Like

Many thanks to @Suedkiez for digging into this one to try and obtain some factual information.
Let’s keep it here in one place please.

1 Like

I suppose that the configuration would be very helpful for @Connor because “secure” sounds like potential for interference

Hi Suedkiez,
Just to address a few of your points. There are two issues here:
1 I have a problem with Roon as a piece of software not finding my 218s.
2 I have a problem with Roon as a company not providing adequate or satisfactory customer service.

This is why I split this into two threads. These are two distinctly different things.

So to address point 1:
The original problem is still present I.E. Roon cannot locate the Meridian 218s. Sometimes, the system will run for a month or two without issue, at other times it will be every day. There are no changes to the network settings, sometimes Roon finds the 218s at other times it does not. I can play a song, stop it, go downstairs, come back to the imac and Roon has lost the 218s.
At all times, the 218s show as online in the Ubiquiti config software, the webpage for each device and also the Meridian Device Manager and also Meridian IP control.
Initially, I tried rebooting Roon, then rebooting the iMac. This would allow Roon to find the 218s 9 times out of 10.
If I open the webpage of the any of the 218s when Roon can’t find them, they are online and I can change the settings etc but Roon still won’t find them.
Only by opening Meridian Device Manager does Roon always relocate the 218s.
I cannot see how this is a Meridian issue as the devices always show as online and I can always connect to them via other means to Roon. Only Roon seems to have issues connecting.

To digress and address your comment on Static IP addresses. Static or fixed IP addresses are required by nearly all control systems: Crestron, Savant, Control4 etc for IP control. I prefer binding the MAC address to the IP address but static IP addresses are fine when used outside of the DHCP range. Either way, this should not affect Roon not finding a device when its IP address is not changing.

By secure network, I would understand this causing an issue if Roon could not find the 218s at all. However, it does find them and then loses them again. :unamused:

Point 2:
At least we can agree that 28 days from the last message is too slow :grinning:

About (2), I think (but I am not a moderator) Roon prefers if complaints about quality of service, etc., go into the #feedback section of the forum because they are not a support issue. As you noticed, support is overwhelmed with actual support issues as it is. It is said that Roon reads every topic in #feedback.

About (1), it will be for Roon support to figure out what is going on, but nevertheless Wes already said in the older thread that this seems to be a known Meridian issue. I don’t know but thought it’s worth pointing out (and you don’t seem to be the only one affected …). I’m sure your additional info will be helpful.

About the secure network either working or not, I would not be too sure. If there are managed switches, VLANs, etc., the network management can do whatever, and who knows the results - it depends :slight_smile:

Regarding the static IP address digression, some services may require them and maybe they have a reason, but I don’t see that you are using control systems like Control4 etc., at least you didn’t mention them. They can work, they are just IP addresses, and they have their role in certain complex setups as long as the user/admin (or installation person in the case of control systems) is diligent in assigning and documenting them as well as excluding them from DHCP ranges. They can also be helpful for testing in certain cases. I am just very opposed to various support organisations habitually recommending them if there is no good reason to do so, because they are normally not necessary and many home users are not diligent in their setup (and later inevitable update). We always see issues on the forum caused by them due to IP collisions (which are notoriously irreproducible because everything works until suddenly the DHCP server assigns the same IP and things break seemingly at random). For setting up a streamer and Roon in a normal home network they are definitely not necessary and DHCP is nearly always the better choice at home. If a streamer does not work with a working DHCP it is broken. Your requirements may differ in a complex network (but then the burden of debugging the network is an accepted necessity)

Hi Suedkiez,
I’ll start a new thread about the quality of service (or lack thereof) in the feedback section. Sorry that this was in the wrong area.

With regards to my network:
The whole house is on one VLAN. I have a separate VLAN for guests, this is separated on wifi only. All switch ports are on the house VLAN.
I have RSTP, IGMP Snooping and Multicast DNS enabled. I am not seeing any logging issues with any of these services.

Fixed IP addresses - Partial Digression :slight_smile:
I am using a Savant control system at home for the lighting, cinema, heating, AC, doorbell etc. The Savant is not really used to control the 218s as Savant does not interact with Roon, hence me not mentioning the Savant in the list of network kit.
However, when I have used Savant to control the 218s I have not noticed any dropouts in connection.

I had mentioned in my previous posts that I am a Hifi dealer. Our businesses main work is in home automation and I am also a Meridian dealer, so my dealing with Meridian were at a dealer to manufacturer level rather than user to manufacturer hence probably their recommendation to try static addresses without worrying that this could cause any IP collisions. I do take onboard your point about home users not being so diligent with their network setups though. Either way, I am using Bind MAC to IP so binding the IP addresses in the router rather than setting as static in the equipment.

Back to Roon
I do accept that this is a very difficult problem to solve. It is intermittent and without obvious cause, reoccurrence of the problem can take days or more to happen.
I have through a process of elimination found a way to resolve the issue, at least for a temporary basis until it falls over on its own again. Whatever process, rebooting the iMac or using Meridian Device Manager allows Roon to find the 218s again.
For all other interfaces: Web page, Meridian Device Manager, Meridian IP Control and Savant have no issues with maintaining contact with the 218s.
I would love it to be a network issue where changing one setting brings it all back, but that doesn’t seem to be the case. The issue seems to lie within Roon. I don’t know if it is because Roon treats the 218s differently as RAAT devices or not.

1 Like

Understood. IF your network can be ruled out, then to be sorted out between Meridian and Roon, I suppose. On the other hand, it’s just Roon Tested, and I think that’s up to Meridian to make it work - obviously Roon might want to help or not

Another week rolls past and support are nowhere to be seen…

Interestingly though, this is similar to the old SONOS problem roon used to have. Devices would drop off roon, and if I went to the sonos app and did something to a speaker, it would appear in roon almost instantly.

Roon fixed this, and it feels like a similar issue. Somerhing about how roon discovers network devices is not quite right.

@connor could you take a look?

@peterrussellwilks I’m not part of the support team, but I just wanted to give some background info here and ask a couple of questions.

  1. Have you always had dropouts with Roon and the 218 with this Ubiquiti network? Or did it work at some point? If it did work, can you think of any difference in network topology from when it did?

  2. Do you have a dumb (unmanaged) switch that you could temporarily plug both your iMac (Core) and your 218 into? Or at least the 218? Going Ubiquiti – (Gbit) → dumb switch → 218 is probably sufficient.

Please bear in mind that this may not be a Roon issue. The Meridian-Sooloos discovery protocol is UDP and multicast (I think) and it’s not something that Roon can change. Unfortunately some routers/switches do not play nicely (i.e. are buggy) with this; in particular, packets can be lost when the switch drops down from Gigabit to (the endpoint’s) 10/100Mbit UDP. I encountered this myself with one of my Meridian-Sooloos endpoints and fixed it by changing the switch that the endpoint plugged into. Managed switches are often tricky too (I don’t know why).

I’m not sure, but it’s possible that the Meridian device manager is not using UDP.

Hi Joel,
Thanks for your message. I can’t think of anything specifically that changed in the network, when I first had Roon (2015), I think it worked for a few years without issue. Then adding Ubiquiti, it also seemed fine for a long time. There are the usual Ubiquiti updates, but nothing stands out as to the exact point that it started t o have issues. What’s annoying is that the frequency of dropping out is so variable it’s hard to test. Sometimes, it is literally pausing a song and going downstairs. The imac goes to sleep and when I wake it up, the 218s have gone. At other times it seems to be a few days of uninterupted music.
I will try and dumb switch and see if that helps. I have tried with the managed switch to limit the amount of ‘management’.

This is ringing alarm bells. What are the Mac’s sleep settings? Is it full sleep as opposed to “turn off display”?

1 Like