Meridian Explorer 2 woes

I think that I have seen mention of this somewhere on the site; Roon is running from a ROCK NUC box with a Meridian Explorer2 attached.

It can run for a day or so without a problem (running Radio Paradise) and then stop running. The NUC appears to be on as per expected, but it needs a reboot (or possibly a restart of the software) to get back up and running again.

On top of that, sometimes the reboot then needs me to disconnect the Meridian from the USB port and reconnect it before it will work again.

Finally, I can be happily listening and then there is a loud noise similar to the grey (?) noise that you get when you disconnect something with the volume up. That sound normally indicates that I Roon will scoot through multiple tracks not playing any of them and jumping to the next and the next etc… This means a walk over to the unit, disconnect the Meridian. count to five and reconnect it. I am not sure if this has something to do with the output of the track changing between tracks, but it does seem to happen as one track ends and another is due to start. An hour ago (which is what prompted me to reach for the keyboard) it happened twice in about 10 minutes.

Any thoughts or pointers please?

Thanks in advance - Terry

Hello @TerryD,

When you see the issue that occurs during the track changes, have you noticed that it happens more often when the next track is of a different sample rate, from a different source (Tidal, Local, Internet Radio Station), of a different format (FLAC, MP3, AAC)? The issue you are describing seems indicative of your device failing to sync it’s sample rate correctly when ROCK is requesting a sample rate change.

I’m going to enable diagnostic logging on your account so that we can forward some more information to the tech team for analysis. What this means is that the next time your ROCK machine connects to the internet, it will upload a set of logs to the Roon servers. It would be helpful if the next time you see the behavior you are describing occur that you mark what time it occurred so that we can zero in on the issue with greater accuracy when looking at your logs.

-John

Good morning. I have just noticed that my replies to your email have not made it through to your community@ email address.

I will post one or two of them into the topic, but I may need to directly email one or two of them?

Good evening John.

I think that you could be correct to some degree, I will check over the next few days, but I haven’t seen/heard it happen for a few days, but I have not got to the end of a selection and radio hasn’t kicked in. A bit of a reverse way of looking at it. Most of what I play is flac but some at higher rates than others. I seem to recall that the problem can occur “mid album” and it is like a stylus skipping all of the tracks and going into the centre zone. It appears to not be able to find the track when in fact I think that it is unable to push the track to the device.

Internet radio is 100% as far as I recall, but if that “skipped” it would manifest itself as a stop wouldn’t it? If so, the it is possible as I listen to Radio Paradise at 320 and sometimes it will go for many hours and then I find that it has stopped, but that could be for a number of reasons.

I will try to make it happen and note the times etc.
Thanks for your attention - Terry

Typical. I leave it on whilst I am out and it stays playing. (this was Tuesday 17th April)

However, there was a skip at 14.48:

The half second of static/noise was heard, track skipped but this time it seems to have recovered, although there is no sound coming out of the amp/speakers, normally it just skips through the playlist.

It happened as I changed from Polaris to Aliens.

I just went to replay Polaris to see the quality of the flac and this happened:

That is more like it. N.b. The April Maze is a higher quality album to Zero 7’s.

I will now need to go and disconnect the Meridian USB and plug it back in again for it to work again.

Thanks for your assistance - Terry

Before disconnecting the USB I closed Roon, rebooted the NUC opened Roon again and when I looked for audio devices, the Meridian is not there, it seems that a warm reboot doesn’t do the trick. I am guessing that power off and on again will find the Meridian USB.

Yes, that works, all is good after a power off/on cycling of the NUC.

Regards – Terry

p.s. you can probably see some/all of this in the logs? The time now is 15.05h BST (GMT +1)

And on Sunday last (22nd):

Roon/rock/nuc/meridian have been behaving themselves until about 15.15h today:

Hello @TerryD,

Thanks for all of the information, I will pass along your logs to the tech team for further analyzation. I would also recommend reaching out to Meridian about your issue to see if they have any input. We have many customers happily using ROCK with their USB DACs without issue, and often in cases like this the problem is a result of poor linux support on the device end of things.

-John

Thanks John.

I changed the focus to my Logitech Transporter and recreated the playlist around the first example (Polaris to Aliens) and that worked fine, no crash at all.

As you say, it could be a Meridian problems, a Roon to Meridian problem, or that the Roon to Transporter path has converted it differently to the way it did to the Meridian.

I quite like the Transporter sound in any case, so I may avoid the Meridian for the time being although that is a pity.

It would be interesting to hear what the techies come back with.

Thanks again for your time John - Terry

The other point that I was going to make was; when the problem occurs, you can’t stop Roon going through the playlist, the pause button doesn’t seem to function.

Do you have the latest firmware on your Explorer 2?

I think so Henry, or at least it was the latest up to a month or so ago.

I will check again though just in case.

Regards - Terry

I was more concerned about early firmware versions. In all likelihood a month old firmware should be OK.

The latest version appears to be the 2016 version which I am using.

Hello @TerryD,

I’ve had the tech team take a look at your logs, and unfortunately it doesn’t seem like there is much we can do from our end of things. In the logs, we can see the USB commands sent to the devices and how the device responds. All of these commands are standardized in what is referred to as the UAC 2.0 standard which allows these new generation of USB dacs to work without having to install drivers. We can see the command being sent from Roon to the Explorer 2, but the device isn’t responding to the command that would allow for playback. Roon is attempting to skip the song in case it’s an issue with the audio stream from the file, but obviously it’s failing since the issue is happening in the playback device not with corrupted media.

I will file this bug on our end of things to keep the documentation for future reference and see if we can relate it to any other device’s misbehaving with ROCK. We periodically check all of the bug reports with all of our platforms during review periods to see if we can find common threads that may be causing issues for multiple different devices.

-John

Thanks John, I appreciate your attention on this. I take it that your guys are in contact with the team at Meridian, or should I go on there and create a support case as well?

For the past few days I have been using my Logitech Transporter as the DAC and it hasn’t hiccuped once.

Regards - Terry

I am going to have a play with my ROCK based endpoint too. I know it has worked but I’ll double check.

I’ve been using my Explorer 2 with a variety of Linux boxes without any problem at all – I’d be surprised if ROCK would be the culprit here.

I did however have the small USB lead fail on me. I would try to use the Explorer on a different (Mac/Win) endpoint and/or change the USB cable if possible – if only to see if there’s different behaviour.

The Explorer2 is fine on say a radio stream where the quality stays constant, it is when it is playing the “radio” after the queue has finished when it can wander around the saved album including high resolution. That seems to be where it hit problems.

Outputting to another endpoint seems to work fine, no crashes.

Regards - Terry

I have a second Explorer2 (the wife’s) so I will swap them over (cable and unit) and see if the problem persists.

I have the same problem with my Explorer 2.
Latest firmware checked.
Changed cable.
Problem is when it change between Tidal (MQA and blue light) and back to my own library with different frequency and bit depth…shifting forth and back, suddenly no more music. The NUC also heat up as the fan runs…
Tried my Dragonfly red…no problems at all (I know it doesn’t do MQA).
Cheers