Meridian Sooloos & Roon Server On Single QNAP NAS? [Solved]

I’m running Meridian Sooloos (2.494) and Roon Server (1.0) on the same QNAP NAS (4.2.1). Sooloos is working fine, but I can’t get the Roon app on a desktop to see the Roon Server on the QNAP.

Roon Server on QNAP is running fine and doesn’t have any issues noted in the log.

Any ideas?

Hi Chris,
Can you connect to the Roon Server if you enter the IP of your QNAP on your remote device manually?

No. Entering the IP address doesn’t work either. I have another QNAP NAS running Roon perfectly on this network. It’s just the QNAP that also runs Sooloos that isn’t working with Roon.

Try turning the SOoloos core off and rebooting the NAS. It could be that Roon and Sooloos share the same ports.

I would try the following, to figure out if this is some conflict of Sooloos and Roon Server:
Stop temporarily Sooloos on the QNAP. Restart Roon Server and see if solves the problem.

According to this forum post Sooloos is using different ports than Roon Server.
Sooloos is using

  • UDP port 9001, 9002, 9131
  • TCP ports 9011, 9012, 9080

Roon Server needs the following ports:

  • UDP port 9003
  • TCP ports 9100-9200

EDIT: Sorry Nick, did not you already replied when I was posting this :slight_smile: .

Hi Christopher - Just tried that test and nothing changed. It appears that it isn’t a conflict between the two.

No worry😎

I have had Sooloos and Roon running on the same machine before and didn’t have any conflict but it is worth doing the test to see if it makes any difference.

Is there anything else different on that specific QNAP compared to the other working one?
Is it connected to the same network/switch/router? Has this one (or the switch/router) an active firewall?

Did you copy over your existing Roon library from your previous server to the QNAP?
If you did: Has the old Roon Server been stopped?

I can’t find any other differences between the NAS units. Connected to same switch. No firewall.

Didn’t copy any existing Roon library or files.

Hi Guys - Just want to let everyone know that Christopher helped me figure out what the problem was. The simple solution was to re-download the qpkg and reinstall.

It seemed Chris had downloaded the qpkg quite early (within the first few hours after release). This package did not include the library at that point (and not all qnap devices have this one preinstalled).

1 Like