Metadata improver error on Nucleus

Hello - I hope someone from Roon will contact me about this. I too have the same problem. The last update seemed to have fixed it after re-naming the cache didn’t work. But the problem has returned. Cleaning up the library has not worked either. I run a Roon Nucleus and have restarted it after attempting every fix. This is becoming very frustrating.

Hello @Michael_Kurtz,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Hello. In addition to the above information:

Core is Nucleus (10.0.0.218) Roon Version 1.7 (build 571)

One remote device is a Samsung Galaxy Tab E 8.0 running Android version 7.1.1. Roon Version 1.7 (build 610)

The Roon app is also installed on my Microsoft Surface Pro 3 running Windows 10 Pro version 1909 OS Build 18363.1016 using Bitdefender security. Roon Version 1.7 (build 571)

Local files are stored on an SSD installed in the Roon Nucleus. Streaming is through a Tidal account.

I have just updated the Roon software. Now the Nucleus and both remotes are running Roon Version 1.7 (build 610). I believe all updates have now been made. I restarted all devices but the Metadata Improver is still halted on both remotes.

Additionally, I have a Blue Curve Gateway modem, connected by Ethernet cable to a Cisco 2960 network switch, connected by Ethernet cable to a Naim NDX 2 streamer.

Have the same issue. Latest version of Roon and Rock in a home built Nucleus (using the directions provided by Roon), hard wired to a D-Link DGS108 switch which is then wired to a T3200M modem.
Rock/Nucleus is hard wired to a dCS Bartok.
Wheel is constantly spinning and always reports
"Metadata Improver: Halted. Roon needs a software update.
Rebooted, used “Clean up Library” and a hard power off…no luck.

Hi Warren. My problem turned out to be a network issue and nothing to do with Roon. In my case I was using using a Cisco 2960 network switch and it turned out my Nucleus didn’t like talking to it. I had to connect my Nucleus to my router, then connect only the router to the Cisco and then only the Cisco to my streamer. Hope this helps.

Hello Michael,
So you have the Nucleus connected directly to the router, avoiding the switch entirely for Roon access to the web…will give it a try but have used this D-Link switch for some time without an issue.
Thanks for your reply…

1 Like

Yes. That is correct. I hope it works for you. If not, start a new thread and I’m sure Roon support will help you eventually. That is what I did and where I got the information that other people using the Cisco 2960 switch were having the same problem as me. Of course, the issue may not be your switch but some other network related problem. All the best.

And do contact Roon Support if you haven’t already

One question…assumed that posting here was, essentially, contacting Roon support. Is there another portal for support questions?
Thanks for your help.
Best

Yes. I think the most effective way I received help was by starting a new thread in this support category.

As per your comments, I switched the Ethernet at the Bartok and the issue went away…
(the Bartok allows one to use the ethernet line from the router/switch to the Bartok and has second Ethernet out to the Nucleus)

1 Like

Hey Warren - I’m so glad this worked for you. Enjoy the music! Cheers.