Metadata Improver: Halted. Roon needs a software update. (Still not fixed)

Core Machine (Operating system/System info/Roon build number)

Antipodes CX with latest version Roon (1.7 build 610) and latest Antipodes firmware (2.7)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

FRITZ!Box 6590 Cable - latest firmware FRITZ!OS 07.20
FRITZ!Repeater 3000 - latest firmware FRITZ!OS 07.20
Antipodes CX is connected by LAN (1 GBit) ot FRITZ!Repaeter 3000

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Lindemann musicbook:25DSD connected via USB to Antipodes CX

Description Of Issue

“Metadata Improver: Halted. Roon needs a software update.” message shows continuously.
I already enhanced Memory for Photos/Artwork to 1024 MB. And I checked music-folder settings.
But the message showed up again.

I also already made a roon backup and re-installed roon. Message showed up again.
I do as well have massive performance issues with roon: Sometimes I have to wait for about one minute for search results. This 1-minute lag only occures sometimes. After that issue, roon performs “normal”, so I get results within one second…

What can I do?

this may and probably is totally unrelated, but let me try: I had the same message. It occurred because I had used another full Roon installation on anther PC. When I fired up my second Roon on my main PC, I got precisely that message. I waited for 5-10 minutes until Roon messaged me that I had another instance running and offered me to disconnect it. That helped and all was good thereafter.
I had a couple of strange Roon messages while using two installations. Roon takes a long time to find out that it last run on another device and comes up with all sort of funny messages until then. Safest is, to disconnect from the Roon core and then power down.

Hi Joachim,

thanks for your reply. I am only running one single roon core.

But I use three different remotes: 1 PC (Windows 10), 1 iPad and 1 android smartphone.
Each remote shows the same message.
After shutting down the roon core, clearing roon core cache and restarting it, the message is gone.
But it shows up again and again…in most cases some hours later.

The thing is, your Windows installation is also a Core.
And this message pops up every time a Core starts up unauthorized. (That means another of your Core’s are currently authorized by Roons online licensing service)

I always have two or more Cores running, and on every occasion when i switch to another of those Cores, this message is present and i need to authorize that Core and reboot it.

You might want to check if the PC runs more then one core. You could deinstall Roon, then install roon core only for PC, and then install Roon complete but connect to the core installed previously. The PC distributions sadly does not have a remote only piece, only Core, Bridge or all. I assume that the Android only runs remote and no core.

Hi Mikael, hi Joachim,

Thanks for your hints.

I uninstalled roon on my PC (I don’t really need the PC being a remote).
I also reset/restarted the roon core and now will try, if the message shows again.

Hi @Matthias_Heberle,

Is there any change in behavior if you try to reboot your Core?
Have you been using the Windows as a Roon Client or as a Core as well?
Did this issue occur only when switching between Cores?

Hi noris,

when I stop the roon server, clear roon server cache and restart it afterwards, the message is gone.

Sometimes it came again after half an hour, sometimes after two days.

Since Mikael and Joachim told me, that the Windows version is not remote only, I uninstalled it on sunday.
The message did not show up again since then. I hope, it won’t come again…not yet 100% sure.

I did use the Windows version only as remote to control the setup in the living room.

The performance issue with the occasional lag of up to one minute for search results is still present…

Best Regards

I never (intended to) switched between cores, because I only used/configured the antipodes server as core

You might want to think about distributing a PC „remote-only“ Module.

Hi all together,

my issue is still not fixed. Today I got the Metadata message again.
No I am only running roon software one one antipodes server, on one iPad and on one Android smartphone. So only one core.

What else can I try?

Best Regards

The only reason i can imagine now is that someone else has got access to your Roon Account credentials. Unless this is related to some network issue which was suggested previously by the Roon crew.

Hi Mikael,

thanks for your suggestion.
I just changed my password for the roon account and restarted the server. Let’s see, if this works…

Best Regards

Hi @Matthias_Heberle,

A Metadata Improver error may also occur due to other factors, please see:

Are you by any chance using any VPNs / VOIP systems?

Hi Noris,

I am using a unitymedia account, which is a cable account (measured 412 Mbit down / 20 Mbit up / 22 ms latency). I am using only IPv4 and disabled IPv6 at the moment.
My phone @home runs over the same cable which is VoIP but we barely use it ever (about 1 call per month).
I do not use any VPNs.

Regarding the routers firewall: I did not configure anything special there. But I would expect roon not to work at all if it would be wrong firewall settings there…or am I wrong?

I don’t know about the firewall and/or amtivirus software on my Antipodes CX server. I can’t configure anything like this for the server (on which my only core runs).

Sincy I changed my roon password two days ago, the message did not yet show again but I had some days without message earlier and it still came back then…

Best Regards

The message keeps coming up.

What else can I try?

If you have not already I would suggest deleting Roons cache folder as it will rebuild itself afterwards. Stop Roon core locate folder delete or just rename it , then restart Roon. This worked for me when I had the issue on ROCak and it never came back after this. Not sure how you access this from Antipodes though.


thanks for your reply. I did that several times. It fixes the issue for the moment. But the message keeps coming up again.
Sometimes some hours later, sometimes some days later…


Sorry to hear that… Then i suppose this might indicate an issue with your VOIP setup. Somethkng obviously either messes up the communication or deauthorizes your Core…
But @support should see that fine when they enable diagnostics for your account.

Hi Mikael,

I did not see the message yesterday but today after I started the Antipodes server.
The telephone has not been used during the past few days…but maybe you are still right.

Hope the support can help me.