Metadata Improver Issue

Well here’s something odd. I have had this problem the last few days - been adding new albums from Bandcamp - and the spinning sync circle wouldn’t stop. Got the same message about a Metadata issue Software Update required.
Just now I simply went into each recent album and looked at them one at a time. No action taken, just looked. And the constant Syncing I’ve had for days just disappeared.
What does this mean?
Thanks.

Hey @Lyall_Johns,
So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

I’d also reboot the core and see if the message persists!

Hi Nuwriy,
As I mentioned, I no longer have that problem. The message re Metadata Software Update required has disappeared. I had previously rebooted Roon but that did not help. Just viewing my most recent purchases, perhaps coincidentally, stopped the spinning Sync symbol and I have not seen the Metadata Software Update Required message since then.
The Issue has solved itself.
Thanks.

Shortly after my previous message, the constant syncing and Metadata Software Update Required message re-appeared!!
And remained until this morning when Roon 1.7 Build 537 Improvements & Bug Fixes was installed.
Now the interminable syncing and Metadata Software Update Required message have both disappeared.

Did that form part of the Bug Fixes for Build 537?

Hello @Lyall_Johns, our investigation into the metadata improver message continues, although we are seeing that some of the changes we made in 536 are improving the situation! I’m going to add this information for our team to take a look at. Let me know if the metadata message returns!

Also, the release notes for 536 can be viewed here.

I’m seeing the same thing, started yesterday after I added one new album and updated FLAC metadata on two albums, and still going. I’m running the latest version of Roon Core (1.7 (555)) on a synology DS218+. Everything seems to be working fine, and the nas disks aren’t spinning so I don’t think Roon is really scanning anything, but the update circle in the Roon app just spins and I’m seeing the metadata improver message.

I did just change settings yesterday to no longer display version info on albums, so maybe Roon is churning through each album in the library again after that change? Seems odd though…

Somebody advised me on another thread (they are a few regarding this issue) to restart the roon server. I did that before even posting the issue with no luck, but then I’ve restarted again (several times for some other reasons) and this issue just disappeared…

Hello @occasionallyhere and @rcrawley, yes a reboot is resolving the issue for the majority of other users who are experiencing the issue.

That seems to have worked. In my case I stopped/started the app on the DS218+ and no issues over the past few days. Thanks!

I have been getting the Metadata Improver error message after every update for a while now. A hard (power off) reset of Roon Core has cleared the error.

With 555, behavior has changed. The hard reset had no effect. What worked to clear the message was a restart of roonserver.service.

Came here to report the same thing. I noticed the metadata spinner error again yesterday after having Roon off for a few hours (had to shut down due to electrical work in the house), I did run the update a few days ago but didn’t notice the spinner until after core being offline. And like @Greg_Miller restarting didn’t work this time like it did last time. For me, I had to go into Settings -> Library and run Clean Up Library to stop the metadata spinning. I only had a bout 200 tracks that needed to be cleaned up, so nothing huge, but that worked this time.

A post was split to a new topic: Metadata improver error on Nucleus

i just got this error for the first time since upgrading to 1.8 (i had gotten it many times in the past). so, its sad that it is still there after the big update.

one of the most annoying things about this is the way the error message is worded to lead you to believe that a software update is neeeded, when it is clear from reading the reply from Roon developers that they are aware that it has nothing to do with that. if the problem itself is (evidently) unfixable, then i would love to at least see the error message reworded so as not to cause people to think they need to update something