Metadata Improver message after restart of Roon server

Roon Core Machine

AMD Ryzen 3600XT processor, 32Gb Ram
Debian, Linux kernel 5.10.127-2

Networking Gear & Setup Details

Edgerouter Lite
Virgin Media Hub 4 running in modem-only mode

Connected Audio Devices

Various - 2 Apple TV’s, one Chromecast, Mac and PC as endpoints

Number of Tracks in Library

8858 tracks

Description of Issue

Had to shut down the music server yesterday because we were having a new fusebox installed, which meant the power was going to be out for a time.

Since starting it back up today, the red ‘Metadata Improver’ triangle has appeared and I’ve not been able to figure out what’s wrong.

Yes, I’m running the latest version of Roon everywhere,
Yes, I’ve tried rebooting it,
No, we haven’t got any internet/network problems, our internet connection is rock-solid and we use enterprise-grade gear where we can.

I noticed a lot of messages like this in the log:

08/18 18:24:19 Warn: [easyhttp] [16] Post https://identifier.roonlabs.net/identifier/2/album web exception without response: Network is unreachable (35.231.208.158:443) Network is unreachable (35.231.208.158:443)

but why are these appearing when I can ping that IP address from the same box with no problems? this makes no sense:

dloader@deb-mus-svr:~$ ping 35.231.208.158
PING 35.231.208.158 (35.231.208.158) 56(84) bytes of data.
64 bytes from 35.231.208.158: icmp_seq=1 ttl=104 time=106 ms
64 bytes from 35.231.208.158: icmp_seq=2 ttl=104 time=100 ms
64 bytes from 35.231.208.158: icmp_seq=3 ttl=104 time=101 ms
64 bytes from 35.231.208.158: icmp_seq=4 ttl=104 time=101 ms
64 bytes from 35.231.208.158: icmp_seq=5 ttl=104 time=100 ms
^C
— 35.231.208.158 ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4007ms
rtt min/avg/max/mdev = 100.388/101.874/106.314/2.249 ms

This was working perfectly up until the restart. What’s changed?

Reboot your router. Actually, reboot everything that can be rebooted.

Hey @David_Loader,

Thanks for writing in! There’s a chance that your Core or network is having trouble communicating with our servers. Below is a list of common troubleshooting steps that will help resolve this type of problem, but for more details on networking best practices with Roon, please read this article.

  1. Change the DNS that your network is using

  2. Disable IPv6 on your router and Core

  3. Remove any managed switches, WIFI repeaters, or powerline adapters from your setup

  4. Disable any VPN, firewall, and antivirus running on your Core

Let me know if your issue persists after going through the above :+1:

Update - fired up Roon today and it was prompting me to run a software update on Core and remote. Did that, and the red triangle is now absent. Hooray!!

Clearly that indicates the problem wasn’t with my network hardware as that has been untouched for 3 weeks and 3 days.

Have Roonlabs/Meridian finally fixed this…?

Hi @David_Loader,

I’ve moved your post into this support topic that you had previously created, this way all history is together.

Not sure if you noticed @benjamin’s reply to you, above … he suggested some troubleshooting steps to explore.

It’s good your Roon Core could update, I agree disappointing that the Metadata Improver issue is still present.

What I can say from experience is that just because the Roon Core can connect to one Roon cloud service it is not an indicator that all is well with the connectivity to the other services it uses. I’ve witnessed this myself … in my case fortunately a simple router reboot resolved it and I’ve not seen it since.

I hope you together with @benjamin are able to work the problem at get a solution. I know he is waiting for your feedback on the above.

No, they haven’t fixed it.

roon was running fine two days ago (Thursday) on build 1021. The log file shows that the server downloaded build 1105. Today, I fired it up again, it’s running 1105, and the red triangle is back. Neither network topology nor network configuration were changed between then and now.

I’ve sent @Wes log files from Thursday and today in our support PM conversation. Maybe that will help them fix it.

- Eric