Metadata Improver: Paused - Roon is having trouble verifying your connection with our servers

Roon Core Machine

QNAP TS453
PC WIN 11 Core i7

Networking Gear & Setup Details

FritzBOX!7590

Connected Audio Devices

PC, Ropiee, NAS

Number of Tracks in Library

Over 110000

Description of Issue

In addition to the known problem (QNAP - Not Showing Local Folders Anymore), I also noticed us second problem: “Metadata Improver: Paused - Roon is having trouble verifying your connection with our servers”. If, on the other hand, I install the core on WIN11 PC, the system runs with no issues. Any ideas?

Reboot EVERYTHING including the Modem/Router …

Start each component in turn BUT wait until internet is connected before moving on

A restart usually resolves the “pause” problem.
It suggests that a Roon is unable to connect Roon cloud servers, so this might be a firewall or networking issue.

It’s worth rebooting any network equipment and also try temporarily switching off any firewalls.

Rebooting a network b/c Roon can’t communicate with its own servers seems extreme at best and untenable in environments where network stability is already designed in and key. Not everyone can cycle their home network at will. :slight_smile:

I have this problem frequently on RoonCore running on both a Synology NAS and a MBP – both hardwired into the network so not using wifi, and both have direct access to egress – and find that restarting Roon usually fixes it on the Synology and rebooting the MBP always fixes it. I run into about once per month and have yet had to (nor wanted to) reboot my network. Just sayin’…

I have never had the problem myself but the OP is seeking help, so he has to start somewhere.
Most networks, at some stage, need to be restarted to overcome obscure problems and it’s invariably more effective than spending many hours with analysis tools.

Hey @Nicola_Sforza,

Ben here with the support team, I wanted to follow up on this thread and see if any of the above has helped with your issue?

I’ll be on standby for your reply :+1:

For now the problem only persists if the Core is installed on the QNAP NAS (along with the other known problem: QNAP - Not Showing Local Folders Anymore). If the Core runs on WIN11 there is no problem.

The guide contains troubleshooting hints to potentially resolve the problem.

This guide doesn’t solve the two problems. The issues appeared suddenly in a fully functional system.

The linked guide is not supposed to solve both problems. He’s about one of the two. He also contains only troubleshooting hints – the actual troubleshooting and solving has to be done by affected users.
As per the title, I assume this thread is about the inability to reach the Roon Cloud Servers. You already know about the main thread for your other issue from previous threads you started on the forum. You can look there for latest status updates on it (for short: it’s still unresolved; workarounds exist and work for most users).

Then something has changed obviously. If you do not wish to troubleshoot your issue and/or reveal details about your network/NAS setup, I’m unsure who should be able to help you resolve your issue.

Good luck with figuring that out.

The NAS has been running for over a month because I opened a ticket with QNAP, hoping to solve the problem of the folders. Tonight, I tried to move the Core to the NAS and the metadata problem disappeared by itself without any changes to the NAS settings. The problem of folder detection persists. It follows that there is an incompatibility with the CORE version running on the NAS, also because I have never had problems with the CORE on the NAS for almost two years.

Hey @Nicola_Sforza,

To confirm, you are now only running into issues with your NAS core not being able to see and add your watched music folder?

If possible, can you provide more details about your music folder? Is it on an attached SSD? Please share a screenshot of both the file path of your music folder as well as your roon storage settings.

How long has this issue been occurring? Are you able to add other folders to your watched list?

News of the day. Yesterday the new version of Qfirewall V2.3.0 came out and I installed it. At the same time I “pointed” the folder via IP address (which did not work before) and: miracle !!! The NAS now always sees the folder where the audio files are saved even after reboot! The solution (not worked till today) is to use QNAP IP address instead of local name in ROON Storage location.
Eg:\192.168.x.x.\Music where \Music is a folder shared on my local network.
I installed Roon on the NAS from Jan 2020 with no issues at all since one month ago. Before I put Roon core on my desktop PC with no issues. The NAS is QNAP TS453BE with 2 SSD (Cache acceleration) and 2x4TB HDD and 2x18TH HDD.

image

The party lasted one afternoon: the problem came back strongly. The unit is not available.
Roon sees only Qobuz albums.

image

And how much RAM did you install? With over 100k tracks, Roon needs a substantial amount of RAM and the rest of the NAS (QTS and other apps you may have installed) too. AFAIK it was sold with 4GB RAM only and is specified for a maximum of 8GB total.
Your NAS may just not be powerful enough (not enough resources) for what you put upon it.

Hey @Nicola_Sforza,

Thanks for the update, and for letting us know you’re still running into issues with your storage! After enabling diagnostics on your account, it looks like you’re running an import, and the Roon identifier is matching to existing tracks which were marked as deleted. It’s using the old entries (referencing the new file locations) rather than re-creating, re-analyzing, and re-caching images.

If possible, are you able to reconfigure your music storage on another available/open drive on your NAS? From there, remove the watched folder you have in Roon and re-route your file path to the new drive you’ve set up. Be sure to remove the watched folder path before doing anything else, and to remove the physical drive itself safely.

Let me know if this is possible, and if you run into the same issue :+1:

My NAS has 16Gb ram.

Sorry but 16GB is beyond the specification from QNAP and Intel. Crazy things might happen if more than the specified 8GB are actually being used. It’s probably best you let your Roon Core run on the PC, which works flawlessly as you wrote.

1 Like

Now the metadata works well. Also with 8GB the “QNAP - Not Showing Local Folders Anymore” persists.

I’ll Try this evening or, at least, tomorrow morning.