Microsoft Surface Tablet Mode - Keyboard does not display, crashes search field

Core Machine (Operating system/System info/Roon build number)

Windows 10 version 1903, Microsoft Surface Pro 6. Roon 1.6

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

WiFi via a Verizon Actiontec MI424-WR

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Mac Mini connected via USB to a Rega DAC

Description Of Issue

When I’m in tablet mode on my Surface Pro and click on search, the search field opens but the keyboard does not pop up. If I then open it manually via the task bar, the keyboard opens for a second then closes and closes the search field. The search field works fine in laptop mode with the attached keyboard. Any thoughts?

Does the on-screen keyboard work in other apps?

I can agree. This bug is also existent on my Surface Book 2. What You can do is to open the keyboard app first and then the search field within Roon. I hope that the next update resolves it.

Hi @Stephen_Bettridge,

In Settings > Setup do you have Enable On-Screen Keyboard enabled in Roon?

This has been reported before - I thought there was a ticket opened for it?

Yes, the on screen keyboard works in other apps

Thanks for this. It fixed the problem of the keyboard not popping up, but it still exhibits the crashing behavior where the screen flashes or stutters and then closes both the keyboard and the search field

I found one similar thread but it seemed to be that the person hadn’t configured there Surface properly and there was nothing about the search field/keyboard crashing

1 Like

I have the same issue as @Stephen_Bettridge

No, this issue of the on-screen keyboard opening and closing when in tablet mode has been reported, and a Ticket opened:

It happens on my Windows tablets as well (a ThinkPad 10 and a Surface 3) and it’s an annoyance. The workaround is to go into Keyboard mode, and manually open the on-screen keyboard using the keyboard icon in the Taskbar.

Oh I see, I guess I didn’t use the right keywords in my search

Hi @Stephen_Bettridge /@Mark_Hyland,

We’ve recently released Roon 1.7 (Build 500) which includes changes that should improve this behavior. Please give it this a try and let us know how it goes!

You can read the full release notes here:

The Team at Roon Labs

The secret to getting this to work is to make sure that Roon is running in fullscreen mode. If it runs in Windowed mode (i.e. there is a Windows titlebar showing), then the onscreen keyboard will disappear when you try to type into the Search field.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.