Migrate to QNAP issues

I acquired a QNAP TVS-471 yesterday with the intent of migrating my core off my Mac Pro. The migration went okay and the Watched Folders I changed to recognize the new storage are working great. I have two issues. I added my iTunes library by pointing to the correct iTunes folder in “add iTunes Library”. I have almost 5000 songs. I started last evening about 11PM and this morning the progress circle is still spinning and no songs or albums have been added yet. The other issue is with Tidal. If I enter the correct username and password I get an error message that says “There was an unexpected error, please check your account details.” I know my username and password are correct. All of this worked before migration. What did I do wrong?

The iTunes XML import is not working correctly on linux based computers/devices. As a workaround you could either add the iTunes Music folder as a watched folder. But this will not add any Playlists etc.

In my setup I wrote a small bash script that will correct the paths in the xml file and save it to a new file that can be used with Roon. But you need to run it again, if anything changes in your iTunes Library…

Ah! I see. I don’t really use playlists so I guess I can add it this way just fine. I was thinking that anyway. How about the Tidal issue? Any thoughts?

I have no Tidal subscription and only listen to my local music. Maybe someone else has experience with this issue?

There is something else happening here. I just tried to add my picture to my account and got an error message and when I go to the tab for Account in Settings I see a message that says “Error Retrieving Account Information”. It’s almost like the QNAP can’t see outside the internal network. Except that I can play my Internet Radio stations.

How is your QNAP connected to your network?

Have you already tried stop/start RoonServer in the AppCenter (or to reboot your QNAP)?

Yes I have stopped and restarted the RoonServer in the AppCenter. I did not reboot however. The QNAP is connected to a switch which is connected to a FiOS router connected to the Internet. Maybe there is a port on the QNAP that needs to be opened. I am not sure but there is definitely something happening that may be blocking my connections to the outside world (I think). I am going to reboot the QNAP.

Okay good news. The Tidal access and account access issues are resolved. I rebooted the QNAP but I don’t think that this solved the issue. After the reboot I reopened Roon and was asked to deauthorize my Mac Pro as a Core and then all my network devices started working with my new Core. I think that the configuration was still seeing the old Core as prime and would not allow me to authorize Tidal under this scenario. So now Tidal is working as is my iTunes library now that I added it as a watched folder. I am not sure migrating was the way to go here. I think a fresh new install would have been preferable but hey who knows. Thanks for the help. I think I am now 100% up and running. I probably got in my own way on the journey.

1 Like

I am glad you could figure it out. I’d recommend (if you did not already do so) to stop Roon on the MacPro and make a zip file of the “RAATServer” and “Roon” folder (in the user*s library folder) and delete these folders afterwards (keep the zip file for backup purposes). When you start Roon again, it should start like a fresh install. Select to connect to a remote core.
By that you can make sure that there is no server running in the background.

Thanks. I already did some of that by renaming the old core files. I will do the rest that you suggested. I am working on some clean up right now. I appreciate all your help and suggestions.

Уважаемый Кристофер, прошу Вас помочь с установкой roon на qnap-251 я не могу понять как это делать. У меня выдается вот такая ошибка Тип Дата Время Пользователь IP источника Имя компьютера Содержимое
Ошибки 2016/11/29 19:25:50 System localhost [RoonServer] Shared folder “RoonServer” could not be found. Please create it in the QTS before launching the package.
Как его там найти или точнее как на него зайти?

Dear Christopher, I ask you to help with the installation on the QNAP roon-251, I can not figure out how to do it. I have now issued this error Type Date Time User source IP Computer Name Content
Errors 2016/11/29 19:25:50 System localhost [RoonServer] Shared folder “RoonServer” could not be found. Please create it in the QTS before launching the package.
How to find it there, or just like to go to him?

Hi Boris,

You need to navigate to the Shared Folders icon on your QNAP desktop and create a new share called RoonServer. Then you should be good to go.


Привет, nick_riches! Не совсем понял как понять создать? Из чего я его создам?

Hello, nick_riches! Not quite sure how to understand to create? What I will build it?

У кого нибудь есть возможность зайти ко мне на mac через teamviewer ?

Someone has the ability to go to my mac via teamviewer?

Maybe this helps:

You need to create a shared folder “RoonServer” as shown in the picture below.

Большое Вам спасибо!)) было очень легко, вот только теперь другая проблема как мне добавить туда все мои музыкальные файлы itunes и медиатеку которая находится на qnap?

Thank you very much!)) Was very easy, only now another problem how do I add music to my itunes library files and which is on QNAP?

Go into Settings in Roon and navigate to the Storage screen. Click on the + Add a Folder button and point that to your music folder. This should add your music automatically. Hope this helps.

Please also read the instructions on my blog how to add folders on QNAP devices. This might differ a little bit on QNAP NAS.

1 Like