Migrating from MacOS to Windows (Roon Server)


Not having much success here: I did the trial thing on a single MacBook Pro (Core, Control & Output) for 30-days whilst comparing different software products. Then converted Roon trial to a subscription because I especially liked Roon’s UI.

Now I’m trying to set-up a headless environment with a NUC; I’ve downloaded Roon Server, backed up Roon database but I can’t find anything that tells me, step-by-step, how to transfer the license to the new server environment. I don’t get options for anything other than ‘Run’ or ‘Quit’ on the server install on the NUC. I assume I need to do this with Control on another device but can someone give me step-by-step instructions please, rather than me doing experiments?


Here you go: https://kb.roonlabs.com/Migration

Thanks Mike but still no joy.

I’m following all the instructions but it’s problematic. See attached screen grab. This is what I get with every 5-10-secs “. . . Failed” after “Connecting . . . “


  1. I’m wanting to transfer license from the trial/temp MacBook to the W10 NUC;
  2. The NUC is ethernet connected, I’ve tried the Mac connected via Ethernet & wireless;
  3. I tried via an iPad with the same messages?


There’s no license, per se, to transfer.

Answer Run to the Server, then you should be able to connect to your NUC.

Hi @Steven_Pryce,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Are you able to temporarily connect the Mac via Ethernet? If you do is there any change in it’s ability to connect to the Core?

Once you are able to connect to the NUC you can authorize it as your Core.

Do you have any active antivirus or firewall on the new Core machine? If you temporarily disable them is there any change in behavior?

Can you verify that you are not still running a Roon Core on your Mac?

Thanks Dylan.

“Newbie” status has me running around in circles bit.

Pretty straightforward network:

  • Cable Modem (Telstra)
  • Connected to 8-port Cisco switch/hub
  • which is connected to Synology NAS
  • The new NUC7i7BNH ethernet connected to the same network
  • PS Junior DAC>Cyrus Monoblocs>MA Platinum 300 speakers

I had a trial license on the Mac & connected this via ethernet & eventually figured out how to access my library on Synology NAS. Used Roon Remote on iPhone6 = no problem. Confirm that Roon now completely deleted from Mac.

Now the NUC doesn’t want to find the Synology. With the problems I had in setting up the NUC as Roon server I REALLY want to have this as a headless install; I’ve read the blurb & if I’ve understood correctly I install Roon Server & delete the previous Control/Core - see screen shot below - then use iPad as Controller? Your documents refer to Roon Folder - I don’t have that, just what you see in the screenshot?


See More from Dylan Caudill via Roon Labs Community

Hi @Steven_Pryce,

Can you try re-uploading the screenshot? It isn’t showing for me here.


Try this!


Hi @Steven_Pryce,

On Windows you’ll need to follow these instructions to find the Roon folder:

  1. Open Windows Explorer
  2. Click in the address area to the right of the text, to make it active like typing in a web browser, and type %localappdata%
  3. Find and open the Roon folder

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.