Migrating Roon Server from ROCK to Win 10 causes re-analysis of tens of thousands of files

Roon Core Machine

Migrating Roon Server from ROCK on NUC6i5 to Win 10 on NUC6i7
Current ROCK with fully identified media library on external LaCie 5Tb, backed up to SSD Portable. This backup restored to new Roon Server install (on new Win 10 OS) on the NuC6i7 with THE SAME portable 5Tb LaCie

Networking Gear & Setup Details


Connected Audio Devices


Number of Tracks in Library

The portable LaCie holds abou 8.500 albums + 350 albums on Qobuz

Description of Issue

After the restore, and login on the new Core/Server (through controller on iPad Pro) it seems that the whole library needs to be re-analyzed? The Album count on the home page stays still, but the small spinning circle tells me that it identifies X no of new tracks continuously (at least an hour or so up and running).
Under Settings Library and Background anaysis i see that the number of tracks to be analysed increase constantly, and i quit this at around 30K tracks.

I have migrated my library in various scenarios before, but the tracks have previously been identified as “the same”, and there has been very limited re-analysis.

Has something changed in track identification that causes this or what? I’m on build 884 of course…

Hey @Mikael_Ollars,

Sorry about the delay in getting back to you… :pensive:

I wonder, when migrating your library this time around, have you followed all the steps outlined here?

Also, what are your Audio Analysis settings?

Hi Beka, thx for getting back on this.
I would like to say that i followed the guide lines, as stated in the KB, yes…
And Analysis Settings were set to OnDemand: Fast and Background were using 4Cores.

This is not the first time i’ve migrated a library to another Core, and my impression has always been that Roon identifies the already analyzed files as long as they haven’t changed.

However, i actually decided to NOT use the NUC6i7 but rather go back to the fanless NUC6i5 with ROCK. So we can close this, as i took another route.

Thank you!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.