Migrating the Core from a NAS to a new Server

Core Machine (Operating system/System info/Roon build number)

Windows Sever 2019
Roon Remote and Core 1.7 (build 537) 64bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet network, TP-Link and Etherregen switches

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Lumin U1 Mini

Description Of Issue


First of all I am a very happy and satisfied Roon user since 2018, had no problems until recently.

But now I have a big one and it is getting very frustrating. I thought moving my Core from my NAS to a new Windows Server should be a quite simple and straight forward task but I was wrong. I started it 3 days ago and it is still not done.

I believe I am doing everything as it is described here:

This is what happened so far:

Originally Roon core was installed on a Qnap NAS (name: MediaNAS)

Music folder was and still is on the same NAS drive. The Roon core was actually installed within the same library as the music files.

A successful scheduled and forced backup was performed from Qnap to an exFAT formatted USB drive.

Both core and control is updated to the latest version.

Roon Core from Qnap is now uninstalled, and all Roon files have been deleted from the NAS after the first unsuccessful recovery. Unfortunately the old log files from the NAS were deleted too.

Roon Core is now installed on a new Windows 2019 Server (name: Roon-Server).

Roon Control was removed and now re-installed again on the same Win 10 Laptop PC.

After the first launch of the new core (name: Roon-Server), but BEFORE logging-in to the new core I started the restoration (exFAT USB drive connected to new core). At first I did this wrong, logged in first. Before the second trial I removed the core and control, and re-installed them again.

The restauration took about 2 hours (5000 albums) and finished successfully, requested a re-launch.

After re-launching the core and the control from the PC the new core iwas found , but with the OLD core’s name: MediaNAS, but showed the correct IP of the new Win Server.

Even though the backup restoration was “successful” it did not find the music library on the NAS, I had to add it manually, and after adding it the identification started again…another 2 hours and all albums were imported.

After importing my music everything worked, except my previous personal data was gone, the backup restauration was actually unsuccessful.

So I decided to start the backup restauration again (at this time all albums were imported already) but the the result is the same, after it’s finished there is no music in the library, so asks me to add music…

Please help to find my problem.


Hi @Zsolt_Kadas,

Can you share a screenshot of Settings > Storage?

When you add the watched folder to Roon, you want to make sure that you completely remove the old watched folder first.

Hi Dylan,

This is what I see now, after trying to restore the backup.

I did not remove the old watched folder before adding the new.

I have just finished the whole process again and did it as you suggested.

It is okay now, thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.