Migration from NAS to Internal Storage

Hi all,

So, I’ve followed the guidelines about migrating from a NAS to internal Nucleus storage while keeping your edits in-tact. And it doesn’t seem to work.

Am I doing something wrong? I Backed up the database to my NAS drive, restored it, and then copied the files over to me new SSD internal storage drive. I shut down the Nucleus server before copying, then restarted, but my edits are nowhere to be found.

Anyone know what I’m doing wrong?



Hi James,

Did you follow this step in the Configuration, Internal Storage section of the Migration Guide?

  1. Go to Settings > Storage and disable all current watched folders except Internal Storage. To do this, select the 3 dots next to the storage location and then choose Disable.

Cheers, Greg

I did, yes. Twice. Sadly that didn’t work.

To be more precise, I’ve followed the migration guide twice now. The second time, I reformatted the SSD from the Web Administration interface, wiped the database, re-imported my entire collection from the NAS and restored the database backup before following the guide.

Still no sign of my edits, which is annoying as I spent goodness knows how many hours making them during my free trial.



Did you give Roon time to reanalyze your library? It may take a while for Roon to go through and identify your files in their new location and match with your library.

I’m moving your thread to Support category and will tag @support.

Cheers, Greg

Hi Greg,

I did yes, but that didn’t seem to make a difference.

It would seem, however, that the 20th time was the charm. I’ve no idea what I did differently this time, but I’ve now been able to disable the old folder/share and enable the Nucleus Internal Storage folder and the OS rescanned the files and kept the metadata in tact.

Really weird, but hurrah! :slight_smile:

Thanks for the help, in any event.




Great news. Enjoy the Nucleus!

Cheers, Greg

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.