MiniDSP SHD Roon Ready

I just got an email saying the MiniDSP SHD got its Roon Ready status. But when I go to change the volume it does not work. There is a volume slider like on all Roon Ready devices but it doesn’t


make any changes to the music. I reset my Roon Core (Mac Mini) and made sure I was all up to date on all my devices. I also can’t edit the volume range. I have included a picture. I’m not sure whose end is messing up Roon or MiniDSP. Thanks.

Not sure how helpful this it, but it’s working correctly on my system (also a Mac Mini core).

EDIT: Have you enabled the “Roon Ready” SHD output in your audio settings?

I did enable the Roon Ready on the SHD. It shows up with the Icon for the SHD. Everything seems fine it’s just the strange volume control situation. So your volume control starts at 0 and goes to 100? Thanks for your response!

I have it set as Device Volume in my settings, so my volume control tracks the SHD one. It goes from -127.5db to 0.0dB and I currently have it set at -30dB. I can set limits and change the volume directly through Roon.

My volume is doing the same thing in roon. -127.5-0. However, when I change volume in roon it does nothing. I’ve gone back to the factory setting and everything. So strange. I’ve been waiting for my SHD to be roon ready for a year. Thanks for your feedback.

Have you completely removed power and usb connections from the SHD and ensured it’s on the latest firmware

Yes. I unplugged from the wall and did the same to my Roon core. I went to the shd volumio local page and checked again for an update. Nothing. It’s strange this is happening because it is showing up in my audio devices as Roon ready. It was unauthorized yesterday.

@Ross_Cuzick you’re most likely using an outdating firmware which is different from Volumio. Please go to our user downloads section, grab the latest firmware and update your SHD as per the manual p77. (https://www.minidsp.com/images/documents/SHD%20Series%20User%20Manual.pdf)

Once you do, you will have full volume control functionality as expected. :slight_smile:

I was able to update. I do have use of the volume slider in roon now. However, it now shows that I’m using DSP volume so not allowing it to be bit-perfect.

Very strange. I have a SHD Studio but Roon says I am using analog output. How come?

That is weird. Yours says analog. But should say digital. I still can’t use it. It says it’s using raat but has this dsp volume thing.