Missing Albums In Library

Well, not really missing, but they don’t show up in my Library. I have to use the Search function to find the Artist or Album. Strange.

Any ideas?
Chris

I would guess that you still have a focus in effect.

Do they show up with Show Hidden Tracks And Albums set to Yes in Settings > General?

If so, it’s possible they’ve been automatically flagged as duplicates, or inadvertently set as Hidden.

If Roon is hiding the album you should be able to click the little Edit pencil on the album page, and choose Unhide Album

Focus only used to identify library. And Mike, I set “Show…and Albums” to Yes. But still no go. If I find the album via search, and click Edit - Unhide Album still no go.

And I have a medium sized collection and have no idea of what’s not being shown. I just found Miles b/c I was wanting to listen to him.

Can you paste a screenshot of the album details page here?

Any help Mike?

Have I been forgotten?? lol

Can you find Miles Davis from the Artist screen?

Silly question, are you looking under “M”? You can change sort to last name in settings > general.

Cheers, Greg

No. And I tried sorting by last name too…still no go.

Dropping a flag for @mike

Hey @fore – sorry for the slow response here. This is definitely strange.

Can you try going into either the album, artist, or track browser (or all three), pressing / to open the Focus popup, and then type Miles Davis in the filter box? It sounds like you won’t be seeing anything but I just want to be doubly sure before we look deeper into this.

Sorry again for the trouble here @fore! We’ll figure out what’s going on here.

Thanks Mike. No, actually all 34 albums, artists and tracks come up when I Focus on Miles Davis. But still, none are showing up in the Library without the use of Focus or Search functions.

And again, this if for more than one…and I have no idea how many others are ‘missing’ from the Library at this point too.

Hi,

I’m in a similar boat to @fore on this one.

I just finished ripping about 3,700 albums from my CD collection using dBpoweramp - a number of CDs weren’t ripped cause the metadata wasn’t found in the CDDB. I created a pile to tackle later which has arrived.

I am using XLD to rip the short-stack of CDs - start with Irene Torres and the Sugar Devils, album by the same name. I edit the metadata first in XLD and then rip the album. All goes fine and rips have been confirmed to work fine - played them in Adobe Audition.

I tell Roon to force a re-scan to pickup the new album. Nadda. It won’t see it.

Metadata for the album appears to be fine - did some massaging in Kid3, per the screenshot.

Any suggestions? I have set Roon to not hid hidden tracks / albums. Doesn’t show up, can’t find it in searches or focus. Thoughts?

1 Like

Have you tried searching by song, for instance “Without You”?

Cheers, Greg

Yup, tried that @Greg .

Odd. We’ll have to flag @mike.

Cheers, Greg

It’s likely something about the metadata Roon isn’t crazy about.

As a work-around, I tried ripping the same CD(s) with iTunes and guess what, when I add that music folder, Roon loves it and away we go. Very odd.

Unfortunately iTunes won’t rip to FLAC which is what I’ve built the database on.

You may be doing this, but you could rip in iTunes to lossless ALAC and then convert to FLAC. Kind of a pain though.

Cheers, Greg

@Greg Nah, just leave them as ALAC - don’t really see the advantage of converting, do you?