Missing artist pictures

Hi Roon team,
Please check the picture attached. Most album artwork is okay and tidal files seems okay too. But I can’t get artist pictures at all. Music files on NAS. and Roon server is on Linux OS.

What seems I’m missing? @support ?

I searched some similar issues, but it was answered like I should add image files?? isn’t it supposed to be supportive on roon automatically?

Please confirm.
Thank you~

what is the iPad iOS version and roon version installed on the iPad? Thats looks like a pretty old iPad

you need at least iOS11 and should also be running the latest Roon to keep things compatible

Hello @May_Park,

Thanks for contacting support, I’d be happy to assist here.

  • Can you please confirm that you have the newest version of Roon installed on the iPad?
  • Have you tried closing out of the iPad App and then re-launching it? You can close out of the app by double pressing the home button and then “swiping away” the Roon window
  • Does rebooting the Core machine help resolve this issue?
  • Does this same behavior occur on your Linux machine itself or on other Roon Remotes?

Please let me know your replies to the above questions when possible.


Hello @noris
Thank you for the prompot support, here is an answer on your questions.

  • Yes, the newest version of Ron installed on the ipad and android mobile and still has the same issue.
  • Yes, sure thing, but still has the same issue.
  • Yes, it still has the same issue after rebooting the core machine and control devices as well.
  • The other linux machine is running LMS, so it’s not a matter to compare and it works fine with artists pictures.

Please help.
Thank you.
Best regards, May

Hello @May_Park,

We have seen issues such as these previously be solved by clearing the cache for the machine. Can I please ask you to perform the following steps for the affected machine?

  • Quit Roon (or RoonServer)
  • Find and open your Roon or RoonServer folder
  • Locate and delete only the cache folder (Roon/Cache)
  • Restart Roon

On Windows this folder looks as follows and the same structure should be visible on Linux OS:

Please let me know if the above steps resolve this issue or if you need further clarification.