Missing CODEC after 1.8 install

Core Machine (Operating system/System info/Roon build number)

INTEL 10 NUC running ROON 1.8 version.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Exfinity X1 router 1gig internet using ethernet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

I have the CODEC stored at ROON/DATA/CODECS folder. It was working before. I reinstalled it and still not finding the CODEC stored in the folder when playing music at ROON.

Hello @George_Rebong , just to confirm - you have installed the uncompressed ffmpeg file as detailed here?

Hi @George_Rebong

Can you share a screenshot of the Web UI as well as a screenshot of the ffmpeg file in the codecs directory? Thanks!

Hi Brian,
Yes. I installed the uncompressed file. I just noticed the Qobus is OK but when I change service to TIDAL this is where I am getting the MISSING CODEC.

Does the message only occur on specific tracks?.

As @dylan, says, a screenshot of the Web UI would be very useful. This would confirm that the codec file has been correctly recognised.

Hi Brian,
Sorry for late reply. Here is the WEB UI screen.

System Status

Serial #1C697A637F78

Operating System



Version 1.0 (build 227) stable

Running 4 days, 23 hours, 17 minutes, 12 seconds.

Roon Server Software


Missing Codecs

Roon Database & Settings



100% of 458 GB available.

Hope this help.
Thank you


This text will be hidden

Hope this WEB UI screen shot is better.
Thank you

Looks like there is something wrong with what you’ve installed. A screenshot of the ROON/DATA/CODECS folder of your ROCK might be helpful too. I link the guide again, please give it a thorough read if you want to try again:

Just to be absolutely clear, George, the ffmpeg-git-amd64-static.tar.xz file needs to be decompressed twice - after the second decompression you should see

And it is only the ffmpeg file that should be placed in the codecs folder.

This is what it should look like:

If ffmpeg is not showing in that folder, you might not have decompressed it properly.

1 Like

Thank you very much to all you gave me directions to solved the MISSING CODEC.
Great support here.
Love ROON.


so what was the solution? decompress the ffmpeg file twice?

my problem is the same, but i cannot see the rock/data/codecs directory structure, just the ROCK System Status window with missing codecs message

4 posts were split to a new topic: Difficulties setting up Rock

4 posts were split to a new topic: Nucleus problems after update