Missing Files and scanning for weeks

Howdy,
I’ve had a Roon for a few weeks and have noticed a pretty large number of my albums missing. I searched for them in every way I can imagine and they aren’t there. They are definitely in the file folder and play fine using a variety of other Apps. I have a pretty big library but as far as I can tell it’s not as crazy big as others around here. I looked at the file names and there is nothing obvious. These files are not in the “skipped files” list either.
As an example I have
zappa1977-10-31 The Palladium - New York, NY
that did not show up.
Then this showed up just fine.
zappa1977-10-29 The Palladium - New York, NY [Show 1]

So I keep looking at the settings/storage screen to force rescan but it’s grey’d out because the initial scan has not finished. It appears stuck on the numbers below.

I’m running Core on a Mac Mini running High Sierra. The file server is a synology.

Any suggestions would be appreciated.

Thanks
Mike

16%20PM

what are the hardware specs of the NAS and the MacMini and the network connection type lan/wifi speed etc

its also possible its stuck on a corrupted or bad file.

@support

The 2014 Mac Mini is 2 core (4 thread) i7 with 16gb of memory

The Synology is the 1817+ with 8gb of memory

I don’t know where the logs are but I’m going to dig through them to see if I can find something about where it might be stuck in the scan.

Taking an educated guess, I’d say this is a permissions issue. If you’re good with command line I’d suggest you use that. Depending on what networking protocol you are using (NFS / SMB / AFP) you’ll need to align your UID and / or GID and ensure you have read on the file. If you’re not sure what commands they are, have a read up on chmod and chown. Alternatively I’m sure Synology has a GUI, upon which you should investigate that ‘all files and subfolders’ have had the correct permissions applied. This may also help - which I wrote for Plex but the concepts are the same. NAS units are great, but they do need a bit of work with permissions. https://www.tech-knowhow.com/2016/03/how-to-plex-permissions-linux/

ps Groups are your friend with NAS units. :slight_smile:

I will verify this when I have a bit more time but the permissions for files that are successfully imported into Roon are the same as some that are not from a small spot checking. I didn’t compare GID and UID yet

You didn’t specify a file extension in your example above.

Roon is more limited in the file types it will import compared to many other players. There is no support for some very common types. eg. .iso, .ape and also un-split flac’s + .cue. I haven’t looked in a while and this could have changed but unsupported files probably still do not show up in the skipped file list. Supported file types are in the knowledge base:

https://kb.roonlabs.com/FAQ:_Some_of_my_files_aren’t_showing_up_in_Roon

Hopefully this is not what is causing your problem as depending on genre there will be a lot of pain converting them.

Sorry, I forgot to mention that the files are flac.

From other threads about “endless scanning” I would assume that there might be one or more files which Roon stumbles upon and cannot recognize. Usually this gets solved with (more or less) extensive log analysis supported by - guess who: @support :slight_smile: *
But if you want to try you could check the log files yourself - maybe you’ll get an idea which files are trouble makers.

* Hopefully I haven’t flagged the team - @Mike_Falcon , that would be up to you. :wink:

@support

What information do you need to help me with this? I can provide the logs easy enough but I know y’all will need other specifics.

I do not believe it is a permissions issue as far as I can tell. I’m not an expert, but I check the permissions of the library folder and the individual files and folders that are working vs the ones that are not working and nothing is amiss.

I dug through the logs hoping to find something but I’m over my head here.
One bit of information that I failed to mention is that my library is still being “analyzed”. It’s about half way done. I didn’t appreciate how long this would take in the beginning so I had it on Throttle mode. I’ve since changed it to speed things up.

Thanks everyone for helping me out here. I really love Roon.

Helllo @Mike_Falcon,

I’d be happy to take a look here at what could be causing this issue. Just to confirm, even after you changed the analysis from Throttled Mode, the numbers of tracks imported and files scanned does not change, right?

I have gone ahead and enabled diagnostics mode on your account and what this action will do is next time your core is active a set of logs will automatically be generated and uploaded to our servers for analysis. I’ll take a look to see if we can uncover the file(s) causing the issues once they reach our servers. Please let me know if the number of files imported changes at all or if it remains the same.

Thanks,
Noris

Not exactly. Although it does add new files I add to the scanned folder. My core is active currently so it should be sending the info. Should I restart it?

To be more clear. The number of imports only changes when I add a file to the folder. Otherwise it stays the same.

Hello @Mike_Falcon,

I believe I have identified some files/folders that could be causing issues and although I can’t say for sure that these are the cause, it may be worth a try to see if you can remove these from your watched folder and see if the import progresses:

/Users/mfalcon/Library/RoonMounts/RoonStorage_af38532b047612b504befc2014a759ba883d71d7/music/Music/2Pac/Greatest Hits/1-04 God Bless The Dead.flac
/Users/mfalcon/Library/RoonMounts/RoonStorage_af38532b047612b504befc2014a759ba883d71d7/music/Music/Brian Eno & David Byrne/My Life In The Bush Of Ghosts/
/Users/mfalcon/Library/RoonMounts/RoonStorage_af38532b047612b504befc2014a759ba883d71d7/music/Music/Frank Zappa & The Mothers Of Invention
/Users/mfalcon/Library/RoonMounts/RoonStorage_af38532b047612b504befc2014a759ba883d71d7/music/Music/Medeski, Scofield, Martin & Wood/MSMW Live_ In Case The World Changes Its Mind
/Users/mfalcon/Library/RoonMounts/RoonStorage_af38532b047612b504befc2014a759ba883d71d7/music/Music/Prince/Chaos And Disorder
/Users/mfalcon/Library/RoonMounts/RoonStorage_af38532b047612b504befc2014a759ba883d71d7/music/Music/Skerik/Left For Dead In Seattle
/Users/mfalcon/Library/RoonMounts/RoonStorage_af38532b047612b504befc2014a759ba883d71d7/music/Music/Marc Johnson/Shades of Jade

Note: If there is not specific file format at the end (such as .flac or .m4a) then multiple files in that folder could be problematic, please temporarily move the entire folder out of your watched media location.

After moving these files, please restart your Roon application and let me know if the import progresses.

Thanks,
Noris

So, I “took care” of these files. Most of these were the same album spread across 2 folder that had different letters capitalized. I.e. one folder had “Shades Of Jade” and one folder was “Shades of Jade” I removed them, cleaned the library, fixed there metadata and put them in all one folder.
This has to do with using iTunes for many years. Ugh.
So, this has fixed the scanning being hung up but some files are still not being imported. I’ll try to find examples but the files not being imported have “.flac” at the end. And they play fine.

Hello @Mike_Falcon,

Glad to hear that the import is not stuck anymore. Just to make sure I’m understanding you clearly, these files do not appear when you search for them in your Roon library and you can confirm that the folder is inside your watched media location? If so can you try triggering a Force Rescan for that watched folder? You can do so in Roon Settings -> Storage -> 3-dot drop down menu -> Force Rescan. The option should look like this:

I would also check to make sure that they’re not under Skipped Files.

Thanks,
Noris

Yes, it appears we are all good now. The missing files are there.
I’m glad we figured out what was choking it up. Many Thanks,
Mike

@Mike_Falcon,

Awesome, that’s great news!

Would you by any chance be comfortable submitting a few of the affected media files so that I forward them to QA to see why it would be causing such issues? Hopefully you haven’t completely deleted them but if you have no worries, I was just wondering so that we can try and prevent similar situations in the future. I will PM you instructions shortly on how to send us media and if you can do so, that would be great!

Thanks,
Noris

1 Like

I will gladly upload one of the files if you like but I changed the metadata and folder names. I think what choked the scanner was the folders had the same names except different capitalization on certain letters.
Half the files are in the folder
Shades Of Jade
the other half in
Shades of Jade

Once I changed the Album to being consistent, removed them, and re-added them everything worked and it finished the scan and seemingly added all my files. This is from the late 00’s when I used iTunes to rip my discs. It did this, I don’t know why.
Would you still like me to upload them even with the metadata changed?
Mike

Hello @Mike_Falcon,

Thanks for letting me know about the changes you made to the files. Since they are not the exact ones that caused the issue, you don’t need to upload them for analysis. I’m going to go ahead and mark this thread as [Solved], but if there’s anything else going wrong with your Roon setup feel free to either PM me to re-open this thread or start a new one, thanks again for contacting support and I wish you a great day!

Thanks,
Noris