Missing Genres but present in Albums

When I view Genres in Roon, I have only 22 genres displayed of the 27 actual genres in the library.
For example,

shows the 22 genres sorted by name and you can see that no genre “French” is displayed.
this shows the details for a Jacques Brel album and it shows that Genre for this album is “French”. A review of the hard drive that stores the library shows that all 27 genres are present.
Any suggestions?

Select “Show Genres From Files Tags” in Settings, first tab.

That is how it is set.

Does anyone have any suggestions about what else I can try to display the missing Genres?

Any chance you’ve set up genre mappings?

Settings > Setup > Genre Mappings

That is interesting, Mike.
As you can see from the third screen shot above my settings are No to Show Roon Genres and Yes to Show Genres from Tags. So I have never gotten into the Genre Mappings. Here is what I see:

In this Image African, Blues, Brasil, Classical, Cocktail, Collection, Comedy, European, Female Vocal and French are genres in my file tags. In some cases these have been mapped to Roon Genres: Blues, Classical, Cocktail, Comedy and French. In the first screenshot above, I can see that Blues and Classical are displayed in Roon, even though they are mapped to Roon Genres and I have a setting not to display Roon Genres. On the other hand Cocktail, Comedy and French that also map to Roon genres are not displayed. So if the genre mapping is to blame because Roon genres are not displayed, that does not why I see Blues and Classical but not Cocktail, Comedy and French.
Do you have any suggestions? Thank you.
P.S. this was a clean database in 1.1 after these issues had been addressed and these setting enabled.

Can you focus on the genre French in the album view?

I’m wondering whether French is showing up as a sub-genre. I don’t have Celtic showing up in my main list of genres, it shows up in International.

EDIT: Forget that when I changed my genre setup to match yours and I now have 50 genres rather than Roon’s 26.


@mike do you have any suggestions for how to get access to the missing Genres?

Hey @PNCD – sorry for the slow response here. Can you search for one of the missing genres, navigate to its page, click the edit pencil, and confirm what its parent genre is?

Genre display settings in Roon are fully editable, meaning you can toggle the display of genres from Roon’s metadata or the tags from your files, and you can edit the hierarchy.

That said, hiding Roon’s genres doesn’t edit or automatically disable the hierarchy, so delta blues is still going to be considered a subgenre of blues. If you have both in your library and consider Delta Blues to also be top level, you can edit the parent genre to be “Top Level”.

Let me know if that clears this up Peter. Thanks!

How do you do this?


Click the edit pencil on the Genre page, then click Choose Genre in the Parent Genre section.

There’s a button in there that says Make Top Level.

Thanks Mike, that’s well hidden!

I must say I find it a bit obtuse and cannot seem to make it do as you suggest, I am on a iPad though which can make editing a bit flaky.


Excuse me, @mike, but I find this to be unclear.
Where would I “search for a missing genre”? Clearly they are missing in the Genres view. Clearly they exist in the file tags. My settings say to use the file tags but some do not display. 22 out of 27 Genres are displayed as expected and 5 Genres are not displayed but still exist in the files.
Let me be clear on something else: I see no Genres that are not those I have in the file tags. There is no display of Roon Genres being activated and suppressing my file tags.
So how do I find something that is missing?

@mike here is a screen shot of a track from an album that uses my Genre French. That is a Genre that does not show up in the display of Genres. I simply cannot understand what is going wrong with five of my file tags for five Genres.

Haha, it’s not that hidden. Genres are edited in the same place you edit everything else :smile:

Are you not seeing the Genre Picker popup? You may have to tap Choose Genre twice. Let me know if that’s the issue @Sloop_John_B.

Hi Peter,

Have you tried to search for the French Genre? Click the search icon on the top right and type French. You may have to scroll down to find the Genre French (after albums, tracks, etc.).

Does that help?

Cheers, Greg

The search feature :wink:

But guess what: I just put together a small test library, reproduced a setup similar to yours, and what do you know – we have a bug here.

As I mentioned, turning off Roon’s genres doesn’t change the hierarchy. French is actually part of our Genre hierarchy, and since it’s a sub-genre for something that doesn’t exist in your tags, there’s no way to navigate there in the Genres browser right now :expressionless: We’re going to look into this, Peter – thanks for the report.

For now, the work-around is still to just edit the genre. You can search for the missing genres (or click the genre on an album or artist page), and edit it to be top level. That should unhide it on the Genres page while we look into this.

Thanks again for catching this @PNCD!

@mike So at least I am not crazy.
But this also shows why I could NEVER accept Roon meta data. You have French in Western European Traditions, which, along with Caribbean Traditions and African Traditions and ahost of others, rolls up into International as the top level Genre. Meanwhile Italian exists on its own as a top-level Genre. Other stand-alone top level Genres include Brasil and World. In my opinion, this is dysfunctional and all I want you, Roon, to do is let me use my consistent files tags and never see yours. It is a show stopper.

Okay so lets say I want the genre Celtic to be a top level one. So I choose the Celtic genre

click pencil

now what do I do at this stage?

if I click Celtic I get

if I select make top level genre I have

I’m afraid to save this as I’m not quite sure what it will do.

<this isn’t intuitive>


Ok John,

I’m brave!

No Celtic.

I selected Top-Level.

Now it shows.

Cheers, Greg