Missing local audio device on PC[Solved]

Hi, just installed Roon on a Windows 10 pc and I can’t seem to find the local audio device. This pc is not acting as a Core. I can see the Sonos devices and HQPlayer fine. Just not the local audio (realtek) device so I can play through the local pc. The local audio device is working as I can hear windows notification sounds. Thanks.

Hi, @hammer, thanks for your report! Could you please specify what device you use as a Core? Wouldn’t you also mind sharing a screenshot of your Audio Tab (Settings-> Audio) with us?


Ivan

Had the issue myself a long time ago. Was caused by the Windows firewall. Did you block incoming connections?

Thank you. I am able to see the Core and the Core’s audio devices from the pc. Also, I am able to play to another pc’s local speakers from that other pc. The issue is on this particular pc, while I am able to connect to the Core, but I do not see this pc’s audio device even though the audio device is up and plays windows sounds.

Yes, I did read your problem description. Nonetheless, it is possible that you can see the devices on the core but not that of the local pc (remote), and can be caused by your firewall not accepting connections. So please check your firewall to be sure.

Thank you. What should I look for?

The easiest way to know if the firewall is to blame, is by turning it off and restart Roon (all on the pc that lacks the local audio device). If you’re using the default Windows 10 firewall, see these instructions: https://support.microsoft.com/en-us/help/4028544/windows-turn-windows-firewall-on-or-off.

If you can confirm it works when it is turned off, you’ll have to remove the firewall rule that blocks the incoming connection. Come back when that is the case. Also when it is not the case :wink:

Thanks for your help. The issue was my network profile was set as public and not private. After setting to private, I can now see my local audio device. Thanks for pointing out the network issue - I would have never found it otherwise!