Mobile App Not Finding Audio Devices

Roon Core Machine

Lenovo Idea Centre 3
Windows 11 Pro
Intel Core i5-10400 CPU

Networking Gear & Setup Details

Small Green Computer:
Sonore Optical Module Deluxe
Sonore 7v Linear Power Supply
TrendNet 4-port Gigabit Switch With fiber port

Connected Audio Devices

Meitner MA3 Integrated DAC via USB and Ethernet

Number of Tracks in Library


Description of Issue

My Android phone app suddenly stopped working. I get a “no audio devices found” “manage audio devices” message even though the audio device has been selected and shows on the screen. Everything is fine with the PC I have uninstalled and reinstalled the app, and have rebooted my phone several times, but the problem persists. Please help.

Your first screenshot is showing that you need to enable the default output on the phone for Roon to use it.

Geoff, thanks for your quick response. However, enabling that output causes the music to play through my phone rather than through my main 2-channel audio system which is connected to the Meitner MA3. I decided to unplug my Ethernet connections and reconnect them, then something strange happened. The phone now controls the music streaming directly through the Meitner on the Ethernet network but the phone no longer controls what is playing through the USB output of my PC (which is my Roon core). Thoughts?

Ah, I see now what you mean.

Is the phone now just displaying the Meitner/ethernet Zone, and not the Meitner MA3 ASIO Zone?

Are all zones visible on your PC (assuming you have the Roon UI installed on it)?

I’m wondering if this is a firewall issue. Can you check to see if your Windows Firewall has an exception made for roonappliance.exe?

The phone displays both the Meitner ASIO output and the Meitner device as Roon Ready, which I assume is the Ethernet streaming connection. The PC displays all zones. You mentioned in your next message whether there might be a firewall issue. I don’t see how that could be the case. The system has worked properly for 18 months and this issue arose just in the past day. I have no idea what could have triggered the phone app to suddenly lose control over the PC’s USB output.

Geoff, I forgot to mention in my last reply that the Small Green Computer components are for my Ethernet connection.

Just to confirm what you are saying, you can see the audio connections in Roon’s Settings > Audio on both the phone and PC, but you are not seeing the Zone Picker on the phone at all, just the “Manage audio devices” message?

So you didn’t check your Windows Firewall’s settings?

The reason I asked for this is because, with the last release of Roon, there has been a change to the architecture of the Roon software on Windows setups. The previous all-in-one installation of Roon has now been split up into two components, the Roon UI and the Roon Server. The latter now requires an additional Firewall exception to be made for roonappliance.exe. If that is not there, the Firewall will block any traffic from it to Roon Remotes (including your phone), and this traffic may include the necessary information for Zones to be displayed.

Geoff, good morning. Once I disconnected and reconnected my Ethernet connections the “manage audio devices” issue with my phone was resolved. The issue I have now is that my phone is not “seeing” the music being played through my PC, even though it’s "connected " to the PC as the Roon server. If I play music through the phone my Meitner MA3 now automatically defaults to the NET (Ethernet streaming) output rather than the USB output which plays music being sent from the PC. So, I can now have music playing through the phone and the PC simultaneously, but using the phone I have to switch to the NET output of the Meitner to hear it. This was not the case in the past. Whatever was being played through the phone would appear on the PC UI and vice versa. It’s an issue for me because the Ethernet network connection does not support DSD 128, which I have in my music library.

I checked the firewall issue you suggested and there are exceptions for Roon as follows:

Windows Security:


Bit Defender:


Bit Defender is my primary security app.



Geoff, I have discovered that I have synchrony between my phone and PC only if I choose the Meitner MA3 Roon Ready Zone, thus bypassing the ASIO USB connection. I’m not sure why that is the case now, but that’s the answer to my problem. I just can’t play DSD 128 music at full resolution. Ethernet streaming is limited to DSD 64.

Are you saying that you have both the Windows Firewall and BitDefender active simultaneously? I don’t think that is a recommended practice. Either one or the other, I would have thought.

No. They’re not able to run simultaneously. When Bit Defender is running (and it always is unless I have to shut it down to do an update) it supersedes the Windows application. I was just pointing out that in both instances there are exceptions for Roon with Bit Defender containing the exception for roonapplication.exe.

Are the Zone Pickers on your PC and Phone displaying different lists, and this is why you can’t select the same zone for both devices? Can you post screenshots of the Zone Pickers? E.g. here’s what I see on my PC and my smartphone:

(Note that my smartphone Zone - Surface Duo 2 - is being displayed on the PC because I’ve turned off the “Private Zone” default in the Device Setup screen)

You haven’t accidently set the Meitner USB Zone on your PC to be a Private Zone, have you? That would explain why it is not being seen on the phone…

1 Like

Geoff, problem solved! I had to turn off the “private” setting on the Meitner ASIO option. Interestingly, it has always been turned on so maybe the recent update affected this setting. I greatly appreciate your help. Have a great weekend.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.