MOCK - Tell us what strange gear you've installed ROCK on!

which wifi chips is supported by ROCK? as we are not able to add specific drivers to ROCK, better choose the right hardware.

What’s the betting on ROCK running on a Ryzen NUCalike like this ? My guess is that the Linux part would run, but drivers would be all over the shop.

Hmm, i think it’s time to shed my distrust for AMD, they seem to to really have begun to “get their crap together” as stated in the clip.
I’m still in the “AMD pulls power like water heater and run as stable as a Yugo from -74”-camp, but try and have an open mind.

I had an Athlon64 which I liked, but have been Intel for 2 or 3 computers since. I just ordered a new PC with a Ryzen R7 3700X. It’s got a 65 watt TPD so I’ll have to look elsewhere for my water heating needs.

1 Like

I think the most anyone can say is that the chips that are used in the supported NUCs are probably supported, although that may not be the case for the NUC 8 and 10 models.

See:

  • We recommend using the onboard ethernet, but support for some USB ethernet and WiFi adapters is included. Some of the above NUC7s have built-in WiFi, which we may support, but once again, we recommend using ethernet and not assuming WiFi works here, or is an acceptable solution for Roon Core connectivity.
    (ROCK KB Article); and

I was an Athlon64 fan and I admit a tendancy to support the underdog. That said, their processors were so bad for so long that I caved and bought Intel. Pragmatism means that my last upgrade was a Ryzen 7 but only as they now hold the bang for buck higher ground again.

2 Likes

Hello, am new to Roon and really enjoying the interface.

However, being a tinkerer (and always looking to save cash :slight_smile: ) I’ve installed ROCK onto an old Lenovo M600 Tiny (https://support.lenovo.com/us/en/solutions/pd100929/) running an Intel Celeron N3010 Processor with 4GB RAM.

Works perfectly with my Sonos set up (Sonos Connect V2) and other mobile devices, but intermittently fails to start my Chromecast Audio devices when selecting a new track. The play button moves to “pause” but I have to stop and start it again to get the track to play from Tidal (I don’t maintain a local library). Works much better when advancing automatically down a play queue.

Any thoughts or advice gratefully received. Thank you for reading this and I hope this is the right place to post this. If not, please let me know where I should. I know that the Lenovo is prob under spec’d for ROCK.

1 Like

How is the core connected to your network?

Ethernet cable over powerline network

The only thing I can suggest is you try a direct connection to your router/switch and see if the situation improves. I use Powerline adaptors with no problems but others have had issues.

Yup. It was working fine when I had the box on Linux Ubuntu, but I was having trouble getting Remote Desktop to work, so tried ROCK. Actually, thinking about it, you could well be right. On Linux it was running on Wifi. Might well be the Powerline…

I instelled ROCK in ZENMEI i5-7260 mini PC yesterday .
It play very well.

2 Likes

I try to upsample to DSD512 used my ZENMEI i5-7260u fanless mini PC ,it installed MOCK.
It still plays very well.

1 Like

Today ,I got a new ZenMei i7-8550U fanless miniPC from Chinese 1111shopping festival.
I installed ROCK Immediately. and upsample to run DSD512.
It performs very well.
By the way ,i7-8550U’s tempreture lower then i5-7260U’s.when two fanless miniPCs upsample to run DSD512.

Hi Guys, new to Roon.

I want to dedicate my i5 2nd Gen laptop (Z560 model) to MOCK. Now I did install the ROCK on it but couldn’t boot it beyond the initial large Lenovo window. No F2/F12 commands seemed to work either. The laptop just didn’t start after installing ROCK. How can I go around this problem as the pc of HW is just lying around doing nothing…

The other option is for me to buy an i5 4570 4th Gen PC that’s within my budget and to dedicate it to ROCK. Now, will that work and be powerful enough to upsample Tidal HiFi to DSD512? And has anyone used those here?.. thanks

You are on your own here my friend - nobody can say for sure what will work or not other than Roon’s identified NUC systems. Unless they have an identical system, and even then a BIOS version might still break something.

My 7th generation (Kaby Lake) i5 NUC is not powerful enough to upsample TIDAL to DSD512, so I doubt you will have better luck with a 4th generation model.


There are some major differences between the processors in NUCs and desktop PC’s. I don’t think there’s a way of saying this will/won’t work as it depends on lots of other factors also, such as source rez and disk and memeory i/o etc.

But i agree that it most likely will be a struggle…

1 Like

That is two relatively processor intensive actions. The MQA unfold then the upsample. I’ve got a gen 5 i5 NUC that quite happily does a straight 512 upsample but I’ve never tried it after an MQA unfold.

Yup. I was testing a worst case, but my little i5-7260U equipped NUC is not up to the task even with straight Redbook CD upsampling to DSD512.