Modern Linux Distros support

I just canceled my order for a NUC11 since the bios does not support legacy mode and ROCK requires that, even though all modern Linux distros do support uefi boot. I considered just running a linux desktop or server distro and then downloading the linux server package but the documentation I can find on the Roon Support site references old distros. It looks like the latest references are from about 5 years ago. I wonder if roon let go all its Linux engineering staff or perhaps they were just contractors that finished their task and left. At any rate I’m not interested in a NUC10 which is only about 20 dollars cheaper, particularly if roon isn’t really supporting linux in a meaningful way. I’m currently paying 120 dollars a year and am wondering if its worth it. I have a relatively small local Library, mostly using Qobuz. My current Roon setup is on a 2018 Macbook Pro which works, but I’m finding that I really need a Roon server continuously running to make this useful.

So does anybody have a current Linux desktop or server running Roon Server, such as Ubuntu 22.04, Fedora 36? If so are the installation steps on the support pages still valid? Any help or pointers would be appreciated.

Roon Core runs headless on any recent Linux distribution and ya, the installation of Roon hasn’t changed.

1 Like

How about a MacMini?

Happily running Roon Server on Ubuntu 22.04, before that on 20.04 and 18.04. No problem at all…


I suppose you could run Linux on a intel Mac Mini. I wouldn’t bother trying on an M1 yet, still buggy. :wink:

But I’m thinking that’s not what you meant when you suggested a Mac mini. :rofl::joy::rofl:

Same here. Ditched my Mac roon server when they dropped cuda. Ditched windows when I got tired of the bloat and updates. Now I’m on Ubuntu Desktop 22.04, using Plex, Roon and hqplayer with a large zfs storage pool and samba shares. There were a few hiccups here and there but most were of my own doing, overclocking and stuff… :+1:t2:

Lack of a client doesn’t matter much, between Remote Desktop and file sharing there’s not too many reasons to even sit in front of that machine anyways.

No, I meant Mac Mini running Apple OS, whatever it’s called.

I am using AudioLinux headless on Intel NUC.
I’m not good at Linux, but AudioLinux has a script menu that allows you to do everything you need without knowing about Linux.
In addition, the technical support services are excellent.

Welcome, @Bill_Ricker.

Linux across the board here. Currently run server on 20.04, and bridge (including desktop using Wine) on 22.04. There are binaries, and an easy installer script for x64 and arm7/8.

Fedora 36 it is. Easy peasy, no Linux expert level needed.

Thanks for all the replies. Good to see that recent distros still work. Still wish ROCK would work with EFI. Pretty bizarre that it doesn’t. Any one from ROON care to comment on ROCK support with EFI? Any plans to support this?

Have a read through the following thread:

Per @Danny, Roon has UEFI working, but is unable to obtain the proper (for a NUC11) ethernet driver. I expect you won’t see UEFI, and hence NUC11 support. until that happens.

I just installed roon on a parallels virtual machine. Didn’t try to pump any audio, but it came up fine and I could connect to it after deauthorizing my mac. Seems to work fine. Should of tried that before winning on the forum :crazy_face:

Why? Might as well continue using Roon core on the Macbook if you are going to do that.

Why not reorder a NUC11 and install your flavor of Linux with Roon on top or a supported NUC with ROCK?

I quickly switch back to the Mac of course. I just wanted to verify that linux (pop os 22.04 in this case works). The easy install worked flawlessly and did set up a system service (enable/disable with systemctl like god intended). My Nuc11 is arriving tomorrow :slightly_smiling_face:.

Ok, that makes more sense. You should be good to go shortly.