More problems with Movistart Router for ARC

Roon Core Machine

Networking Gear & Setup Details

ROCK installed in Intel i5 NUC 11

Connected Audio Devices

Weiss DAC 202 usb

Number of Tracks in Library

2000 albums

Description of Issue

I did solve my initial problems with ARC configuration opening the correct port in my Movistart Router and canceling the VPN in my iPhone
Now I am able to open ARC , from my iPhone 13. But if I close it ,and I go out of home I can not re open ARC , I must go back home and reinstall ARC and reopen ARC.
If I do not close the ARC app and go out of home yes I can hear my Roon from outside.
I remind you that Movistart router have not the protocol indicated in the help page.
I did solve the problem just opening the port in the router.

Hi @francisco_gaston,

I’m assuming your description of your setup from your previous post remains accurate? ARC Movistar Router configuration (ESP) - #25 by francisco_gaston

To clarify, your ISP has provided a dedicated external IP address. After disabling the VPN on both your Core and iPhone and setting a manual port forwarding rule in your Movistar router, ARC was functioning outside the home via cellular data.

However, if you close ARC outside the home, it will fail to connect to your Core unless you reinstall? Does ARC freeze or hang, or do you receive any warnings before having to reinstall? A precise description of the symptoms will help us pinpoint the issue in logging.

Recent diagnostics confirm that ARC is losing connection to your Core when connected via cellular data and timing out when attempting to log back in. Are there any diagnostics displayed in Roon → Settings → Roon ARC? If port forwarding is still configured correctly, then the remaining possibilities are memory pressure on the phone (there’s evidence of this in logging) or the VPN continuing to interfere with ARC.

Thanks for help and looking this problem. Now I am again unable to connect ARC.
See the display that appears:

I have the VPN disabled in the Iphone.
As well I have the port open in the router.
As I did informed at the beginning the protocol mentoned in the instruction is not in Movistart router.

Again thanks for help
Only device I have between my Roon Core Nuc intel i5 and Movistart router itvis a converter RJ45 to giber and back to RJ45
I am able to connect ARC through wifi
I annex the screen shot

1 Like

Hi @francisco_gaston,

In your Movistar router web administration, there should be a setting related to DNS. I believe it can be accessed in the Configuración Básica menu under Tu Red Local.

I’m curious if the router is relying on Telefonica’s DNS servers, rather than Cloudflare, Quad9, or Google. In the columns next to DNSv4 servers, try entering, the public address for Cloudflare.

Similarly, what are your settings related to DHCP in this web administration page? Do you have a static IP still assigned to your Core?

The symptoms you’re experiencing suggest that something is blocking authentication requests from ARC when you reopen the app.

We’ll follow up from here. Thanks again for your patience.

hi Sorry not answering before. I did acces to my router configuration
I took several pictures of different screen, so that you can give instruction for necessary changes I shall do

Hi sgain
After dislog with technical dervices they have chsngedthe port opened snd now I sm able to vonnect snd disconnect grom oit of home
But ss I read seems it is not safe to have a port opened
Do you have any recommendation

Hi @francisco_gaston,

As long as you haven’t disabled the router’s firewall/network security software or placed an active router in your network in front of a DMZ or the router’s firewall, then port forwarding with Roon is safe. Please see this thread if you’re curious to learn more: Security with Roon ARC / Roon 2.0 - #28 by Zorik_Shirman

Happy to hear ARC has been configured with your ISP’s help. Let us know if we can help further.

Hi good morning
Ok anyway I did send in my other mail several screens shots of the router configuration
Could you confirm everything is ok?
Just to prevent further problems

Hi @francisco_gaston,

I’ve deleted your screenshots, just for caution and to prevent sharing public IP addresses. I believe you’ve correctly implemented a manual port forwarding rule for your network. Most importantly, you’ve pointed the static IP address and port range in the router port forwarding web administration page to the IP and Port Number listed in Roon → Settings → ARC.

If you have any difficulties, try enabling IP Tunneling in the web administration.

Thanks a lot for your kindly help
I am very happy with Roon
As well the qualty I get with my DAC is very high using my ROCK NZUC i5 directly usb connect
The Roon digital volumen control allows the use withouta preamp

1 Like