MOTU M2 - Wasapi exclusive mode not possible and glitchy audio in ASIO mode

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro 64-bit
Version 2004
OS Build 19041.804

Roon version 1.8 (build 764) stable (64 bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

PC directly connected to router using wired connection.
Speed: 1.0 Gbps

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Tidal Masters subscription.
MOTU M2 USB audio interface connected to USB 3.0 port on a Maximus VIII Hero motherboard.
Firmware version: 1.02
Driver version:

Description Of Issue

I am unable to make Roon to use the audio interface in Wasapi (exclusive mode), when using this mode, it shows an error saying: “Failed to initialize audio device”.

So right now I am using Asio mode, but when starting the next song, I get a very broken version of the song, just random noise, then I have to pause, wait like 5 seconds and play again, this will fix the audio without problems. Sometimes this fix doesn’t work and I have to just skip to the next song, but the same happens, basically I just can’t listen music.

This issue doesn’t happen at all when using Tidal desktop application, it can use the MOTU M2 in exclusive mode without problems.

In my failed attempts to fix it, I found that the driver properties of the USB audio interface says “Driver not migrated”, I already tried all the possible fixes, including updating my BIOS firmware version, but that didn’t fix it, I still get both problems (Wasapi and audio glitches in Asio mode).

At this moment I don’t know what to do.

Any help would be deeply appreciated!

Thanks in advance.

This is can be due to a Windows Update error. You can read about similar issues on Microsoft answers forum. But, I’ve copied the most applicable suggestion here:

the best option is to download the driver from the support page of the manufacturer of your system

So, uninstall the driver and install the latest driver from the manufacturer. At this point, it is not about fixing Roon, it is about fixing the driver issue on your PC. Even if your other software does not seem impacted, imho, you should correct this error first.

I tried that several times, I get the same result:

All these Device not migrated have the same error message:

Device USB\VID_07FD&PID_0008\M20000023542 was not migrated due to partial or ambiguous match.

Last Device Instance Id: USB\VID_054C&PID_0CE6&MI_00\7&280a7fe1&0&0000
Class Guid: {4d36e96c-e325-11ce-bfc1-08002be10318}
Location Path:
Migration Rank: 0xF000FFFFFFFFF132
Present: false
Status: 0xC0000719

If you have uninstalled the Motu driver and re-installed using the latest version (MOTU M Series Installer 4.0 (84479).exe), then I would suggest you contact Motu Tech Support as they may have better insight into what the issue is with their driver.

Btw, just another user, Official Roon Support will be by and they may be able to suggest something else.

I tried the nuclear solution, reinstalling Windows, it fixed the “Deviced not migrated” but Wasapi in exclusive mode still doesn’t work.

I guess it is just not compatible, also can’t find any related problems on Internet.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.