Moved my Core, now Roon doesn't see Windows audio devices


I just moved my Core from my primary Windows PC onto a separate dedicated PC running Ubuntu 22.04 with the latest Roon Server installer (Dell OptiPlex, Intel Core i5 8th gen, 16 GB memory). The Roon Server app installed fine. Before I moved the Core to it, I performed a backup on the Windows machine. After moving the Core using the Roon app, I performed a restore. The Core is running happily on the Ubuntu box, and the restore seems to have gone fine; I see my library, playlists, tags., etc… except I don’t see any of my local Windows audio devices in the Roon app on the Windows machine. It just shows the audio devices on the Linux machine, and then it also found a Chromecast and Apple TV in the house. The devices are fine on the Windows machine, Roon just doesn’t see them.

Here’s what I’m seeing on the Audio page in Settings:

Any advice on troubleshooting this?

EDIT: I should add that these devices are on the same LAN and same subnet. I just have one /24.

EDIT: Everything is 2.0 build 1128, and the backup is from version 2.0 build 1128. If I switch the Core back to the Windows machine running full Roon and restore the backup, it works fine. But I want the Core to be on the dedicated Ubuntu machine running headless Roon Server…

Sheb, did you de-authorize or logout of you previous Windows Core PC? I don’t believe your Windows PC is showing as a device in the Settings → Audio screenshot you showed.

What was on the Windows Core, the full Windows Roon application or only Roon Server? Do you want full Roon on the Windows PC or would Roon Bridge suffice?

Hi Robert,

Yes, I de-authorized the previous Windows Core PC. Your observation of the Windows PC not showing as a device in Settings > Audio is the problem. That’s the local PC running the full Windows Roon app, so it’s very strange to me that it doesn’t even see its own local audio devices. If I move the Core back to this Windows instance, they come right up, no problem.

The previous Windows instance was running the full Windows Roon application. I’ve never run Roon Bridge before. I’m not sure if Roon Bridge would suffice. I think I’d prefer the larger application since I do the vast majority of my listening on this Windows PC. I just want to get the Core off my primary computer and onto another machine. It’s something I’ve wanted to do for a while, but now I really want to do it before I forward a port to my internal network and get started with ARC.

Just a suggestion, but if your Ubuntu Core is working with all of your music and settings, and you have a Roon backup (made from within Roon’s Settings → Backup) and music on external drives, then it may make sense to delete Roon from your Windows PC and reinstall a fresh copy. This will act as the Remote if your Ubuntu is active on your network.

I should have mentioned, I tried a full uninstall/re-install few times on both sides. I even started from complete scratch: I did a full uninstall on the Windows machine and a full uninstall on the Ubuntu machine. Then I installed Roon Server on Ubuntu, and then installed the full Roon app on Windows. It connects to the Core just fine, but even on the a fresh first-run setup, before even seeing the full UI for the first time, Roon does not see any local Windows audio devices.

Is your Windows firewall configured to allow exceptions for Roon and RAAT Server?

Looks like roon.exe was already in there. Added raatserver.exe as well, no change.

I have no idea why, but now it’s working. My plan this morning was to restore from the original backup one more time on the Ubuntu Core and then try things from more remote Roon apps on my network (iOS, a second Windows machine, etc.) to see if I could isolate the issue to the Core or to my primary Windows machine. I moved the Core, and de-authorized the primary Windows machine. I then did a full uninstall/reinstall on the Windows machine. This time, when it connected to the Core, the audio devices were there.

I feel sure I’d tried this combination yesterday when I was performing numerous uninstall/reinstall/deactivate/restore operations, so unfortunately my only advice to folks who may see this in their own configurations is to just keep trying.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.