MQA DAC Not Decoding MQA Files Anymore

Roon Core Machine

Device name XXXXX
Processor AMD Ryzen Threadripper 2950X 16-Core Processor 3.50 GHz
Installed RAM 64.0 GB (63.9 GB usable)
System type 64-bit operating system, x64-based processor
Edition Windows 10 Enterprise
Version 21H2
Installed on ‎7/‎10/‎2021
OS build 19044.2006
Experience Windows Feature Experience Pack 120.2212.4180.0

Connected Audio Devices

Questyle M12 USB DAC & Headphone amp

Number of Tracks in Library

5000 tracks

Description of Issue

When playing MQA files from Tidal, I used to have an “Enhanced” signal path, which included Authentication and one rendering stage. Now I only see the Authentication stage (which I think is done by Roon software even without an MQA-compatible DAC?), without the later stage enhancing it. I have “Enable MQA Core Decoder” enabled in the device settings and the general setting is “Treat MQA as better than CD quality, but not as good as lossless hi-res content.” I’m curious why this would have changed. I’m using the same DAC. I’m trying to remember if it ever worked on this computer (my work computer), or only on my home computer. Or if it changed when upgrading to 2.0. It may also be relevant to say that I have Tidal HiFi, not HiFi Plus, but that hasn’t changed.

Can you post the device settings for the M12 zone to see if anything obvious sticks out. Tidal Hifi sub will allow 44.1/ 16bit MQA decoding only any files at 24bit will not be decoded. Your example however is 16bit so should decode. Check you Tidal settings in services is still set to Master.

Some times a reboot of core and DAC can clear Roon and it’s MQA signal path to resume its normal procedure.

Thanks for responding! The computer (core, endpoint, and remote) has been restarted several times. Do these screenshots help?


You have it as decoder and renderer.Your DAC is only a MQA Renderer I believe. Try setting it to renderer only.


That’s it, thanks!

It seems a bit strange that changing it to Renderer Only adds decoding and rendering to the signal path. I still don’t really understand how MQA works though. Anyways, sounds great! Thanks for your help. I’m glad to get that working again.

If you have it set as decoder and renderer Roon expects the endpoint to do all the decoding and final rendering of MQA so it bypasses the internal decoder and you can’t use DSP as it will break the MQA chain. If you want to use DSP and maintain MQA signaling you need to set it to renderer only and let Roon handle the initial decode (first unfold) or if it’s just an MQA rendering DAC you need to set the same.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.