MS200 disappeared

I have RoonServer (build 204) running on a Mac Mini, and a Meridian MS200.

From the Mac Mini and other Mac’s on the network, I can see the HTML page for the MS200, but it’s no longer showing up as a networked endpoint in Roon. Other Airplay endpoints are visible.

I’ve restarted all the networking kit, the Meridian kit and the firewall is off on the Mac Mini.

Any troubleshooting tips would be very welcome…

Thanks, Dave

Check cables and reboot the MS200 would be where I start.

All cables reseated and everything powered down and up with no joy… The MS200 is happily presenting its web interface so it’s on the network.

Do you have Sooloos running as well?

Is the MS200 fixed IP, assigned IP under DHCP or plain DHCP?

Hi, I don’t have any Sooloos kit sadly; when I get home I could see if the Sooloos configure application can see it…

The MS200 is assigned a fixed IP by the router.

Thanks, David.

My (2) MS200 are fine. What changed in your setup?

Nothing that I can think of… I should have a little more time to swap out things and test a little more over the weekend.

What firmware version is the MS200 running ?

Software version: 1.0, build 169
Co-processor version: 1.3.7
Hardware version: 2.1

Ok…so that is latest I think.

Assume you have rebooted every device including Roon core ?

Yip, everything has been rebooted many times… I can see the MS200 with the Sooloos configure app as in additions to being able to see its web interface ; it’s just Roon that cannot see it.

I’ve also swapped in/out various different network devices but to no avail.

I’ve also performed a factory reset of the MS200 - still no joy

Can you delete the fixed IP allocation on your router then reboot everything to allow the MS200 to pick up a standard DHCP IP address?

Doing a factory reset on the MS200 will not affect the fixed IP allocation by the router which is the only variable that hasn’t changed by the sounds of things.

Confirming that that’s the latest

Sadly, removing the address reservation doesn’t make any difference…

You may have covered this already, but have you reflashed the Firmware onto the MS200 using the Sooloos Configure program

I realize that you already have the latest Firmware installed…but I’ve also seen instances of Firmware reflashing can bring Endpoints back to life

Thanks Ronnie, I’ve not tried this - how do I do it?

This is what you’ve said above…so I assumed you had already used this program previously??

When you run the Sooloos Configure program and it finds the MS200…does it give you the option to upload firmware to the device…and if so, does it list the Firmware version that is available on the computer on which you are running the program??

I’ve used the Sooloos configure app, but it automatically uploads new firmware - I cannot see how one reflashes.

It’s been a while since I used the Sooloos configure program…and I’m travelling at the moment…so I’m going to flag someone who may be able to help

Hi Russ
I’m away from the Windows PC that I typically use for Meridian Firmware and Sooloos Firmware uploads etc., so I can’t talk Dave thru the exact steps required to reflash his MS200 with Firmware

I think there is a way to just reflash with current firmware…or else to flash an older version…and then again with the newest version

Obviously, the goal here is to try and reset the MS200 so that it appears as available in the Roon Audio Settings

Any help you can provide with the specific steps would be appreciated