Multichannel and Stereo issues


I’m using a Roon trial license to see if it can play my multichannel and stereo music library. Installing Roon worked like a breeze: on a Windows 2016 server (Core only), on a PC, and Roon Bridge on a NUC PC near my audio setup.

The only problem was that I could not select 5.1 for the channel layout of the NUC zone (WASAPI driver). The option is disabled and fixed to “2.0”. This issue has been reported elsewhere on this forum, but I could not find a solution.

The NUC is connected to a surround processor over HDMI. The corresponding “Intel Display Audio” configuration is correctly defined as 5.1, and working properly in other applications.

As a test I installed the ASIO4ALL driver on the NUC, which did in fact allow me to define a new zone in Roon with a 5.1 Channel Layout. Multichannel music now played fine, and I assumed this was the fix I needed. However, this driver will also play stereo music as 5.1, using only 2 of the 5.1 channels. As a result the surround processor will not allow any stereo processing such as 3 channel stereo (“Trifield”).

I now have to match the zone with the music format (WASAPI for 2.0 and ASIO4ALL for 5.1), which is not very convenient, especially for the not-so-tech-savvy.

So my questions are:

  1. How can I select 5.1 Channel Layout for the zone using the WASAPI driver, or:
  2. How can I force the ASIO4ALL driver to play stereo material as stereo instead of 5.1?


Roon Core: Windows Server 2016, Roon Version 1.3 (build 262)
Roon Bridge: Windows 10 64 bit, Roon version 1.0 (build 115), Intel Display Audio driver.

I’m probably missing something, but why can’t you use the HDMI zone for both your multichannel and stereo material? You can tell Roon how you want to use stereo material over a multichannel connection - play as stereo or mix to 5.1… For example:

Thanks for your reply. I have the same configuration as in your screenshot (except that I have 5.1 instead of 7.1). Despite the fact that the “Send stereo/mono as 5.1” option is disabled, the surround processor gets a discrete (PCM) 5.1 signal from the NUC when playing stereo music. As stated above, this disables all the wonderful stereo processing that the surround processor is capable of.

Interesting. I’m pretty sure worked for me when I was using it on a NUC running Windows 10 Pro; however, I’ve now moved over to a Core running on ROCK, which is where the screenshot comes from.

I’m just wondering if your issue is related to the fact that you are running the Core on Windows Server 2016. Hopefully Support can help you further.

Hi @Marco ----- Thank you for the report and continued feedback, both are appreciated!

Moving forward, can please provide some further insight into the endpoint you are noticing this behavior with? I want to have a better sense of the gear being used, in regard to the audio zone that is having the issue.


Hello Eric,

Thanks for looking into this. The zone / end-point configuration is as follows:

Intel NUC5i3RYK. Windows 10 Pro 64 bit build 1703. Roon Bridge 1.0 build 115. Intel Display Driver (which includes the audio driver) version The ASIO4ALL driver version is 2.14.

The NUC is connected over HDMI to a Meridian HD621 switch, which is connected over MHR to a Meridian G65 surround processor, which is connected over SpeakerLink to Meridian DSP7200.2 (LCR) and DSP3200 (SL/SR) speakers.

If you need any additional information, or if there is anything you’d like met to try, just let me know.


ASIO doesn’t allow apps to send less than the max number of channels, so this isn’t going to be the right tack. It’s also why the setting isn’t working, and why @Geoff_Coupe isn’t having similar issues with ROCK.

This is the right way forward – we need to figure out what’s going on with drivers here. I see you posted the driver version, but it might be worth looking into whether Meridian provides any other drivers here, or whether they have advice on getting Windows and the 621 to play nicely over HDMI.

Hello Mike,

It’s good to know that ASIO is not the right solution here. I can focus on a WASAPI solution now.

Meridian does not have any drivers for the HD621 or G65. It seems to me that if I have the Intel Display Audio device configured correctly (channels, supported formats) it should all work properly regardless of the equipment at the other end of the HDMI cable.

I will do a fresh Windows 10 installation on the NUC. Maybe something broke during the OS evolution over the years from Windows 8 to Windows 10. I will post the results here.

If that doesn’t help I might look into a Linux option for the NUC. Can one use ROCK for this? The description says it’s a Core, but it also has the Output component. Can one install (or use) just the Output part of a ROCK system?


I did some more tests and got a lot closer to the cause of the problem, but not yet to a solution.

First I did a fresh Windows 10 installation, downloaded and installed the latest Intel NUC drivers and BIOS, configured and tested 5.1 sound for the HDMI audio device, and installed the Roon Bridge. It still did not allow me to select 5.1 channel layout.

I then connected the HDMI cable directly to the TV (which also supports surround), configured and tested 5.1 sound for the HDMI audio device again. Roon did still not me to select 5.1 channel layout.

As a test I then moved a game PC to the living room, connected its HDMI cable to the Meridian HD621, and installed Roon Bridge. Everything now works correctly! Roon allows me to select the 5.1 channel layout, and stereo and 5.1 music play accordingly. This is of course not a permanent solution.

Conclusion: the problem is very likely compatibility between this specific NUC hardware (NUC5i3RYK) or its Intel drivers and Roon.

What would you recommend at this point?


Hi @Marco —— Thank you for your continued feedback, and more importantly, thank you for your patience! Apologies for the delayed response.

Moving froward, our techs do not believe that this behavior you’re experiencing is related to the drivers, as everything is from intel and not another source. What they do believe, is that this problem is more than likely related to your Win10 settings as the team thinks something could be misconfigured here at the OS level. For example, checking how the Windows output is configured would be a good starting place.

Furthermore, perhaps this is related to your “boot order”. Ideally you will want the AVR to come up first, then the NUC, and finally, Roon.


Just to be clear, the game PC is a bigger PC with a discrete graphics adapter, correct?. Did you use the same or different HDMI cable for the game PC and the NUC?

I did the following additional test:

  • Power on the AVR and NUC.
  • Disable the auto-start option for the Roon Bridge software from the taskbar icon.
  • Shut down the NUC.
  • Shut down Roon Core on the Server.
  • Restart the NUC (AVR still powered on).
  • Verify the Windows playback device properties: 6 channels, all relevant formats supported.
  • Start Roon Bridge.
  • Start Roon Core.

The result is unfortunately the same: Channel Layout is fixed at 2.0.

FYI: the Windows playback device properties are as follows:

That is indeed correct. The game PC has an nvidia graphics card with HDMI, and therefore uses the nvidia audio drivers. I used a different HDMI cable with a normal HDMI connector instead of a mini-HDMI connector on the NUC.


Hi other Marco :slight_smile: !

I know that the following ‘solution’ is a bit drastic. But, just in case you really cannot make it work in Win10 :

Have you considered running ROCK OS on your NUC ?
Of course, you can only do this when Roon is the only thing you need on this PC, and you don’t like to do much ‘tweaking’.
But it has been so stable, easy and flawless, that I have never looked back to Win10 since installing it…
And yes, that includes multichannel playback (ok, mine is a NUC6i5…).

A bit drastic, yes. But maybe it is worth checking out for you, and be happier in the end… ?

Hello Marco!

Thanks for your suggestion. I have considered it, but isn’t ROCK a Core product? Can one use just the Output component of a ROCK system?


The Roon software in ROCK supports both the Core and the Output functions - it does not have the Control function (see Roon Architecture for details). And yes, you can just use the Output component on its own, if it’s the only way to get multichannel…

Just after posting, I read that you had considered running ROCK. Skipped that bit, sorry about that :).

Anyway, I see you are already answered. Yes, you can just and only use the ‘output’ part of ROCK, and point to a different Core if you need to. I think this will be self-explanatory; nothing special to do.

My personal opinion : at least, try it out one time, to know if it is something for you. Especially if you have a spare SSD somewhere, to test in a non-destructive way.
I (a computer nerd even) think it is much nicer and hassle-free than a Win10 install.

But NOT recommended if you need other applications on your NUC, or if you are the kind of person that likes to ‘tweak, tinker and adjust’. In that case, you should continue to try and solve your current problem.

Okay, thanks for the info. I will probably try it. The NUC is planned as a dedicated Roon Bridge device, so Windows 10 is not a requirement.

I will post my findings here.


Well, I tried the ROCK alternative. Here are my findings.

Installation was easy and straightforward. However, in the Roon Settings I now see a Roon Optimized Code Kit with 3 (!) HDMI devices: HDA Intel HDMI 0, HDA Intel HDMI 1 and HDA Intel HDMI 2. The NUC only has one HDMI connection.

I was able to configure HDA Intel HDMI 0 with a 5.1 Channel Layout. Unfortunately, when I play any 5.1 music, I get a “Transport: playback_error_endpoint_device_init_failed” message and no sound. Stereo music seems to work fine.

The other 2 “ghost” HDMI devices will not do anything.

It seems like my NUC5i3RYK is officially supported for ROCK:

It is therefore odd that these issues occur. Perhaps @support can weigh in on this?


The NUCs generally have one HDMI device for each graphics port–this includes HDMI and DisplayPort outputs. Some NUCs have up to 3 ports. I think some NUCs may expose devices for ports that they don’t actually have, but I’m not 100% sure. We just expose what Intel makes available.

Try using the 7.1 layout instead, then experiment with whether or not you need the setting to swap rears and surrounds.

When using 7.1 there is no sound when playing 5.1 music. The user interface shows that it is playing and there is no error message now. The “swap rear/surround” option makes no difference. Stereo music still works okay.

Do you have a NUC5i3XXX available at Roon Labs? If so, does it play 5.1 music?