Multichannel - Disable Channel Mapping

I have on problem with the way Roon handles multi channel content. Is there any way to turn off channel mapping completely. I have a 5.1 system and use JRiver as a WMD for upmixing. With stereo content it works perfectly, but any multi channel signal gets remapped and send as a fake 5.1 signal which prevents that Jriver upmixes correctly. The result is that track without a LFE channel just don’t use my subs which isn’t great. How is it possible that there is no option to just send the original channel mapping and let an AVR or in my case roon do the channel mapping?

Seems like a lot of important information is missing from your post. I’m unable to see what you’re after. Maybe you are able to help yourself reading the relevant documentation?

You can also use Roon’s DSP engine to create your own mix matrix.

Other maybe relevant information:

What information is missing that would make my post clearer? All I want is that roon send exactly the channel mapping of the file to the audio device. I don’t see a way how that is possible. Instead roon remaps a 5.0 and send an empty signal to the subwoofer. This is not great as Jriver thinks that it receives a proper 5.1 signal and does not upmix (i.e sperate the sub channel). So far I only see the options “Downmix as needed” or “channel mapping only”. What I would need is something that doesnt change the mapping at all. I assume this would be the case for anyone sending their signal to AVR so I don’t understand why this is not an option.

Why you need to up-mix a multichannel signal to a multichannel (5.1) signal and what you understand under the term “fake 5.1 signal”.

Now that things are clearer and you figured out how Roon handles your case.

The documented behavior of Roon.

Please post your wish into the #roon:feature-suggestions section of the forum (or just edit the title of this thread and change the section), that’s what it is for.