Multichannel on Wasapi and RoonBridge@Volumio@Rasp4, AirPlay

Core Machine (Operating system/System info/Roon build number)

1.7-511, Win10.32

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Pc-LAN-Volumio‘s RoonBridge-Hdmi-NanoAvrHDA-Analog 6ch.

Description Of Issue
MCh issue are occurring while playing back Qobuz files, my only HD Mch source.
I have Roon running with my R4 now for a week and am super happy for 2Channel. Quobus integration is great.
I would prefer a tabbed Album selection interface instead having to fiddle with the Focus thingy.
However, MCh is an issue. There are only a few albums in Qobuz, I believe mostly Quadro with a remixed centre, but I hope for more.

I have ASIO4All installed which works in MCh mode with REW.
With Roon, ASIO is only 2Channel for me.
I have to disable the unselected Asio output in Roon in order for Roon to use Wasapi. Wasapi would not work in 5.1 but only in 7.1 mode, „ mapping only“ works best.

It works, sort of.
Needs a R4 reboot after being used the first time. The channel mapping is wrong. Only 2Ch when 5.1 is used, wrong mapping (rear and front swapped) when 7.1 is selected. Sometimes the centre would not be mapped at all. This is not handled transparently in Roon but should be part of a kind of DSP menu.
I had to disable EDID sensing in the R4, forcing 1080p@60hz with all audio modes allowed to get the R4 to play with my NanoAvr. There is no R4 configure setting for audio modes (2-6-8 ch selection). This is a Volumio and R4 issue, I try to post it there too.
I tried Airplay too - that is only 2ch, and works only for AppleTv (with password!) and not Volumio as I believe it does not use the HDMI out there. That needs a huge overhaul (the AirPlay thing in Qobuz)

Can you please show us any of the ‘multichannel’ albums on Qobuz ? I wasn’t aware that any streaming service had multichannel available ?

This one

1 Like

While typing, I became aware, that the Hdmi1 interface is the other, not connected port. I then used the Hdmi0 interface. That did not swap front and back any longer, so it is usable. The Wasapi interface plays a center channel with this album
which sounds a bit like synthetic.
The R4-hdmi0 plays no centre channel.
It would be good if somebody could test this with a file containing a true center channel recording.
I will try what happens with a connected Hdmi1 port next…

Hi @Joachim_Strobel,

It sounds like the first issue is solved? HDMI works as expected when routing through your Oppo 103 and just through the RoonBridge is the issue?

By Volumio RoonBridge, what exactly do you mean? Do you have a Raspberry Pi with an HDMI In/Out? I’m not able to find a Volumio R4 product, can you share a link to it?

Hi Noris,
Wasabi: Considering that I spent over one hour to get it working Iveould say: not all is well.
First, with Aiso being seen by Roon but not used, Wasapi could not access the Hdmi output. Only disabling Asio made Wasapi start working. I guess my Oppo identifies itself as a 7.1 device through Edid. For my tests, I made sure that it is turned on before the Pc is on, as otherwise wasapi would not see the Hdmi port. I have not tried to switch the Oppo on later as a check what Wasapi identifies (I have an Edi’s simulator and will include that later).
Now, if I set Wasapi to 5.1, it comes back with an error that the track can not be played. Switching back to 7.1 all is good.
The Signal path display shows a 5.1 (Source) to 7.1 mapping, but no control interface. There are a couple of “ late minute” options in the device interface, like swapping side and rear or map instead of down sampling, but these look amateurish and need an open interface. I am still not sure if the Centre channel is mapped correctly or not. There is probably no .1 content in music streams, but once the famous 1812 recording or the Starwars soundtrack is available, their will be, and then it would be good to see what Roon does to that LFEchannel.
I come back to the Volumio issue later.

Hi Noris,
Volumio support R4 since August:
2.599 (02-08-2019)
Raspberry PI 4 support

Within Volumio I can select Hdmi as output. And I can install a plugin called RoonBridge V1.0.
That then uses the Hcmi port. Roon sees three interfaces, the said Hdmi0&1 and a ?common one. It sees volumio‘s Airplay interface too. Room can not connect if Volumio plays something, I first have to stop play. I also had the Volumio’s Bluetooth input enabled, but that messed Roons access up and I disabled it again.
It is a bit strange, as I read in Forums that the Rasp Roonbridge would not use Hdmi. I hope nobody breaks no licenses. The Volumio reports the Hdmi port to be 2Ch when playing Webradio or files. The system probe does not work when Roon has access, but Roon must force the Hdmi to 7.1, hence 5.1 selected via Roon only produces 2Ch.
As said it works, but the channel mapping is not transparent and messed up from time to time. Room maps the source’s 5.1 to 7.1 but does not say how.
Audio is interleaved with Video on Hdmi. That interleaving works better with some video frequencies than other. The R4 defaults to Vga video resolution without audio if it does not recognize the sink’a devices Edid as something useful. This makes connecting the R4 to Hdmi a challenge. It could turn into a benefit, if Roon chooses that resolution enabling audio with it for the second hdmi port.

Hi @Joachim_Strobel,

Roon does not control of how Volumio sets the Video Resolution on the HDMI port, this would be in Volumio’s domain.

For multi-channel mixing, more information can be found in our Knowledge Base Docs. If you need to mix individual channels you can do so using Procedural EQ - Mixing in the DSP Engine.

Hi Noris,
I realize that the EDID sensing und configuration is done by Volumio. I fail to understand why I do not hear a centre channel with Volumio, but hear one with Wasapi.
I think I understand the settings described in the knowledge base link, but would prefer a graphical interface to see where goes what. I understand that the procedural EQ might help, but can not find any further documentation or examples on its use.
Thanks for your support.

Hi Noris,
I was wrong, sorry. All mixing is available in the procEq. I somehow missed all these switches - it looked to me as a blank sheet waiting for scripts.
After some listening, I decided the the R4 with Volumio works a Lan Roon bridge, but it does not sound as good as Wasapi, so I am moving it to the bedroom keeping my encapsulated pc via HDMI in my main stereo setup. I have Wasapi now always available thanks to an EDID emulator and can start my pc remotely and am good to go…

Hi @Joachim_Strobel,

Glad to hear you were able to find the mixing options! I marked this thread as [solved] but if you have further difficulties feel free to reach out again. Until next time, take care!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.