Multichannel with Mac Mini?

I was using an i7 NUC with ROCK. It outputted multichannel DSD. I have replaced it with an M2 Mac Mini. Roon then did not offer multichannel output. I did try choosing my Marantz surround receiver as the output device, but Roon converts the multichannel DSD to 44.4-Khz stereo. I have the Mac Mini connected to the Marantz by HDMI. I then went into Roon’s Settings/Audio and enabled a separate instance of Marantz (AVR Core Audio) and chose Device Setup. I then opened show Advanced and selected Channel layout 5.1. I also chose Exclusive mode and DSD playback strategy of DSD over PCM v1.0 (DoP), No MQA support, and Device volume.

Did I set it up correctly? Thanks.

I have NUC/ROCK connected to a Denon AVR with HDMI that does play Multi-channel PCM, but it has never been able to play DSD over the HDMI connection. The MC DSD files are converted to MC PCM for playback. I had to get an 8 channel DAC for MC DSD playback and Roon does output DSD over Ethernet to that device.

I don’t think DSD over PCM works with Denon or Marantz AVRs. As far as I know they are not setup for it.

My HDMI Audio setup doesn’t have an option for Exclusive mode, Private zone is set to no. Volume control is fixed, and channel layout is 7.1 (so I can swap rear and side surround channels when I want to).

1 Like

I don’t think that Macs support an audio only HDMI connection and also might restrict the resolution. Assuming that it might check to see if the monitor is on and active, have you checked to see if you are also getting a second screen detected on the Mac Mini? And if the TV that is connected to the AVR is turned on and that HDMI IN active on the AVR?.

Which Marantz are you using?

If you google Mac Mini HDMI on the roon forums you will see several threads you might be interested in

I have a Marantz SR 7015. I have attached screenshots concerning the setup and the signal path. Would appreciate any help. Thanks.

Hi Andrew,

I think you should use “Convert to PCM” instead of “DSD over PCM”.

I have a Marantz SR6015 connected to a mac-mini (not M2 though) via hdmi to listen to my multi-channel dsf files and have had no problem so far.

Have you tried to have a look into the Audio Midi Setup program to see what’s going on ?

Here are my settings in Roon for the Marantz AVR:

To start try the highlighted (blue text) “Identify this Device” link under Audio device. That should take you to a list where you can select the Marantz SR 7015 since it is Roon Tested. That is what I did with my Denon AVR-X8500H. Not sure, it’s been awhile, but that may change the options in the setup file if the device is identified. Your setup file is different from mine and its possible that is why.

Hi. Thank you for the detailed information.

Audio Midi Setup had a setting of 192.0 kHz 2 ch 24-bit Integer. It would not let me select 768 kHz. Since I have a 5.1 system, I’m not sure which setting to select. I can choose 5 channel with 16-bit, 20-bit, or 24-bit integer or 6 channel with the same choices of integer. For now, I am going to try 6 channel with 24 bits, assuming it would allow the 0.1 in 5.1. Should I select something else?

My Marantz supports more channels, but my speakers appear in a 5.1 configuration.

When I click the button for speaker configuration, the dialog box lets me choose which channel to assign to each speaker, and one of those speakers is the subwoofer, so it looks like 6 channels is the correct choice. But I am not sure which channel to assign to each speaker. Will Roon automatically use the correct channels based on whatever the source audio designates?

I thought I had read that it is usually better to use DSD over PCM than to select Convert to PCM. My Marantz natively supports DSD.

Thanks again for your help.

It looks like I had configured Roon for my SR 7015. But Roon is remixing 5.0 channels into 2.0 and using AirPlay rather than HDMI, for some reason.

Roon lists a separate audio device called mararntz-AVR, connected through CoreAudio, but that selection also remixes to 2 channels. As I posted earlier, I had managed to use Audio MIDI Setup to configure that device to 6 channels, but now it somehow has gone to only 2 channels, 16-bit integer, with 32 kHz, 44,100 Hz, and 48,000 Hz as the only available selections. I have lost the multichannel and higher-frequency options.

I then rebooted the Mac mini and entered Audio MIDI Setup. Now, it won’t let me select anything higher than 2 channels, 24-bit integer, 176.4 kHz. So I can’t get the multichannel back. Confusing.

I now see that, by changing the output on the Marantz’s physical dial, I can change the output choices from the Mac’s Audio Midi Setup. When I select the Marantz output to which I have connected an HDMI cable to my Mac, Audio Midi Setup permits me to choose 6 channel, 24-bit integer, 192 kHz. Then, Roon’s Device setup dialog shows 5.1 Channel layout. Clicking on the Signal path button shows Channel mapping from 5.0 to 5.1. Finally, I got sound to play through that configuration, though I can’t hear sound from the rear speakers…

For what it’s worth, when I test each of the six channels in Audio Midi Setup, the Mac Mini correctly plays the test signals from the rear speakers and the subwoofer. But it seemingly randomly reverts to two-channel audio when I play music through Roon. Yet, even when Signal path shows Channel mapping from 5.0 to 5.1, no sound comes from the surround speakers. It seems that pressing play on Roon triggers something in Audio Midi Setup that reverts to two channels, though Roon still reports that it is outputting 5.1.

I am not sure how to make Roon use multichannel. It used to work with my NUC, but the Mac Mini doesn’t seem to want to cooperate.

But sub and center channels do get the right information? Which channel layout is selected in roon´s audio setup menu for the HDMI output? 5.1 or 7.1 with ´downmix as needed´ (preferred) or ´channel mapping´?

Which kind of multichannel source file are you playing from roon? A 6CH FLAC or 8CH FLAC or WAV? Do you have a dedicated multichannel test album for channel identification in the very same format? I usually use tacet´s or Philips´ SACD multichannel albums.

There are cases in which one of the devices in the chain connected via HDMI might be mixing up either Center/Sub and SurroundL/SurroundR channels or RearL/RearR with SurroundL/SurroundR resulting in nothing or the wrong information coming out of the surround speakers. Maybe you might want to check this.

Here is the advanced HDMI setup page on my NUC/ROCK for the Denon. Note: my speaker configuration is 7.2.4 in the living room. The X8500H and SR 7015 are very similar except the Denon has 13 amps/channels. I believe 192/24 is the max PCM resolution for both device so that is what I use.

My channel layout is set to 7.1 in Roon but it only plays 5.1. Notice on the setup page, same as @Tuong, with channel layout set to 7.1 there is an option added by Roon to swap rear and surround channels. I can and do, on occasions, use this option to swap the side and rears for the back channel as desired depending on where I’m sitting in the room and the device used for playback. For instance my OPPO 205 uses the sides surrounds for rears vs the Denon using the Back speakers.

The difference appears to be the server platform and how Roon interacts with the machines OS, Rock vs MAC. I’m not familiar with Mac’s and cannot offer any help with that.

1 Like

Thank you. I am not sure why the Mac is thwarting multichannel output.

Does anyone know of a way to fix it with the equipment I have?

If not, is there a gadget that would connect to the Mac Mini to send the DSD multichannel stream to the Marantz unadulterated?

Thank you.

Hi. Thank you, Everyone, for your help. After perusing the forums, I have determined that making multichannel work on a Mac is too fraught (if even possible), so I am returning the Mac Mini and getting an eleventh-generation i7 NUC, which I hope will handle my library much better than my eighth-generation i7 NUC. At least the old NUC handled multichannel through HDMI. I appreciate the assistance.

Have you tried to :

  • Use Convert to PCM instead of DSD over PCM
  • Check what sound mode your Marantz AVR is and what channels are actually outputted - you can see it in the Marantz app or on the screen overlay info.

I did try converting to PCM. I didn’t visit the Marantz menu, but the Marantz worked fine with my NUC over HDMI. I think the Mac must not output the correct signal. It seems to be a common issue in various forums.