Multiple cores existing on same network

Roon Core Machine

Legacy Mac Mini: 3.6 GHz Quad-core Intel Core i3
8GB 2667 Mhz DDR4

New M1 Mac Mini: Apple M1, 16GB

Networking Gear & Setup Details

Huawei DN8245V-12 router.

Connected Audio Devices

Ethernet connection to SOtM sMS-200 connected via USB to HoloAudio Spring KTE Level 3

Number of Tracks in Library


Description of Issue

Until recently I have been using a legacy Mac Mini (as per the description above) as both my work-from-home computer and my Roon core.

I recently bought an M1 Mac Mini to use as my new work-from-home computer, thus releasing the legacy Mac Mini for service purely as the Roon core.

It all works fine, as to be expected. However the Roon installed on the M1 Mac Mini does not see the legacy Mac Mini Roon core, no matter how many times I re-install or restart the respective machines.

In fact the M1 Mac Mini will start as a Roon core and it functions entirely independently of the core on the legacy Mac Mini. In other words I can be playing via the core on the on the legacy machine, pause that stream, and start an entirely different stream on the Mi Mini and it works as if there are two cores coexisting on the one network. I’m pretty sure I’m only paying for one core.

All machines are on the same network and visible to each other. Everything connected via WiFi (except for the ethernet connection between the router and the SOtM streamer).

The question is how do I get the M1 Mac to attach itself to the Roon core on the legacy Mac Mini so I have just one core?

Settings > General and click the " X Disconnect" link in the connected Core panel to display the list of running Cores present in your network. Then choose the Core you want to connect to.

1 Like

Hi there. I do that but the only Roon core that shows as available is ‘This Mac’ ie the M1 Mac. It does not see the legacy Mac Mini which is the actual and intended core.

And have you got the Roon Core actively running on your legacy Mac Mini? And is it the all-in-one version of Roon, or have you installed and set up Roon Server on the Mac Mini (which would be a better fit for the scenario that you seem to be aiming for)?

Hi Geoff - yes I do have Roon core running on the legacy Mac - and it’s visible as core via my laptop and phone. It’s the all-in-one version but I take your point on the server version ands will give that a try. It’s nighttime here now so I’ll give it a go tomorrow and come back with the findings. Again, my appreciation for your help.


OK, so good news/frustrating news.

Yes, installing Roon Server did the trick and everything saw the server at the correct IP address and everything worked fine. The wrinkle is that I control simple Roon playback functions from my desk using Streamdeck. It’s incredibly convenient and useful. Streamdeck sees Roon Core but for some reason cannot see Roon Server. So I go back and reinstall core onto the legacy mac and the previous situation repeats - the new M1 Mac Mini cannot see the core running on the legacy Mac Mini, every other device sees it just fine.

I don’t understand how the M1 Mac Mini cannot see a core that other devices see perfectly well. Perhaps I’ll just have to live with it.

Did you install Roon from scratch on the new machine or use a migration tool?

Originally it came over as part of the migration. Once the issue arose I deleted it from Applications and then did a clean reinstall. The problem has persisted. It can see Roon Server on the legacy mac, but not Roon Core.

Hi @Michael_Rowe2 ,

Apologies for the delay in getting back to you here. Are you still seeing this issue at the present time?

I suspect this might be the issue here, I’ve PM’d you with a reset procedure you can try to see if it helps.

Yes! It has worked. Many thanks for getting back to me. Great to be back to having a single core across all the machines.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.